[Core 106] DNS Probleme

Hierhin gehören Lösungen für Probleme!
sxfire01
Posts: 19

Re: [Core 106] DNS Probleme

Postby sxfire01 » January 11th, 2017, 2:03 pm

Ab welcher Core-Version wird den nun "unbound" verwendet?
Wir müssen wohl leider auf die zuletzt funktionierende Version zurücksteigen und das Ersatzgerät
vorbereiten. >:(
Das Produktivgerät hat ja noch Core 102.
(Hab leider nicht die Zeit um da 3 Stunden herumzuprobieren und
das Erstzgerät muss ja auch wieder mal Einsatzfähig werden.)

Danke

DJ-Melo
Posts: 277

Re: [Core 106] DNS Probleme

Postby DJ-Melo » January 11th, 2017, 2:25 pm

siehe http://www.ipfire.org/news/ipfire-2-19- ... 6-released seit Core 106.

macht mal nen Bugreport sonst geht das bei den "Codequälern" unter.

Gruß

User avatar
Massaguana
Posts: 265
Location: AbbelwoiTown

Re: [Core 106] DNS Probleme

Postby Massaguana » January 30th, 2017, 3:01 pm

Wie Prüfe ich denn ob ich auch von diesem Problem betroffen bin?

Ich habe seit längeren Problem mit der DNS Auslösung die scheinbar nichts mit dem Verwendetem DNS Server zu tun haben. Es macht jedenfalls kein Unterschied welchen ich nutze...

Problem:

Zeitweise können vereinzelte URL´s nicht aufgelöst werden, per VPN oder direkt am Modem geht es aber...

Betroffene URL´s:

rclone.org, accounts.quickclickhosting.com

Im Browser erscheint als Fehlermeldung: "ERR_NAME_NOT_RESOLVED"

Viele Grüße

Massaguana
Image


m0535
Posts: 4

Re: [Core 106] DNS Probleme

Postby m0535 » February 1st, 2017, 3:26 pm

Hi Leute,
ich lese schon seit längerem hier mit. Leider konnte ich das "Problem" bei mir auch nicht in den Griff bekommen.
Ich habe meine 108 jetzt platt gemacht und werde zurück auf die 105 gehen. Leider.
Hoffentlich gibt es bald eine durchgängige Lösung die man umsetzten kann. Mir fehlt leider auch die Zeit hier hier gossartig zu debuggen um die Probleme irgendwie herauszukonfigurieren ...
viele Grüsse.

DJ-Melo
Posts: 277

Re: [Core 106] DNS Probleme

Postby DJ-Melo » February 5th, 2017, 1:06 pm

Testet mal bitte core 109 ob es besser wird.

Purzel
Posts: 8

Re: [Core 106] DNS Probleme

Postby Purzel » February 5th, 2017, 2:22 pm

DJ-Melo wrote:Testet mal bitte core 109 ob es besser wird.


109 ist noch nicht draussen, zumindest wird es nicht gefunden mit Pakfire!

ummeegge
Community Developer
Community Developer
Posts: 3976

Re: [Core 106] DNS Probleme

Postby ummeegge » February 5th, 2017, 3:07 pm

Hallo zusammen,
Core 109 ist im testing tree zu finden --> http://planet.ipfire.org/post/ipfire-2- ... or-testing .
Wie du in den testing wechseln kannst findest du hier --> http://wiki.ipfire.org/en/configuration ... re/testing .

UE
Image
Image
Image

G666
Posts: 11

Re: [Core 106] DNS Probleme

Postby G666 » February 6th, 2017, 4:35 pm

Ich habe mein IPfire System neu aufgesetzt (wechsle von 32 zu 64bit) und auch ich hatte das Problem das keine Namensauflösung über IPfire lief. Mit meiner alten 32bit 108 Version gab es keine Probleme. Ich hatte das Problem umgangen indem ich per DHCP einen zweiten alternativen DNS Server vergeben habe.
Mit den Update auf 109 läuft bei mir DNS über IPfire auf alle fälle wieder.
"DNS-Server: local recursor" steht aber immer noch auf der Startseite.
Image

Purzel
Posts: 8

Re: [Core 106] DNS Probleme

Postby Purzel » February 18th, 2017, 3:10 pm

G666 wrote:Mit den Update auf 109 läuft bei mir DNS über IPfire auf alle fälle wieder.
"DNS-Server: local recursor" steht aber immer noch auf der Startseite.


Bei mir funktioniert es trotz Update auf 109 immer nocht nicht, Aber die Fehlermeldungen sind weg bzgl. local recursor!

Hellfire
Posts: 204

Re: [Core 106] DNS Probleme

Postby Hellfire » February 18th, 2017, 3:17 pm

Während Core 108 (64bit) bei mir noch problemlos lief, fingen sich die Problem mit DNS prompt nach dem Update auf Core 109 jetzt an.

Natürlich stand auch bei mir dieses local recursor im WebIF und ich musste die Kabel Deutschland DNS-Server gegen neue aus der Liste der freien Server tauschen: 62.113.203.55 und 62.113.203.99.

Im Log des Unbound stehen allerdings jetzt solche Geschichten wie
16:06:50 unbound: [26438:0] info: validation failure isatap.ourhome. A IN
16:02:33 unbound: [26438:0] info: validation failure eu.static.mega.co.nz. A IN
16:02:10 unbound: [26438:1] info: validation failure http. AAAA IN
16:02:10 unbound: [26438:1] info: validation failure http. A IN
16:00:45 unbound: [26438:1] info: validation failure g-25.0.threema.ch. A IN
16:00:45 unbound: [26438:0] info: validation failure g-25.0.threema.ch. A IN
15:59:49 unbound: [26438:1] info: validation failure g-25.0.threema.ch. A IN
15:44:43 unbound: [26438:1] info: validation failure http. AAAA IN
15:44:43 unbound: [26438:1] info: validation failure http. A IN
15:15:49 unbound: [26438:0] info: validation failure g-25.0.threema.ch. A IN
15:02:33 unbound: [26438:1] info: validation failure eu.static.mega.co.nz. A IN
15:02:03 unbound: [26438:1] info: validation failure http. AAAA IN
14:45:12 unbound: [26438:1] info: validation failure http. AAAA IN
14:34:43 unbound: [26438:1] info: validation failure http. AAAA IN
14:15:42 unbound: [26438:0] info: start of service (unbound 1.6.0).

mit denen ich nicht anfangen kann. Aktuell kann ich meine Postfächer bei Goneo.de nicht abfragen.

Weiß nicht ob es ein temporärers Problem ist nicht. Ich bin schon fast daran meine VM wieder au Core 108, per Snapshop-Restore, zurückzusetzen.

Das ist mir nämlich alles nicht Wert, dass es ohne die beiden neuen DNS-Server ersten sehr zäh bis gar nicht läuft und offensichtlich trotz der neuen DNS-Server immer noch nicht alles funktioniert.
Grüße,
Michael
Image

Hellfire
Posts: 204

Re: [Core 106] DNS Probleme

Postby Hellfire » February 19th, 2017, 9:16 am

Habe nach dem Revert auf Core108 festgestellt, dass da auch local recursor bereits in den Infos zum (KabelDeutschland) Provider drin stand, nur alles läuft wie erwartet schnell und ohne Probleme.

Tatsache ist, dass es mit Core 109, direkt nach dem Update (Kein Neustart angefordert/durchgeführt), sehr zäh bis gar nichts mehr lief und erst nachdem ich die beiden alternativ DNS aus Liste der freien DNS-Server eingefügt hatte, gings wieder einigermaßen. Ich habe diese direkt im WebIf und nicht im Setup über die Konsole eingetragen. Weiß nicht, ob dies eine Rolle spielte. Das war bereits gestern und ohne Neustart des IPFire, jedoch einen Reconnect zu KD veranlaßt.

Nur bekam ich heute die Rückmeldung von der Familie, dass bspw. Seiten wie wetter.de, pnp.de oder die Online-Banking Seite der Sparkasse nicht mehr aufrufbar sind. Das sind aber nur einige der Beispiele.
Also wieder zurück auf Core 108 und einen Reboot durchgeführt, sowie auf meinem PC ein IPCONFIG /RENEW, weil es hier Probleme gabr bereits forum.ipfire.org zu erreichen. Auf den anderen PCs im heimischen Netzwerk, keine Probleme. Die waren auch noch nicht eingeschaltet als ich auf Core 108 zurück bin. Denke auf meinem PC war noch der alte DNS präsent.

Aynway, schwierige Situation. Core 109 kommt für mich jetzt erst Mal nicht mehr in Frage. Ich frage mich jedoch, ob ich jemals wieder Updaten kann. Wieso ist das so problembehaftet? Gut Kabel Deutschland hat offensichtlich keine erforderlichen DNS-Server, aber es kann doch nicht sein, dass ich jetzt gezwungen werden irgendwelche DNS-Server zu verwenden, denen ich vllt. auch nicht vertrauen kann. Da sind mir die vom Provider schon lieber und dann halt nur mit Core 108.

Ich geb't noch nicht auf ;-) Core 109: nachdem ich nun diverse DNS Server ausprobiert habe, bin ich bei diesen beiden hier gelandet: 130.180.32.59 und 89.238.65.191 die beiden DNSSEC unterstützen.
Nur eine zeitlang funktioniert die Namensauflösung, bspw. im Firefox, ein anders Mal kann Thunderbird die diversen IMAP Server (GMX, Goneo.de) nicht mehr erreichen. Das hat aber keine Methode, denn irgendwann findet Firefox bspw. forum.ipfire.org nicht mehr mehr, während Thunderbird aber keinerleie Problem aufzeigt. Und so zieht sich das Probieren hin wie ein Kaugummi. Ich suche dann wieder andere freie DNS Server, aber auch die funktionieren dann wieder nicht zuverlässig.

Ich weiß nicht was hier falsch läuft. Ich blockiere keine DNS Aufrufe in der Firewall noch treibe ich sonst irgendetwas Außergewöhnliches. Bevor ich auf Core 109 ging hatte ich, wie geschrieben Core 108, aber es lief. Obwohl ich wieder auf Core 108 zurück bin, läufts jetzt auf einmal auch nicht mehr 100%ig zuverlässig.
Local recursor steht auch hier an bekannter Stelle, wobei dies sehr wahrscheinlich auch schon vor Upd 109 dort stand aber ich halt nicht nachgesehen habe.

Michael
Image

Hellfire
Posts: 204

Re: [Core 106] DNS Probleme

Postby Hellfire » February 19th, 2017, 12:00 pm

Ist das eigentlich normal, dass beim TRACERT (auf einer win10 Maschine) auf diverse Adressen immer eine Zeitüberschreitung ausgegeben wird:

C:\Users\Michael>tracert imap.gmx.net

Routenverfolgung zu imap.gmx.net [212.227.17.186]
über maximal 30 Hops:

1 <1 ms <1 ms <1 ms ipfire.ourhome [192.168.0.1]
2 * * * Zeitüberschreitung der Anforderung.
3 8 ms 9 ms 8 ms ip5886dfbe.static.kabel-deutschland.de [88.134.223.190]
4 17 ms 18 ms 17 ms ip5886c274.static.kabel-deutschland.de [88.134.194.116]
5 18 ms 21 ms 17 ms ip5886cb00.static.kabel-deutschland.de [88.134.203.0]
6 27 ms 26 ms 27 ms ip5886cbe5.static.kabel-deutschland.de [88.134.203.229]
7 29 ms 28 ms 26 ms ip5886ca25.static.kabel-deutschland.de [88.134.202.37]
8 25 ms 24 ms 24 ms decix.bb-a.fra3.fra.de.oneandone.net [80.81.192.123]
9 24 ms 27 ms 32 ms ae-1.bb-c.act.fra.de.oneandone.net [212.227.120.90]
10 41 ms 29 ms 29 ms ae-11.bb-c.bs.kae.de.oneandone.net [212.227.120.18]
11 27 ms 27 ms 27 ms ae-1-0.gw-diste2-b.bs.kae.de.oneandone.net [212.227.121.213]
12 34 ms 31 ms 32 ms imap.gmx.net [212.227.17.186]

Ablaufverfolgung beendet.

C:\Users\Michael>tracert gmx.de

Routenverfolgung zu gmx.de [82.165.229.87]
über maximal 30 Hops:

1 <1 ms <1 ms <1 ms ipfire.ourhome [192.168.0.1]
2 * * * Zeitüberschreitung der Anforderung.
3 8 ms 8 ms 9 ms ip5886dfbe.static.kabel-deutschland.de [88.134.223.190]
4 19 ms 17 ms 17 ms ip5886c274.static.kabel-deutschland.de [88.134.194.116]
5 21 ms 21 ms 22 ms ip5886cb84.static.kabel-deutschland.de [88.134.203.132]
6 27 ms 27 ms 26 ms ip5886ca36.static.kabel-deutschland.de [88.134.202.54]
7 24 ms 24 ms 24 ms ip5886ca25.static.kabel-deutschland.de [88.134.202.37]
8 21 ms 22 ms 21 ms decix.bb-a.fra3.fra.de.oneandone.net [80.81.192.123]
9 22 ms 21 ms 21 ms ae-1.bb-c.act.fra.de.oneandone.net [212.227.120.90]
10 31 ms 26 ms 32 ms ae-11.bb-c.bs.kae.de.oneandone.net [212.227.120.18]
11 30 ms 24 ms 23 ms ae-0-0.gw-diste2-b.bs.kae.de.oneandone.net [212.227.116.213]
12 30 ms 34 ms 30 ms redir-bs.web.de [82.165.229.87]

Ablaufverfolgung beendet.
C:\Users\Michael>

Dabei spielt es keine Rolle, ob es nun die Server der E-Mail Provider sind, oder bspw. bmw.de.
Die Wartezeit verursacht, meinem laienhaften Wissen nach, immer IPFire. Zumindest deute ich dies so, dass immer im Step 2 der Timeout auftritt.

Und gerade während ich auf den Submit Knopf hier drücke, bekomme ich wieder im Firefox einen Timeout. Ein parallel gestarteter Ping im CMD-Fenster brachte dann Folgendes zurück:
C:\Users\Michael>ping forum.ipfire.org

Ping wird ausgeführt für web01.ipfire.org [81.3.27.41] mit 32 Bytes Daten:
Zeitüberschreitung der Anforderung.
Zeitüberschreitung der Anforderung.
Zeitüberschreitung der Anforderung.
Antwort von 192.168.21.1: Zielhost nicht erreichbar.

Ping-Statistik für 81.3.27.41:
Pakete: Gesendet = 4, Empfangen = 1, Verloren = 3
(75% Verlust),

Das ist doch nicht normal, oder?

Michael
Image

User avatar
FischerM
Community Developer
Community Developer
Posts: 565

Re: [Core 106] DNS Probleme

Postby FischerM » February 19th, 2017, 7:37 pm

Ahmt,

nein, das ist IMHO nicht normal - allerdings habe ich leider keine Lösung für dich. Ich trau mich trotzdem.

Ich kann nur beschreiben, unter welchen Umständen es hier ohne weitere Probleme - auch nach der Umstellung auf 'unbound' - funktioniert:

ISP (Telekom) <-> Fritzbox 7272 <-> IPFire Core 109 (an FB per 'exposed host' mit statischer IP an RED) <-> GREEN an Haus-Switch <-> internes LAN

Eingerichtet wurde in etwa so wie hier beschrieben. Der einzige Unterschied: ich habe sowohl der FB als auch dem IPFire die beiden DNS-Server von DNS.Watch zugewiesen, nachdem es mit der DNS-Zuweisung in Richtung der FB auf einmal nicht nachvollziehbare Probleme gab.

Ergebnis (Win7-Maschine/32bit):

Code: Select all

c:\>tracert imap.gmx.net

Routenverfolgung zu imap.gmx.net [212.227.17.186] über maximal 30 Abschnitte:

  1    <1 ms    <1 ms    <1 ms  ipfire.localdomain [192.168.XX.YYY]
  2    <1 ms    <1 ms    <1 ms  192.168.YY.XXX
  3     6 ms     5 ms     5 ms  217.0.117.111
  4     7 ms     7 ms     7 ms  87.190.166.106
  5    47 ms    95 ms    97 ms  bn-sb2-i.BN.DE.NET.DTAG.DE [62.154.66.149]
  6     9 ms     8 ms     8 ms  217.239.39.26
  7     9 ms    14 ms     9 ms  62.157.249.74
  8    11 ms    14 ms    11 ms  ae-11.bb-c.bs.kae.de.oneandone.net [212.227.120.18]
  9    12 ms    12 ms    11 ms  ae-0-0.gw-diste2-b.bs.kae.de.oneandone.net [212.227.116.213]
 10    11 ms    11 ms    11 ms  imap.gmx.net [212.227.17.186]

Ablaufverfolgung beendet.


Die einzige Seite, die momentan partout nicht mehr geht, ist witzigerweise ausgerechnet die von 'dnsmasq'.

Wenn ich Deine mit meinen Ergebnissen vergleiche, hätte ich bei den bisher vorliegenden Informationen Deinen Provider im Verdacht. Aber was da schief läuft, übersteigt leider mein Hintergrundwissen.

Gruß,
Matthias


Return to “Problemlösungen”



Who is online

Users browsing this forum: No registered users and 1 guest