Failed to mount ext2 filesystem...

Probleme bei der Installation?
Post Reply
user6789
Posts: 7
Joined: November 30th, 2016, 10:36 am

Failed to mount ext2 filesystem...

Post by user6789 » December 31st, 2016, 9:41 am

Hi forum,

Ich versuche ipfire auf meinen R1 router boardd laufen zu lassen und habe mal folgende versionen
auf meiner sdkarte ausprobiert
ipfire-2.19-core108 und ipfire-2.19-core106

in beiden faellen

Code: Select all

ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree
reading boot.scr
** Unable to read file boot.scr **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
reading script.bin
** Unable to read file script.bin **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
bekamm ich oben stehende fehler meldung.
Ist das ein fehler den ich selber an image flicken kann oder koennte es an der sd karte liegen?
Thx, user 6789

User avatar
Arne.F
Core Developer
Core Developer
Posts: 7366
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Failed to mount ext2 filesystem...

Post by Arne.F » December 31st, 2016, 2:42 pm

make sure that the ipfire image is copied to the whole card not to a partition and that no partition of the cards are mounted at write of the image.

Use a editor that support unix textformat to edit the uEnv.txt (I use Notepad++ on windows)
Arne

Support the project on the IPFire whishlist!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

user6789
Posts: 7
Joined: November 30th, 2016, 10:36 am

Re: Failed to mount ext2 filesystem...

Post by user6789 » January 1st, 2017, 9:36 am

Ich verwende eine 4gb micro sd karte von kingston HC class 10

Und bereite dise mit SDFormatter vor.
Die einstellungen sind wie folgt
Format tpye = FULL (Erase)
Format Size Adjustment = (ON)

Danach spiele ich das image mit Win32 DiskImager rauf,
ganz ohne speziele optionen.

Wenn ich an dieser stelle die partionen auf der SD Karte mir anschaue, kann ich folgende partionen sehen.
Eine 60MB FAT, Primary
Eine 750MB Ext4, Primary
2.91 Unallocated, Logical

In naechsten schritt editire ich die datei uENV.TXT mit Notepad++

und modiefiziere die stelle sun7i-a20-bananapi.dtb zu sun7i-a20-lamobo-r1.dtb,

danach speichere ich die txt datei
und lege die sd karte in meinen banana pi r1 und starte ihn.

User avatar
Arne.F
Core Developer
Core Developer
Posts: 7366
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Failed to mount ext2 filesystem...

Post by Arne.F » January 11th, 2017, 3:23 pm

Mhh. Das sieht alles korrekt aus. Hast du mal versucht ohne die uENV.txt zu bearbeiten zu booten. Da erkennt er dann den Netzswitch chip nicht und hat daher nur ein nicht nutzbares Interface aber das board sollte booten.
Arne

Support the project on the IPFire whishlist!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest