LEDs Alix nach upgrade auf 66

Hierhin gehören Lösungen für Probleme!
joerich
Posts: 5

LEDs Alix nach upgrade auf 66

Postby joerich » February 23rd, 2013, 12:40 pm

Nach dem upgrade auf Version 66 funktionieren meine LEDs nicht mehr auf meinem Alix 3d13.
Ist das bei euch aus so? Upgrade sollte ohne Fehler durchgelaufen seinen (denke ich zumindestens).

Es gab im Webif keine Fehlermeldung.

BeBiMa
Posts: 2087
Location: Mannheim

Re: LEDs Alix nach upgrade auf 66

Postby BeBiMa » February 23rd, 2013, 2:20 pm

Beim Alix solten noch einige Module in /etc/sysconfig/modules eingetragen werden. Mein File enthält folgendes:

Code: Select all

### ACPI
#
ac
battery
button
fan
processor
thermal
video

### cs5535
#
gpio_cs5535

### parport
#
parport_pc
lp

### fusion
# fusion

### cryptodev
#
cryptodev

### sensors
#
i2c_dev
lm90


Für die Leds ist gpio_cs5535 wichtig, nur wenn dies geladen ist, lädt auch leds_gpio.
i2c_dev ist für lm90 nötig. Damit können auch die Temperatursensoren gelesen werden.
SNORT ist Mord!
Image
KabelBW Cable Internet ( 32MBit )
Meine Stadt

joerich
Posts: 5

Re: LEDs Alix nach upgrade auf 66

Postby joerich » February 25th, 2013, 8:46 am

Danke das war's schon. LEDs gehen wieder. Bei update wurde bestimmt die /etc/sysconfig/modules verändert.

Jetzt blinkt zwar meine Power-LED statt dauerhaft zu leuten, aber so ist auch nicht schlecht.

Danke

BeBiMa
Posts: 2087
Location: Mannheim

Re: LEDs Alix nach upgrade auf 66

Postby BeBiMa » February 25th, 2013, 8:58 am

Im Kernel 2.xx war der Zugriff auf die LEDs noch etwas anders. Die Funktionen konnten einzeln gesetzt werden. So behielt die LED1 ihre Funktion aus dem BIOS: Power ON.
Mit Kernel 3.xx werden die LEDs insgesamt vom Modul verwaltet.
In der Grundkonfig liegt nun bei IPFire auf LED1 der Heartbeat.
SNORT ist Mord!
Image
KabelBW Cable Internet ( 32MBit )
Meine Stadt

sysrunner
Posts: 21

LED1 ( Alix) beim Herunterfahren ausschalten

Postby sysrunner » August 7th, 2013, 8:42 am

Hallo,
ich möchte das Thema in diesem Thread noch einmal aufgreifen. Könnte mir jemand einen Tipp für folgende Fragestellung geben:

Am Alix-Board soll LED1 beim Herunterfahren erst ausgeschaltet werden, nachdem die Dateisysteme (bzw. das root-FS) ausgehangen sind. So hat man ein eindeutiges Zeichen, wann man die Box gefahrlos vom Netz trennen kann. Hat jemand diese oder eine ähnliche Lösung in einem init-Skript zum Starten/Stoppen der alix-leds schon implementiert? Falls ja, wie müßte dann das Skript aussehen? Aktuell schaltet LED1 schon aus, bevor das Filesystem ausgehangen ist, was aber erst erst nach ca. 20-30s der Fall ist.

Besten Dank.
Last edited by sysrunner on August 7th, 2013, 8:47 am, edited 1 time in total.

User avatar
Arne.F
Core Developer
Core Developer
Posts: 5661
Location: BS <-> NDH
Contact:

Re: LEDs Alix nach upgrade auf 66

Postby Arne.F » August 7th, 2013, 11:30 am

Du musst /etc/init.d/led so anpassen das es bei stop die entsprechende LED nach dem abschalten der led_trigger die LED einschaltet.

Code: Select all

      echo "1" >        /sys/class/leds/alix:1/brightness


Edit: Fix typo ;)
Last edited by Arne.F on August 7th, 2013, 12:48 pm, edited 1 time in total.
Arne

Support the project on the IPFire whishlist!

Image

Image

Image

sysrunner
Posts: 21

Re: LEDs Alix nach upgrade auf 66

Postby sysrunner » August 7th, 2013, 12:45 pm

Funktioniert, vielen Dank für den Support!
Für diejenigen, die eine ähnliche Funktion mit dem Alix nutzen möchten, steht dann der von Arne erwähnte Eintrag wie folgt in der /etc/init.d/leds:

stop)
    # ALix LED stop
    disable_led_trigger alix:1
    echo "1" > /sys/class/leds/alix:1/brightness
    disable_led_trigger alix:2
    disable_led_trigger alix:3


Mit dem Einschalt-Befehl leuchtet die LED1 noch so lange weiter, bis das System endgültig heruntergefahren ist. Danach kann man die Alix-Box vom Netz trennen.

morlix
Community Developer
Community Developer
Posts: 147

Re: LEDs Alix nach upgrade auf 66

Postby morlix » August 8th, 2013, 4:49 am

Super Idee, das sollte man meiner Meinung nach zum default Verhalten machen.

Gruß morlix
Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 5661
Location: BS <-> NDH
Contact:

Re: LEDs Alix nach upgrade auf 66

Postby Arne.F » February 17th, 2014, 3:31 pm

Kommt mit 2.15 beta2. (Auch die Module werden mit dem neuen udev wieder automatisch geladen.)
Arne

Support the project on the IPFire whishlist!

Image

Image

Image


Return to “Problemlösungen”



Who is online

Users browsing this forum: No registered users and 1 guest