Search found 6 matches

by mpyusko
July 12th, 2019, 10:39 pm
Forum: IPFire in General
Topic: Block active LAN user from internet
Replies: 2
Views: 397

Block active LAN user from internet

So my son got himself in trouble, so I've decided to block his computer from the Internet. He's mid-game, so I'm expecting to hear screams, but nothing is happening. Rule is configured... Screenshot_20190712-183226_Firefox.jpg ..and I apply the new rule. The one above it is a deactivated rule to blo...
by mpyusko
August 12th, 2018, 8:46 am
Forum: IPFire in General
Topic: 300Mbit Connection but only 100Mbit through ipfire
Replies: 10
Views: 1641

Re: 300Mbit Connection but only 100Mbit through ipfire

If, by chance, you are using the e10003 driver, (Intel PCIe Gigabit NICs) then this is what solved it for me..... (Reference HERE ) ethtool -K green0 gso off gro off tso off ethtool -K red0 gso off gro off tso off ethtool -K blue0 gso off gro off tso off ethtool -K orange0 gso off gro off tso off No...
by mpyusko
July 23rd, 2018, 6:04 am
Forum: IPFire in General
Topic: NIC hangs, then resets during speedtest, high throughput.
Replies: 8
Views: 1625

Re: NIC hangs, then resets during speedtest, high throughput.

Code: Select all

ethtool -K green0 gso off gro off tso off
Seemed to fix it. I'm not sure about the performance hit though, if any. It pegs the line and that's all I can ask for right now.

Thank you.
by mpyusko
July 22nd, 2018, 5:58 pm
Forum: IPFire in General
Topic: NIC hangs, then resets during speedtest, high throughput.
Replies: 8
Views: 1625

Re: NIC hangs, then resets during speedtest, high throughput.

echo "blacklist e1000e" >> /etc/modprobe.d/blacklist echo e1000 >> /etc/sysconfig/modules cd / var/ipfire/ethernet edited "settings", changed e1000e to e1000 edited "scanned_nics", changed e1000e to e1000 Rebooted. Intel NICs were not found. modprobe e1000e detected the NICs. Even running the setup...
by mpyusko
July 20th, 2018, 2:21 pm
Forum: IPFire in General
Topic: NIC hangs, then resets during speedtest, high throughput.
Replies: 8
Views: 1625

Re: NIC hangs, then resets during speedtest, high throughput.

That's interesting. I think you might be right. It certainly feels like a driver issue. A quick lsmod on the production fw shows it is using the e1000 driver.

Thanks,
by mpyusko
July 19th, 2018, 11:00 pm
Forum: IPFire in General
Topic: NIC hangs, then resets during speedtest, high throughput.
Replies: 8
Views: 1625

NIC hangs, then resets during speedtest, high throughput.

Home = 400 Mbps x 25 Mbps (peaks at 480x35) Rack = 1Gbps connection ("iperf3 -s" and Speedtest.net are available at this data center.) ipfire (core 120)is running on: Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz Intel DG31PR Motherboard 2GB DDR @ 667 MHz Seagate Barracuda 7200.10 250 GB 04:00.1 Ethe...