Search found 662 matches

by trymes
December 17th, 2019, 6:15 pm
Forum: IPFire in General
Topic: IPFire 2.19 Core 105 Wireless Problem
Replies: 7
Views: 2078

Re: IPFire 2.19 Core 105 Wireless Problem

UPDATE: I was able to resolve this (years later) by downloading an RPM of a 32-bit (this is a 32-bit machine) rfkill binary for another linux distro. I then used 7-zip to extract the RPM file to a CPIO file, and then used 7-zip to extract the CPIO file. I then copied the files over to the system usi...
by trymes
May 14th, 2019, 8:43 pm
Forum: IPFire in General
Topic: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface
Replies: 37
Views: 14956

Re: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface

Have you confirmed that DHCP is running on the blue interface?
by trymes
May 14th, 2019, 6:34 pm
Forum: IPFire in General
Topic: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface
Replies: 37
Views: 14956

Re: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface

Have you added the device to the Blue Access list? You will not be able to access the network (you can join, but not send traffic) until you add it as an allowed device on the Blue Access list, or alternatively, you can add the entire subnet and devices will automatically be permitted on the network...
by trymes
May 13th, 2019, 9:59 pm
Forum: IPFire in General
Topic: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface
Replies: 37
Views: 14956

Re: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface

Since this thread was originally started, the kernel and firmware in IPFire has been updated, and support for this chipset is built-in.

If you read the error you are getting, it says that channel 6 is not supported for mode 802.11a.

I would try selecting 802.11g and see what you get.


Tom
by trymes
February 26th, 2019, 3:52 am
Forum: IPFire in General
Topic: IPsec VPN Advanced Settings do not save
Replies: 4
Views: 426

Re: IPsec VPN Advanced Settings do not save

Well, this shouldn't be happening, so do narrow it down and confirm that it happens on different machines and different browsers, then be certain to report a bug if you are able to confirm it.

On a side note, why are you using IKEv1? It's outdated and you should use IKEv2 where possible.
by trymes
December 11th, 2018, 11:35 pm
Forum: Installation
Topic: Upgrade to 122 leaves me at a grub prompt
Replies: 7
Views: 1879

Re: Upgrade to 122 leaves me at a grub prompt

What did you do to manually boot the kernel? EDIT: Nevermind, I figured it out, with help from this page: https://www.linux.com/learn/how-rescue-non-booting-grub-2-linux%20%20 Basically, I used these commands, I don't know if installations on other hardware will vary: grub> set root=(hd0,1) grub> li...
by trymes
November 13th, 2018, 2:35 pm
Forum: IPFire in General
Topic: DNS IpFire and DNS Windows Server
Replies: 9
Views: 1189

Re: DNS IpFire and DNS Windows Server

There is no need to remove IPFire from the network, just set it up so it is no longer the DHCP server for the network, and have Windows act as the DHCP server. Then have the DHCP server provide the Windows DNS as the DNS server. By default, most routers perform many tasks: routing, DNS, DHCP, VPN, e...
by trymes
November 13th, 2018, 11:48 am
Forum: IPFire in General
Topic: telnet: libncurses error
Replies: 0
Views: 386

telnet: libncurses error

I have installed telnet via pakfire, and on one machine it has stopped working. I get this error:

Code: Select all

telnet: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory
Removing and reinstalling telnet via pakfire did not help.

Any ideas?

Tom
by trymes
November 13th, 2018, 11:45 am
Forum: IPFire in General
Topic: DNS IpFire and DNS Windows Server
Replies: 9
Views: 1189

Re: DNS IpFire and DNS Windows Server

If you are running an Active Directory server behind an IPFire box, the easiest way is to turn off DHCP on the IPFire box and have the Windows AD Domain Controller handle DNS and DHCP. Configure the Windows DNS service to use IPFire as the server it asks when it doesn't know an address - you do this...
by trymes
August 10th, 2018, 5:56 pm
Forum: IPFire in General
Topic: Issue with IPSec after upgrade to Core 122?
Replies: 5
Views: 974

Re: Issue with IPSec after upgrade to Core 122?

Whoops! This is a net to net connection.
by trymes
August 10th, 2018, 3:14 pm
Forum: IPFire in General
Topic: Issue with IPSec after upgrade to Core 122?
Replies: 5
Views: 974

Re: Issue with IPSec after upgrade to Core 122?

Whoa. How many cups of coffee have you had? 122 isn't beta, it has been released, though I see that hasn't been posted to planet.ipfire.org. No Squid, and everything works fine, with the exception of one IPSec tunnel with many individual hosts configured in the local subnets field. Given that there ...
by trymes
August 8th, 2018, 2:34 am
Forum: IPFire in General
Topic: Issue with IPSec after upgrade to Core 122?
Replies: 5
Views: 974

Issue with IPSec after upgrade to Core 122?

I know that there were a handful of IPSec related changes for core 122, specifically with regard to multiple defined subnets. I am having issues with one of my tunnels, and was hoping to find if the issue is on my end or if there is a problem with the newly introduced changes. I have one tunnel that...
by trymes
August 3rd, 2018, 1:12 pm
Forum: IPFire in General
Topic: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface
Replies: 37
Views: 14956

Re: Compex WLE600VX Wlan (ath10k - Atheros QCA9882) not detected for Blue Interface

I would run setup from the command line, remove the blue interface and reassign it to the card.
by trymes
May 24th, 2018, 10:27 am
Forum: IPFire in General
Topic: Regenerating OpenVPN certificates
Replies: 3
Views: 673

Re: Regenerating OpenVPN certificates

As far as I can see, there is no way to do that via the WUI, so my only option is to delete the entry and re-create it?
by trymes
May 23rd, 2018, 11:18 am
Forum: IPFire in General
Topic: Regenerating OpenVPN certificates
Replies: 3
Views: 673

Regenerating OpenVPN certificates

So, I had an OpenVPN user that was unable to connect, and after digging through the logs (it was far from obvious), it became clear that the certificate for that user had expired.

So, what is the right way to generate new certificates when they expire?

Tom