Verbindungen über RED sehr langsam nach Update 125

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 3rd, 2018, 6:42 am

Hallo Zussamen,

ich betreibe nun schon seit ein paar Jahren meinen IPFire recht problemlos mit allen 4 Interfaces (RED/GREEN/BLUE/ORANGE - DMZ). Aber seit dem Update 125 am Freitag 30.11.2018 habe ich folgendes Problem:
* Verbindungen aus den Netzen GREEN/BLUE/Orange nach außen über RED sind sehr langsam. Als wirklich ca. Faktor 1000 langsamer als sie sein sollten.

Es liegt nicht an Problemen im RED Netzwerk oder mit dem RED Interface. Wenn ich auf dem IPFire via SSH eingeloggt, etwa via wget etwas runter lade, so habe ich die normale Geschwindigkeit. Lade ich jedoch von einem Client in einem der internen Netze etwas runter so habe ich nur noch etwa 1/1000 der Download Rate als wenn ich den gleichen Download auf IPFire direkt mache.
Es liegt aber auch nicht an den Internen Neten oder den Interfaces. Verbindungen etwa zwischen GREEN und ORANGE erreichen auch die volle Bandbreite.
Am Anfang dachte ich, dass auf dem IPFire ein Prozess amog läuft und alle Leistung frist, so dass für das NAT nichts mehr bleibt. Aber auch das passt nicht, da htop auf IPFire zeigt, dass sich CPU/RAM und Disk langweilen während ich etwas mit einem Client aus dem externen Netz lade.

Hat jemand eine Idee, was da los sein könnte?

Danke schon mal
Imker

User avatar
Arne.F
Core Developer
Core Developer
Posts: 7977
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Verbindungen über RED sehr langsam nach Update 125

Post by Arne.F » December 3rd, 2018, 11:34 am

Hast du mal versucht den Proxy auszuschalten?
Der ist auf jeden Fall im core125 drin.
Arne

Support the project on the IPFire whishlist!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 3rd, 2018, 12:22 pm

Hallo,
Der Proxy Service ist abgeschaltet. Genau so der IDS.

User avatar
Arne.F
Core Developer
Core Developer
Posts: 7977
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Verbindungen über RED sehr langsam nach Update 125

Post by Arne.F » December 3rd, 2018, 1:29 pm

Ohne den Proxy wüste ich erstmal nix was nach dem Update von core124 auf 125 langsamer sein sollte...
Arne

Support the project on the IPFire whishlist!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 3rd, 2018, 10:04 pm

Hallo,

um das PRoblem nochmal zu verdeutlichen hier mal ein paar wget Konsolen Ausgaben:

1) Versuch eines Downloads aus dem Internet (also NAT über das RED Interface) mit einem Client im GREEN Netz:

Code: Select all

wget https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso
--2018-12-03 22:48:10--  https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso
Resolving cdimage.debian.org (cdimage.debian.org)... 194.71.11.165, 194.71.11.173, 2001:6b0:19::173, ...
Connecting to cdimage.debian.org (cdimage.debian.org)|194.71.11.165|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://gensho.ftp.acc.umu.se/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso [following]
--2018-12-03 22:48:11--  https://gensho.ftp.acc.umu.se/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso
Resolving gensho.ftp.acc.umu.se (gensho.ftp.acc.umu.se)... 194.71.11.176, 2001:6b0:19::176
Connecting to gensho.ftp.acc.umu.se (gensho.ftp.acc.umu.se)|194.71.11.176|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 305135616 (291M) [application/x-iso9660-image]
Saving to: ‘debian-9.6.0-amd64-netinst.iso’

debian-9.6.0-amd64-netinst.iso       0%[                                                                 ] 824,00K  14,2KB/s    eta 5h 58m 
 
2) Nun die der gleiche Download auf IPFire, das geht also auch über RED, aber ohne NAT:

Code: Select all

wget https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso
--2018-12-03 22:53:35--  https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso
Resolving cdimage.debian.org... 194.71.11.173, 194.71.11.165
Connecting to cdimage.debian.org|194.71.11.173|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://gensho.ftp.acc.umu.se/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso [following]
--2018-12-03 22:53:35--  https://gensho.ftp.acc.umu.se/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso
Resolving gensho.ftp.acc.umu.se... 194.71.11.176
Connecting to gensho.ftp.acc.umu.se|194.71.11.176|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 305135616 (291M) [application/x-iso9660-image]
Saving to: 'debian-9.6.0-amd64-netinst.iso'

debian-9.6.0-amd64-netinst.iso      12%[=======>                                                         ]  36.05M  2.73MB/s    eta 1m 41s
3) Und nun ein Download von einem Server aus dem ORANGE Netz auf einen Client im GREEN Netz

Code: Select all

wget https://XXXXX.XXX/owncloud/remote.php/webdav/Film/001-Rip/Kino_de/Annas%20Geburtstag%20-%202001/Annas%20Geburtstag.mpeg
--2018-12-03 22:57:27--  http://XXXXX.XXXowncloud/remote.php/webdav/Film/001-Rip/Kino_de/Annas%20Geburtstag%20-%202001/Annas%20Geburtstag.mpeg
Resolving XXXXX.XXX) (XXXXX.XXX)... 192.168.21.4
Connecting to XXXXX.XXX (XXXXX.XXX)|192.168.21.4|:443... connected.
HTTP request sent, awaiting response... 401 Unauthorized
Authentication selected: Basic realm="Nextcloud"
Reusing existing connection to XXXXX.XXX):443.
HTTP request sent, awaiting response... 200 OK
Length: 423350332 (404M) [video/mpeg]
Saving to: ‘Annas Geburtstag.mpeg’

Annas Geburtstag.mpeg               63%[========================================>                        ] 255,47M  50,7MB/s    eta 4s 
Wie schon oben geschrieben, sind hier keine neuen Infrmationen versteckt. Aber ich denke die Zahlen zeigen recht Eindrucksvoll mein Problem.

Und hier noch die Übersicht der auf IPFire gestarteten und gestoppen Services:

Code: Select all

Services 	Status 	PID 	Memory
CRON Server	RUNNING	2842	1888 kB
DHCP Server	STOPPED	
DNS Proxy Server	STOPPED	
Intrusion Detection System (BLUE)	STOPPED	
Intrusion Detection System (GREEN)	STOPPED	
Intrusion Detection System (ORANGE)	STOPPED	
Intrusion Detection System (RED)	STOPPED	
Kernel Logging Server	RUNNING	1548	6412 kB
Logging Server	RUNNING	1555	1740 kB
NTP Server	RUNNING	2698	3092 kB
OpenVPN	STOPPED	
Secure Shell Server	RUNNING	2778	2396 kB
VPN	STOPPED	
Web Proxy	STOPPED	
Web Server	RUNNING	2792	6836 kB 
Vielleicht fällt ja noch jemand was ein wo ich da weiter suchen könnte.
Danke schon mal
Last edited by imker25 on December 3rd, 2018, 10:33 pm, edited 1 time in total.

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 3rd, 2018, 10:32 pm

Achja,

noch ein Hinweis. Der PING hat eine normale Antwortzeit, auch bei Verbindungen über RED:

Code: Select all

ping heise.de
PING heise.de (193.99.144.80) 56(84) bytes of data.
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=1 ttl=247 time=22.4 ms
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=2 ttl=247 time=20.10 ms
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=3 ttl=247 time=21.8 ms
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=4 ttl=247 time=21.6 ms
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=5 ttl=247 time=21.6 ms
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=6 ttl=247 time=21.3 ms
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=7 ttl=247 time=21.7 ms
64 bytes from redirector.heise.de (193.99.144.80): icmp_seq=8 ttl=247 time=21.8 ms
^C
--- heise.de ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 412ms
rtt min/avg/max/mdev = 20.990/21.644/22.402/0.434 ms

User avatar
MichaelTremer
Core Developer
Core Developer
Posts: 5645
Joined: August 11th, 2005, 9:02 am

Re: Verbindungen über RED sehr langsam nach Update 125

Post by MichaelTremer » December 4th, 2018, 12:40 am

Ist das QoS an?

Ich kann das bei mir aktuell nicht nachstellen...
Support the project with our Donation Challenge!

Get Commercial Support for IPFire and more from Lightning Wire Labs!

Image

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 4th, 2018, 4:44 pm

Hallo,

nein auch QoS ist nicht an.

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 4th, 2018, 5:19 pm

Hallo,

ich habe jetzt mal ein bischen in den Logs geschaut. In der /var/log/messages tauchen immer wieder solche Einträge auf:

Code: Select all

Dec  4 17:55:29 moe collectd[19540]: rrdtool plugin: rrd_update_r failed: /var/log/rrd/collectd/localhost/iptables-filter-POLICYFWD/ipt_packets-DROP_FORWARD.rrd: This RRD was created on another architecture
Dec  4 17:55:29 moe collectd[19540]: rrdtool plugin: rrd_update_r failed: /var/log/rrd/collectd/localhost/iptables-filter-POLICYOUT/ipt_bytes-DROP_OUTPUT.rrd: This RRD was created on another architecture
Dec  4 17:55:29 moe collectd[19540]: rrdtool plugin: rrd_update_r failed: /var/log/rrd/collectd/localhost/iptables-filter-POLICYIN/ipt_bytes-DROP_INPUT.rrd: This RRD was created on another architecture
Dec  4 17:55:29 moe collectd[19540]: rrdtool plugin: rrd_update_r failed: /var/log/rrd/collectd/localhost/iptables-filter-POLICYIN/ipt_packets-DROP_INPUT.rrd: This RRD was created on another architecture
Dec  4 17:55:29 moe collectd[19540]: rrdtool plugin: rrd_update_r failed: /var/log/rrd/collectd/localhost/swap/swap-free.rrd: This RRD was created on another architecture
Dec  4 17:55:29 moe collectd[19540]: rrdtool plugin: rrd_update_r failed: /var/log/rrd/collectd/localhost/swap/swap-cached.rrd: This RRD was created on another architecture
Dec  4 17:55:29 moe collectd[19540]: rrdtool plugin: rrd_update_r failed: /var/log/rrd/collectd/localhost/swap/swap_io-out.rrd: This RRD was created on another architecture
Ich denke zwar nicht, dass das direkt mit meinem Problem zu tun hat. Aber "was created on another architecture" macht mich doch neugierig.
Ich hatte diese IPFire Installation immer in der gleichen Maschine laufen. Wie kann sich da die Prozessor(?)- Architektur geändert haben?
Wurde IPFire früher im x86 Modus betriben und läuft jetzt x64?

BeBiMa
Posts: 2635
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: Verbindungen über RED sehr langsam nach Update 125

Post by BeBiMa » December 4th, 2018, 9:12 pm

Ein Architekturwechsel i586 -> x86_64 erfolgt eigentlich nur auf Veranlassung des Benutzers.
Image
Unitymedia Cable Internet ( 32MBit )

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 4th, 2018, 10:05 pm

Hallo,

jetzt wo du es sagst, bin ich nochmal in mich gegangen. Ich habe vor ein paar Monaten mal den -pae Kernel gengen den normalen getauscht.
Habe ich damit den Architektur Wechsel vielleicht vollzogen?

BeBiMa
Posts: 2635
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: Verbindungen über RED sehr langsam nach Update 125

Post by BeBiMa » December 4th, 2018, 10:21 pm

Das ist gut möglich.

Aufgrund der Fehlermeldung bzgl. RRD suche mal nach Anleitungen für den Wechsel. Soweit ich weiss, können die i586-RRDs nicht unter x86_64 genutzt werden. Entweder gehen die Informationen ( die CPU-, Schnittstellen-, etc. Graphen ) verloren oder können portiert werden.

EDIT: Im Prinzip sollte ein Transfer der RRD-Datenbanken möglich sein.
Die entsprechenden Hinweise geben https://oss.oetiker.ch/rrdtool/doc/rrddump.en.html und https://oss.oetiker.ch/rrdtool/doc/rrdrestore.en.html
Image
Unitymedia Cable Internet ( 32MBit )

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 5th, 2018, 8:15 pm

Hallo zusammen,

ich habe nun heute beschlossen IPFire neu zu installieren und im Anschluss einfach ein frisches Backup wieder einzuspielen.
Die RRD Fehler tauchen nun nicht mehr auf.

Aber an meinem Performance PRoblem hat das leider nichts geändert. Es ist immer noch so, dass ich nur direkt auf IPFire Konsole meine volle Bandbreite erreiche. Versuche ich was von einem Client aus einem externen Netz zu laden, dann bricht die Bandbreite ein.
Verbindingen zwischen den internen Netzten zeigen auch keine Probleme.

Vielleicht hat es ja was damit zu tun, dass ich IPFire als Xen DomU (PVM) betreibe? Installiert habe ich den IPFire dem Skript aus https://downloads.ipfire.org/releases/i ... 25.tar.bz2

Die Installation vorher war als Xen HVM installiert. Das nur so nebenbei, da es für die Performace eh keinen Unterschied macht.

Ich werde aber morgen mal die Gegenprobe zu der Vermutung, dass es am Core 125 liegt, machen und eine Core 124 neu installieren.

BeBiMa
Posts: 2635
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: Verbindungen über RED sehr langsam nach Update 125

Post by BeBiMa » December 5th, 2018, 10:32 pm

Dann passt vielleicht das: viewtopic.php?f=5&t=21991
Image
Unitymedia Cable Internet ( 32MBit )

imker25
Posts: 18
Joined: December 2nd, 2018, 5:01 pm

Re: Verbindungen über RED sehr langsam nach Update 125

Post by imker25 » December 6th, 2018, 7:23 am

Hallo,
Ja das trifft meine Probleme ganz gut. Dort wird exakt das gleiche Verhalten wie bei mir beschrieben. Nur das auf meiner Installation erst mit 125 Probleme kamen

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests