ssh tcp forwarding funktioniert nicht mehr. V124 [Gelöst]

Post Reply
snoopy_cb
Posts: 17
Joined: October 7th, 2010, 11:24 am

ssh tcp forwarding funktioniert nicht mehr. V124 [Gelöst]

Post by snoopy_cb » October 17th, 2018, 9:32 am

Hardware: shuttle xpc (red/green) & vmware VM

Hallo zusammen,

ich habe das Problem, das über ssh kein tcp forwarding mehr funktioniert.
Wenn ich ein Port Forwarding über putty konfiguriere und diesen auf den Webproxy im ipfire zeigen lasse, kann keine Webseite (internet) über den ssh tunnel aufgerufen werden, es passiert nichts (mehr).
Browser ist korrekt eingestellt (lokaler Port zeigt auf den ssh tunnel)
Früher ging es ohne Probleme, seit dem Update auf 124 tritt das Problem auf.

Wenn ich direkt (ohne ssh tunnel) auf den Proxy zugreife, gibt es kein Problem.
Eine auch auf dem Patchlevel 124 befindliche VM zeigt das gleiche Problem.

Wenn ich einen telnet Zugriff auf den lokalen Port mache, lauscht dieser auch.
(telnet localhost 10080


Gibt es Veränderungen in der Vers. 124 die den genutzten Tunnel und Weiterleitung an den Proxy unterbinden?

hier nochmal schematisch
Client/ssh ---------------- Internet -----------------------ipfire /ssh-server
|
((Client (putty)---ssh-tunnel ----------------ipfire webproxy))------ Internet
Attachments
screenshot.98.jpg
screenshot.97.jpg
screenshot.96.jpg
Last edited by snoopy_cb on October 18th, 2018, 8:15 pm, edited 1 time in total.

snoopy_cb
Posts: 17
Joined: October 7th, 2010, 11:24 am

Re: ssh tcp forwarding funktioniert nicht mehr. V124

Post by snoopy_cb » October 17th, 2018, 1:33 pm

gerade eben mit einer VM verifiziert, mit V123 funktioniert tcp forwarding über ssh.
Bei V124 kommt ein "Secure Connection Failed" im Browser.

Andrea.Vt
Posts: 6
Joined: April 20th, 2016, 10:45 am
Location: Zurich

Re: ssh tcp forwarding funktioniert nicht mehr. V124

Post by Andrea.Vt » October 17th, 2018, 8:47 pm

Mit putty bekomme ich die Meldung: "Couldn't agree a key exchange algorithm (available: curve25519-sha256@libssh.org)"

Hat wirklich niemand eine Idee, wie man das beheben könnte?

Veti
Posts: 369
Joined: November 22nd, 2009, 9:26 am

Re: ssh tcp forwarding funktioniert nicht mehr. V124

Post by Veti » October 18th, 2018, 7:14 am

bearbeite manuell deine sshd_config.

Die Auswahlbox führt nicht dazu das der config parameter gesetzt wird.

AllowTcpForwarding yes
und den eintrag PermitOpen no entfernen

doc
Posts: 153
Joined: June 5th, 2014, 12:33 pm
Location: Hannover

Re: ssh tcp forwarding funktioniert nicht mehr. V124

Post by doc » October 18th, 2018, 12:19 pm

Und den SSH Service per GUI oder durch IPFire-Reboot danach neu starten.
Ein /etc/init.d/sshd restart hat bei mir komischerweise nicht gereicht. ???

Und das "Couldn't agree a key exchange algorithm" könnte wahrscheinlich auf einen alten PuTTY-Client hinweisen. Mach davon mal ein Update, wenn Du die sshd_config geändert hast und es dann immer noch nicht geht.
Image

snoopy_cb
Posts: 17
Joined: October 7th, 2010, 11:24 am

Re: ssh tcp forwarding funktioniert nicht mehr. V124

Post by snoopy_cb » October 18th, 2018, 8:05 pm

das auskommentieren bzw. löschen von "PermitOpen none" hat funktioniert, anschl. System Neustart notwendig.
Ein neustart des ssh-daemons reicht alleine nicht aus.


Zusammenfassung:
in /etc/ssh/sshd_config folgende Zeile auskommentieren oder löschen.
PermitOpen none

und
AllowTcpForwarding yes
einfügen bzw. ändern. Eintrag ist bereits vorhanden.

Andrea.Vt
Posts: 6
Joined: April 20th, 2016, 10:45 am
Location: Zurich

Re: ssh tcp forwarding funktioniert nicht mehr. V124

Post by Andrea.Vt » October 18th, 2018, 8:33 pm

doc wrote:
October 18th, 2018, 12:19 pm
Und das "Couldn't agree a key exchange algorithm" könnte wahrscheinlich auf einen alten PuTTY-Client hinweisen. Mach davon mal ein Update, wenn Du die sshd_config geändert hast und es dann immer noch nicht geht.
Danke!
Putty ersetzen hat gereicht.
(Ich wusste gar nicht, dass putty noch weiterentwickelt wird :) )

Post Reply