OT: Erreichbarkeit des Forums

elo22
Posts: 93
Joined: June 18th, 2012, 4:57 am

OT: Erreichbarkeit des Forums

Post by elo22 » February 3rd, 2019, 1:24 pm

Hallo,
in letzten Wochen ist das Forum hier oft nicht erreichbar, die Hauptseite macht keine Probleme. Geht das nur mir so?

Lutz

BetaTester
Posts: 103
Joined: November 14th, 2018, 3:04 pm

Re: OT: Erreichbarkeit des Forums

Post by BetaTester » February 4th, 2019, 11:23 am

Ich hatte bisher keine Probleme das Forum zu erreichen...

extrasolar
Posts: 55
Joined: October 30th, 2016, 11:24 am

Re: OT: Erreichbarkeit des Forums

Post by extrasolar » February 4th, 2019, 5:23 pm

Gestern Abend wieder, dig liefert status: SERVFAIL. Das kommt leider in letzter Zeit öfter vor.

Code: Select all

dig forum.ipfire.org

; <<>> DiG 9.9.7-P3 <<>> forum.ipfire.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 33538
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;forum.ipfire.org.		IN	A

;; Query time: 40 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sun Feb 03 17:54:49 CET 2019
;; MSG SIZE  rcvd: 45

Home: VF VDSL 109↓ 33↑, AVM FB: 7590 [07.01], RPi: Pi-Hole [4.3], VPN: IPsec
Office: VF Cable 400↓ 25↑, Modem: CBN CH7466CE, IPFire-HW: Jetway NC9C-550-LF, VPN: IPsec

Image

User avatar
MichaelTremer
Core Developer
Core Developer
Posts: 5770
Joined: August 11th, 2005, 9:02 am

Re: OT: Erreichbarkeit des Forums

Post by MichaelTremer » February 5th, 2019, 5:52 pm

Hi,

ich hab bisher nichts festellen können. Kannst du herausfinden wo in der Kette der DNS-Server der SERVFAIL auftritt?
Support the project with our Donation Challenge!

Get Commercial Support for IPFire and more from Lightning Wire Labs!

Image

elo22
Posts: 93
Joined: June 18th, 2012, 4:57 am

Re: OT: Erreichbarkeit des Forums

Post by elo22 » February 7th, 2019, 6:16 pm

Gestern wieder.

Lutz

Alorotom
Posts: 400
Joined: March 30th, 2015, 6:56 am

Re: OT: Erreichbarkeit des Forums

Post by Alorotom » February 17th, 2019, 3:43 pm

Tja, hier jetzt auch. Nach mehreren Anläufen kommt die Seite dann doch.

Code: Select all

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\xxxx>ping forum.ipfire.org
Ping-Anforderung konnte Host "forum.ipfire.org" nicht finden. Überprüfen Sie den
 Namen, und versuchen Sie es erneut.

C:\Users\xxxx>nslookup forum.ipfire.org
Server:  RADONIO.elements.local
Address:  192.168.1.1

*** forum.ipfire.org wurde von RADONIO.elements.local nicht gefunden: Server fai
led.

C:\Users\xxxx>nslookup forum.ipfire.org 8.8.8.8
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Nicht autorisierende Antwort:
Name:    fw01.ipfire.org
Addresses:  2001:470:7183::
          81.3.27.38
Aliases:  forum.ipfire.org


C:\Users\xxxx>nslookup forum.ipfire.org
Server:  RADONIO.elements.local
Address:  192.168.1.1

Nicht autorisierende Antwort:
Name:    fw01.ipfire.org
Addresses:  2001:470:7183::
          81.3.27.38
Aliases:  forum.ipfire.org
Der Zeitindex am Client und auf IPFire sind identisch und passen zur Zeitangabe auf dem Smartphone (als Referenz).

Gruß
Alorotom
Image
Image
Image

User avatar
MichaelTremer
Core Developer
Core Developer
Posts: 5770
Joined: August 11th, 2005, 9:02 am

Re: OT: Erreichbarkeit des Forums

Post by MichaelTremer » February 20th, 2019, 3:47 pm

Hallo,

ich hab gestern an der Konfiguration unserer DNS-Server etwas geändert. Hat das schon Abhilfe gebracht?

-Michael
Support the project with our Donation Challenge!

Get Commercial Support for IPFire and more from Lightning Wire Labs!

Image

Alorotom
Posts: 400
Joined: March 30th, 2015, 6:56 am

Re: OT: Erreichbarkeit des Forums

Post by Alorotom » February 20th, 2019, 9:44 pm

Hallo Michael,

nein, heute wieder kurz keine DNS-Auflösung und ein paar pings später ging es wieder.

Gruß
Alorotom
Image
Image
Image

Alorotom
Posts: 400
Joined: March 30th, 2015, 6:56 am

Re: OT: Erreichbarkeit des Forums

Post by Alorotom » March 2nd, 2019, 6:15 am

Für das Protokoll,
gestern ist das erneut aufgetreten. Mehrere Minuten und dann löst er den Namen wieder auf. Strange.

Keine DNS-Auflösung von forum.ipfire.org vom Client aus, keine DNS-Auflösung auf der Konsole von IPFire, aber gleichzeitig parallel keine Probleme im Netz der vor IPFire stehenden Fritz!Box.

Also kann ich aus meiner Sicht die Frage nach dem Punkt mit dem SERVERFAIL mit "IPFire" beantworten.

Gruß
Alorotom
Image
Image
Image

Alorotom
Posts: 400
Joined: March 30th, 2015, 6:56 am

Re: OT: Erreichbarkeit des Forums

Post by Alorotom » March 17th, 2019, 6:52 pm

Heute schon wieder. Scheint immer um den selben Zeitraum herum der Fall zu sein. Echt nervig. Wie bei den bisherigen Auftreten geht es dann nach ~10 Min unerklärlicherweise wieder.

Gruß
Alorotom

Code: Select all

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users>tracert forum.ipfire.org
Der Zielname forum.ipfire.org konnte nicht aufgelöst werden.

C:\Users>nslookup forum.ipfire.org 1.1.1.1
Server:  one.one.one.one
Address:  1.1.1.1

Nicht autorisierende Antwort:
Name:    fw01.ipfire.org
Addresses:  2001:470:7183::
          81.3.27.38
Aliases:  forum.ipfire.org

C:\Users>tracert forum.ipfire.org
Der Zielname forum.ipfire.org konnte nicht aufgelöst werden.

C:\Users>ping ipfire.org
Ping-Anforderung konnte Host "ipfire.org" nicht finden. Überprüfen Sie den Namen
, und versuchen Sie es erneut.
Und direkt auf der Konsole:

Code: Select all

[root@RADONIO ~]# ping forum.ipfire.org
ping: forum.ipfire.org: Temporary failure in name resolution
[root@RADONIO ~]# nslookup ipfire.org
Server:         127.0.0.1
Address:        127.0.0.1#53

** server can't find ipfire.org: SERVFAIL

[root@RADONIO ~]# nslookup ipfire.org 1.1.1.1
Server:         1.1.1.1
Address:        1.1.1.1#53

Non-authoritative answer:
Name:   ipfire.org
Address: 81.3.27.38
Name:   ipfire.org
Address: 2001:470:7183::

[root@RADONIO ~]# ping fw01.ipfire.org
ping: fw01.ipfire.org: Temporary failure in name resolution
[root@RADONIO ~]# ping fw01.ipfire.org
PING fw01.ipfire.org (81.3.27.38) 56(84) bytes of data.
64 bytes from 81.3.27.38 (81.3.27.38): icmp_seq=1 ttl=57 time=48.0 ms
64 bytes from 81.3.27.38 (81.3.27.38): icmp_seq=2 ttl=57 time=38.8 ms
64 bytes from 81.3.27.38 (81.3.27.38): icmp_seq=3 ttl=57 time=38.9 ms
64 bytes from 81.3.27.38 (81.3.27.38): icmp_seq=4 ttl=57 time=38.9 ms
64 bytes from 81.3.27.38 (81.3.27.38): icmp_seq=5 ttl=57 time=38.7 ms
^C
--- fw01.ipfire.org ping statistics ---
6 packets transmitted, 5 received, 16% packet loss, time 5007ms
rtt min/avg/max/mdev = 38.708/40.703/48.004/3.660 ms
[root@RADONIO ~]#
Image
Image
Image

Hellfire
Posts: 607
Joined: November 8th, 2015, 8:54 am

Re: OT: Erreichbarkeit des Forums

Post by Hellfire » March 17th, 2019, 7:52 pm

Ich hab immer dann ein Problem, wenn ich Spam-Mails reporten möchte. Da kommt dann entweder ein Fehler oder die (Folge-)Seite wird unvollständig aufgebaut.

Hat sehr wahrscheinlich jetzt nichts mit dem DNS Problem hier zu tun, aber es ghört zumindest zum Topic...
Image

elo22
Posts: 93
Joined: June 18th, 2012, 4:57 am

Re: OT: Erreichbarkeit des Forums

Post by elo22 » March 19th, 2019, 1:55 pm

Sonntag und Montag wieder nichts.

Lutz

User avatar
MichaelTremer
Core Developer
Core Developer
Posts: 5770
Joined: August 11th, 2005, 9:02 am

Re: OT: Erreichbarkeit des Forums

Post by MichaelTremer » March 19th, 2019, 1:57 pm

Ihr benutzt alle OpenDNS, oder?
Support the project with our Donation Challenge!

Get Commercial Support for IPFire and more from Lightning Wire Labs!

Image

Alorotom
Posts: 400
Joined: March 30th, 2015, 6:56 am

Re: OT: Erreichbarkeit des Forums

Post by Alorotom » March 19th, 2019, 9:54 pm

Hallo Michael,

nein. Hier sind die DNS des Providers aktiv. Fritz!Box wählt bei EWE ein, IPFire steht hinter der Fritz!Box. D.h., für IPFire ist die Fritz!Box der Forwarder. Anfang des Jahres hatte ich einen Providerwechsel. Vorher Telekom, jetzt EWE. Phänomen tritt aber vorher wie nachher weiter auf.

Gruß
Alorotom
Image
Image
Image

User avatar
MichaelTremer
Core Developer
Core Developer
Posts: 5770
Joined: August 11th, 2005, 9:02 am

Re: OT: Erreichbarkeit des Forums

Post by MichaelTremer » March 25th, 2019, 4:33 pm

Hallo zusammen,

ich habe nun folgende Dinge unternommen:

Unsere DNS-Server laufen nun mit PowerDNS 4.1.8, der diese Woche freigegeben wurde.

Und ich habe das Ratelimiting deaktiviert. Das war so konfiguriert, dass kein Resolver mehr als 10 Anfragen in der Sekunde schickt. Ein Burst von 64 Anfragen war erlaubt. Das sollte mehr als genug gewesen sein, aber wir schauen einmal, ob es was hilft das abzuschalten.

Grüße,
-Michael
Support the project with our Donation Challenge!

Get Commercial Support for IPFire and more from Lightning Wire Labs!

Image

Post Reply