500 Internal Server Error (Nach ein paar Stunden)

Post Reply
Stefan86
Posts: 23
Joined: February 14th, 2012, 8:07 am

500 Internal Server Error (Nach ein paar Stunden)

Post by Stefan86 » February 8th, 2019, 2:26 pm

Bekomme leider das Problem nicht behoben, und hoffe auf eine Hilfestellung.

Ich habe seit langer Zeit ein Alix 2d13 mit einer 4GB CF Memory in Einsatz.
Alle letzte Versionen von ipfire bis 126 haben hervorragend funktioniert. Seit ein paar Tagen musste ich mehrmals feststellen,
dass innerhalb ein paar Stunden immer wieder "500 Internal Server Error" auftreten. Egal bei welcher Neuinstallation von 118 - 126.
Erst funktioniert alles ein paar Stunden, dann bekomme ich keine Zugriffe mehr auf die WebGui Menüs.

Verbinde ich mich per Serial an das Alix kommt zwar die Login abfrage, aber bei Eingabe erscheint des Passwort als Klartext.
Ein Login ist erst wieder möglich, wenn ich das Alix komplett vom Strom nehme, und neu starte.
Dann beginnt alles wieder von vorne. Das WebGUI und Login funktionieren ein paar Stunden, und dann treten wieder die Fehler auf.

Auch ein Austausch einer neuen CF bringt nichts. Die selben Probleme. Beide CF haben auch keine defekte Datenblöcke.

Nach einer erneuten Neuinstallation von z.B. IPFire 2.21 (i586) - Core Update 127 kann ich nur In den "error_log" das finden:
[Fri Feb 08 14:46:26.923837 2019] [mpm_event:notice] [pid 1956:tid 3082707776] AH00489: Apache/2.4.35 (Unix) OpenSSL/1.1.0j configured -- resuming normal operations
[Fri Feb 08 14:46:26.937298 2019] [core:notice] [pid 1956:tid 3082707776] AH00094: Command line: '/usr/sbin/httpd'

Kann mir bitte jemand ein Tipp geben, wie ich das Problem beheben kann?
Vielen Dank!
Last edited by Stefan86 on February 8th, 2019, 3:59 pm, edited 1 time in total.

fredym
Posts: 457
Joined: November 14th, 2016, 2:45 pm

Re: 500 Internal Server Error (Nach ein paar Stunden)

Post by fredym » February 8th, 2019, 3:20 pm

Hallo,

CF-Card O.K. (ggfs. Kapazität prüfen)
Speicherbelegung "normal" ?

Stefan86
Posts: 23
Joined: February 14th, 2012, 8:07 am

Re: 500 Internal Server Error (Nach ein paar Stunden)

Post by Stefan86 » February 8th, 2019, 5:30 pm

Habe jetzt folgende Fehlermeldung bekommen,
aber ich weiß leider nicht was das zu bedeuten hat...

CPU: 0 PID: 16725 Comm: hwclock Not tainted 4.14.86-ipfire #1
task: cc790000 task.stack: cd804000
Call Trace:
__ext4_handle_dirty_metadata+0x67/0x190
ext4_free_blocks+0x5c2/0xb90
ext4_ext_remove_space+0xd18/0x1320
? kmem_cache_free+0x16a/0x190
? ext4_es_free_extent+0x8e/0x120
? __es_remove_extent+0x248/0x2f0
? ext4_es_remove_extent+0x44/0xb0
ext4_ext_truncate+0x8e/0xa0
ext4_truncate+0x355/0x410
ext4_setattr+0x87f/0xa80
notify_change+0x2f1/0x410
do_truncate+0x82/0xd0
path_openat+0x6e6/0x1220
do_filp_open+0x80/0xf0
do_sys_open+0x1d5/0x290
SyS_openat+0x1b/0x20
do_int80_syscall_32+0x55/0x100
entry_INT80_32+0x31/0x31
Code: 8d 76 00 89 d8 e8 e1 4d f8 ff 85 c0 89 c6 74 b6 89 c2 31 c9 89 d8 e8 00 fe ff ff 8b 06 ba 04 00 00 00 e8 04 76 ff ff eb 9d 66 90 <0f> 0b e9 5f ff ff ff 89 f6 8d bc 27 00 00 00 00 8d 42 ff e9 7c

Getestet habe ich die hwclock mit:
dmesg | grep -i rtc
ls -l /dev/rtc*
hwclock --test -D

Aber das Datum stimmt soweit.

Post Reply