[SOLVED] - Core 129 - /boot läuft voll (95%)

Zonediver
Posts: 284
Joined: June 15th, 2011, 1:36 pm

[SOLVED] - Core 129 - /boot läuft voll (95%)

Post by Zonediver » April 9th, 2019, 4:58 pm

Hallo Experten,
ich hab gestern Core-Update 129 installiert und jetzt sagt mir der Fire, dass /boot zu 95% voll sei.
/dev/sda1 hat eine Größe von 124MB - davon sind 116MB belegt... wie dieses???
Kann mir da wer weiterhelfen und sagen, was ich da rauslöschen darf?
Danke im Voraus ;)
Attachments
IPFire_001.jpg
Last edited by Zonediver on April 11th, 2019, 2:44 pm, edited 2 times in total.
Hardware: ASRock Q1900M, 2x2GB-RAM, Intel SSD 535 120GB, 2x Intel i210-T1 PCIe

Image

Image

Zonediver
Posts: 284
Joined: June 15th, 2011, 1:36 pm

Re: Core 129 - /boot läuft voll (95%)

Post by Zonediver » April 9th, 2019, 6:54 pm

...niemand eine Idee? Dann isses wohl ein Fehler in der Core 129... muß ich das Teil jetzt neu aufsetzen? Hoffentlich nicht...
Hardware: ASRock Q1900M, 2x2GB-RAM, Intel SSD 535 120GB, 2x Intel i210-T1 PCIe

Image

Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Core 129 - /boot läuft voll (95%)

Post by Arne.F » April 10th, 2019, 5:11 am

Was hast du für ein filesystem?
Kannst du mal einen fsck machen?
Ich würde auf eine Falsche anzeige tippen wieviel platz da noch ist.

Meine Installation hat nur 64MB auf boot und da ist noch knapp die hälfte frei. Aber zumindest in /boot selbst sind genau die files die da hingehören.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

nightman
Posts: 27
Joined: April 8th, 2010, 8:31 pm

Re: Core 129 - /boot läuft voll (95%)

Post by nightman » April 10th, 2019, 9:14 am

Habe das gleiche Problem.
Bei mir kommt die Meldung das noch 3% frei sind.
boot ist bei mir 59MB gross.
Folgende Dateien sind in boot-Ordner.

-rw-r--r-- 1 root root 163089 Feb 23 21:39 config-4.14.103-ipfire
-rw-r--r-- 1 root root 162707 Feb 23 19:52 config-4.14.103-ipfire-pae
drwxr-xr-x 5 root root 1024 Apr 9 19:35 grub
-rw-r--r-- 1 root root 12519064 Feb 23 21:41 initramfs-4.14.103-ipfire.img
-rw-r--r-- 1 root root 14240988 Apr 10 11:04 initramfs-4.14.103-ipfire-pae.img
drwx------ 2 root root 12288 Jun 10 2017 lost+found
-rw-r--r-- 1 root root 2686423 Feb 23 21:39 System.map-4.14.103-ipfire
-rw-r--r-- 1 root root 2731841 Feb 23 19:52 System.map-4.14.103-ipfire-pae
-rw-r--r-- 1 root root 4914528 Feb 23 21:39 vmlinuz-4.14.103-ipfire
-rw-r--r-- 1 root root 4968128 Feb 23 19:52 vmlinuz-4.14.103-ipfire-pae

Werden diese alle benötigt.

Veti
Posts: 369
Joined: November 22nd, 2009, 9:26 am

Re: Core 129 - /boot läuft voll (95%)

Post by Veti » April 10th, 2019, 9:58 am

entferne mal das linux-PAE packet.

Hellfire
Posts: 697
Joined: November 8th, 2015, 8:54 am

Re: Core 129 - /boot läuft voll (95%)

Post by Hellfire » April 10th, 2019, 10:25 am

Man könnte natürlich auch, wie schon bei anderen Upgrades davor, bei denen der Speicher schwand, mittels Tool wie GParted, die Partitionen vergrößern.
So hab' ich es neulich gemacht und dabei sämtliche Partitionen erweitert um für die Zukunft gerüstet zu sein.
Image

nightman
Posts: 27
Joined: April 8th, 2010, 8:31 pm

Re: Core 129 - /boot läuft voll (95%)

Post by nightman » April 10th, 2019, 10:27 am

Hab das Packet entfernt.
Jetzt sind 31MB frei.

Eine Frage zu diesem Packet.
Ich bin mir nicht bewusst das ich dieses jemals selber installiert habe.
Für was wird dieses Packet den benötigt.

Veti
Posts: 369
Joined: November 22nd, 2009, 9:26 am

Re: Core 129 - /boot läuft voll (95%)

Post by Veti » April 10th, 2019, 10:31 am

pae steht für physical address extension.

damit kann ein 32 bit system mehr als 4gb ansprechen. da macht es aber mehr sinn ipfire 64 bit zu installieren.

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Core 129 - /boot läuft voll (95%)

Post by Arne.F » April 10th, 2019, 11:02 am

entferne mal das linux-PAE packet.
Dumme Idee. Der PAE Kernel ist der bessere kernel auf Systemen die PAE beherrschen. (Alles ab Pentium) Nur der ALIX und ein paar andere alte Systeme können das nicht daher muss die Installation erstmal den legacy kernel installieren. Auch einige Sicherheitsfunktionen (NX-Bit usw.) funktionieren mit dem Legacy kernel nicht.

Auf alten Installationen (64MB boot) mit 32bit und pae ist es normal das fast kein Platz mehr ist. Da hilft nur gparted-live und die Partition vergrößern oder neu installieren. Wenn das System 64bit kann sollte man das auf jeden Fall mal machen. (Ich schieb das aber auch immer wieder vor mir her ;) )

Das ist aber nicht das Problem bei Zonedrivers installation. Das hat eine 120MB bootpartition und nur einen 64bit Kernel. Da müsste also massig Platz frei sein.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

nightman
Posts: 27
Joined: April 8th, 2010, 8:31 pm

Re: Core 129 - /boot läuft voll (95%)

Post by nightman » April 10th, 2019, 11:11 am

OK. Dann werde ich wohl für demnächst einen neuinstallation Planen.
Ist längerfristig wohl die beste Lösung.

Ich habe ein ALIX Board mit einem i686 ADM G-T 40E CPU.
Die sollte ja 64bit können.

Hierfür nehme ich ja das i586-ISO Image da ich das ganze über ein PXE-Server installiere.
Die Konfiguration kann ich nachher wieder zurückspielen.
Ist das so korrekt. Oder muss ih mir die Konfiguration Dokumentieren.

Danke für eure Unterstützung.

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Core 129 - /boot läuft voll (95%)

Post by Arne.F » April 10th, 2019, 2:18 pm

Ich habe ein ALIX Board mit einem i686 ADM G-T 40E CPU.
Die sollte ja 64bit können.
Es gibt kein ALIX board mit einer i686 CPU (die haben alle nur i586 Geode CPU's) daher nehm ich mal an du hast eine PC Engines APU1 mit einer AMD G T40E.
Hierfür nehme ich ja das i586-ISO Image da ich das ganze über ein PXE-Server installiere.
Nein. Das x86_64-iso das andere ist 32bit. Du musst auch nicht über PXE installieren, da die APU kann auch die ISO (von CD im USB Laufwerk oder 1zu1 auf einen USB Stick) booten allerdings gibt das Bootmenu jedes zeichen Doppelt aus. Wichtig ist das man im Bootmenu "Serial options" und dann "Install IPFire with serial console" wählt, danach geht die Installation genauso wie auf jedem anderen PC.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Zonediver
Posts: 284
Joined: June 15th, 2011, 1:36 pm

Re: Core 129 - /boot läuft voll (95%)

Post by Zonediver » April 10th, 2019, 4:34 pm

So... jetzt weiß ich noch immer nicht, was ich da löschen könnte... mittler Weile sind 0% frei - von 124MB :-\
Attachments
IPFire_002.jpg
Last edited by Zonediver on April 10th, 2019, 4:47 pm, edited 2 times in total.
Hardware: ASRock Q1900M, 2x2GB-RAM, Intel SSD 535 120GB, 2x Intel i210-T1 PCIe

Image

Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Core 129 - /boot läuft voll (95%)

Post by Arne.F » April 10th, 2019, 4:40 pm

Von dem was du aufgelistet hast nichts. Das sind aber nur 25 Mb.

Daher meine Frage nach dem Dateisystem und ob du mal einen Dateisystemcheck machen kannst.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Zonediver
Posts: 284
Joined: June 15th, 2011, 1:36 pm

Re: Core 129 - /boot läuft voll (95%)

Post by Zonediver » April 10th, 2019, 4:47 pm

Ich hab noch einen ScreenShot angehängt - scheinbar ist das XFS...
Hardware: ASRock Q1900M, 2x2GB-RAM, Intel SSD 535 120GB, 2x Intel i210-T1 PCIe

Image

Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Core 129 - /boot läuft voll (95%)

Post by Arne.F » April 11th, 2019, 6:26 am

Hast du nach der Installation einen Reboot gemacht. xfs gibt gern mal speicher nicht wieder frei solange das volume gemountet ist.

auch "unmount /boot" "mount /boot" könnte schon helfen, falls nicht doch mal das in der fsck meldung angegebene repair-xfs oder so ausprobieren.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Post Reply