Seit Core Update 135,136 und 137 Verbindungsabbrüche auf Rot

Post Reply
wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Seit Core Update 135,136 und 137 Verbindungsabbrüche auf Rot

Post by wissbegierig » October 27th, 2019, 6:17 pm

Einen wunderschönen guten Abend,

Seit dem Core Update 135 bzw auch 136 habe ich im roten Netzwerk( I-Net) Probleme bzw. Verbindungsabbrüche

Eingebaute Netzwerkkarten jeweils Rot (Onboard), Orange (PCI), Blau und Grün.
Unter Sytem gibt es die vollen Ausschläge.
Unter Startseite sieht man das die Verbindung neu aufgebaut wurde


Bei meiner alten IP Fire HW hat der Rechner immer neu gebootet.
IP Fire Alt
Image

Ich dachte die HW ist kaputt, ist gut 10 Jahre alt.

Ich habe mir einen anderen Rechner organisiert und das Ergebnis ist nicht besser :-[ -> HP Compaq 8000 Elite Small Form Factor Business PC
Ausser das es schnellter geht -> Der Verbindungsaufbau.
Bei einem Strom AUS/Ein braucht er beim red interface gefühlt lange um eine Ip Adresse vom Hybrid Modem zu erhalten.
Ausserdem kommt eine komische Meldung am Bildschirm -> diese muss ich einmal abfotografieren.

Image

I-Net Anschluß A1 Telekom Hybrid Technik. 40Mbit

Gibt es ein Logfile wo ich nachsehen kann bzw. irgendwas erkennen kann, bzw. Ihr?

Mfg

Didi L

Unter Sytem gibt es die vollen Ausschläge.
Attachments
2019-10-27 19_45_12-ipfire.localdomain - Statusinformationen.png
Last edited by wissbegierig on November 17th, 2019, 7:10 am, edited 1 time in total.
Image

Image

wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by wissbegierig » October 28th, 2019, 5:13 am

Guten Morgen,

Kann es sein das die Netzwerk PCI Karte welche mitgewandert ist, das System durcheinander bringt ?
Die Netzwerkkarte ist ca. 3-4 Jahre alt.

Ausserdem kommt eine komische Meldung am Bildschirm -> diese habe ich einmal abfotografiert.
Leider unscharf.
Ich hoffe man kann etwas erkennen. Oder kann man die Meldung auch mit Putty kopieren?
IMG_20191028_055350.jpg
Ich glaube ich muss zusätzlich noch bei A1 Festnetz internet anrufen.
Verbindungsabbruch beim eigenen Speedtest Test.
2019-10-28 06_16_07-Internet-Speedtest _ A1.net.png
Mfg

Didi L
Image

Image

wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by wissbegierig » October 28th, 2019, 11:53 am

Mahlzeit,

Am Mittwoch Vormittag kommt der Telekomtechniker!
Sie meinen die Leitung hat was.
Na dann lassen wir uns überraschen.

Mfg

Didi L
Image

Image

wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by wissbegierig » October 29th, 2019, 8:56 pm

Guten Abend,

Ich musste heute ein Patchkabel tauschen. Vom Patchfeld zum Ipfire.
Brachte von der Geschwindigkeit schon mal eine Besserung.
Ich habe jetzt meinen alten Ipfire wieder aufgestellt. Gefühlt läuft dieser etwas besser.

Dürfte aber ein thermisches Problem haben. Nach einer gewisssen Zeit kommen auch hier die Verbindungsabbrüche! Und ein Automatischer reboot folgt.

Mfg

Didi
Image

Image

wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by wissbegierig » October 30th, 2019, 10:00 am

Mahlzeit,

Ja, der Telekomtechniker hat was gefunden und den Fehler behoben.
Sehen wir einmal ob es dies wahr.
Mein Ipfire läuft nocht mit der alten HW. Mit 463 MB Ram

Mfg

Didi L
Image

Image

Hoschiyama
Posts: 9
Joined: July 10th, 2011, 8:34 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by Hoschiyama » October 30th, 2019, 10:00 am

Guude,

ich habe das gleiche/ähnliches Problem.
Im Kernel-Log konnte ich jedes mal eine "dhcpcd [Prozess-Nummer] segfault at 7fffec9e7000 ....." Meldung finden. Nach einem Neustart des roten Interfaces oder einem Reboot war alles wieder ok.
Bei der Suche nach Lösungen bin ich auf diesen Thread gestoßen.
So wie es aussieht scheint es ein Problem mit dem dhcpcd (< 8.1.1) zu sein, welches wohl mit dem core update 137 gefixed werden soll.
Sofern sich das Problem bei mir nicht verschlimmert, momentan nur alle 4-5 Tage, werde ich versuchen bis zum nächsten update durch zu halten.

MfG,

BeBiMa
Posts: 2842
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by BeBiMa » October 30th, 2019, 10:44 am

Bzgl. des Absturzes des dhcpcd habe ich mir durch folgenden fcrontab-Eintrag geholfen:

Code: Select all

# workaround for dhcpcd
*/2 * * * * perl -e 'system("dhcpcd -n red0") unless my $a=`ps -e|grep dhcpcd`' >/dev/null 2>&1

Eintragen mittels fcrontab -e. Damit ist der maximale Ausfall ca. 2 Minuten.
Image
Unitymedia Cable Internet ( 32MBit )

Hoschiyama
Posts: 9
Joined: July 10th, 2011, 8:34 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by Hoschiyama » October 30th, 2019, 11:27 am

Vielen Dank, werde ich gleich mal testen.

wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by wissbegierig » October 31st, 2019, 5:47 am

Guten Morgen,

Der 20h Test war bis jetzt erfolgreich.
Folgende Sachen wurden defenitiv gemacht.
1) Patchkabel tausch zwischen Ipfire und Patchfeld.
2) Der A1 Telekomtechniker dürfte vom Fach gewesen sein und brachte Besserung. Diesmal war ich als Privatkunde echt begeistert! Der Hotline Techniker und der Vorort Techniker waren wirklich vom Fach.
3) Bei 463 MB Ram Ipfire wurde die BIOS Batterie getauscht!

Der Ipfire mit 463 MB Ram läuft wieder perfekt!

Jetzt muss ich einmal die "Neuere HW mit 2GB Ram (welche in Wirklichkeit auch alt ist) für mich zum laufen bringen.

Mfg

Didi L
Image

Image

Hoschiyama
Posts: 9
Joined: July 10th, 2011, 8:34 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by Hoschiyama » October 31st, 2019, 10:38 am

BeBiMa wrote:
October 30th, 2019, 10:44 am
Bzgl. des Absturzes des dhcpcd habe ich mir durch folgenden fcrontab-Eintrag geholfen:

Code: Select all

# workaround for dhcpcd
*/2 * * * * perl -e 'system("dhcpcd -n red0") unless my $a=`ps -e|grep dhcpcd`' >/dev/null 2>&1
Eintragen mittels fcrontab -e. Damit ist der maximale Ausfall ca. 2 Minuten.
Vielen Dank nochmal, funktioniert wunderbar :D
Gestern Abend um 22:10:12 Uhr hatte ich wieder einen "dhcpcd[22804]: segfault at 7ffecca8 ...." und um 22:12:01Uhr hat das Script das Rote Interface neu gestartet.
Schau mer mal ob das ganze dann in 137 behoben ist.

Gruß,

BeBiMa
Posts: 2842
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by BeBiMa » October 31st, 2019, 12:42 pm

Hoschiyama wrote:
October 31st, 2019, 10:38 am
Vielen Dank nochmal, funktioniert wunderbar :D
Gestern Abend um 22:10:12 Uhr hatte ich wieder einen "dhcpcd[22804]: segfault at 7ffecca8 ...." und um 22:12:01Uhr hat das Script das Rote Interface neu gestartet.
Schau mer mal ob das ganze dann in 137 behoben ist.

Gruß,
Freut mich, dass ich helfen konnte. Wie gesagt, ich hab das selbst im Gebrauch und hab seitdem eigentlich kaum Beeinträchtigungen bemerkt.
In der 137 sollte der dhcpcd eigentlich wieder auf eine funktionierende Version zurückgesetzt werden. Bei der aktuellen ist laut ML des Programms noch nicht alles im Lot.
Image
Unitymedia Cable Internet ( 32MBit )

wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by wissbegierig » November 1st, 2019, 6:50 am

Guten Morgen,

Wann kommt eigentlich die 137 Version?

So toll läuft es bei mir doch nicht.
Gestern Abend ist er abgeschmiert wie das Bildschirmfoto schon gezeigt hat. Heute in der Früh ein Automatischer Restart.

Alles mit dem 431 Mb Ipfire

Mfg

Didi L
Image

Image

DJ-Melo
Posts: 675
Joined: July 8th, 2014, 7:12 am

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by DJ-Melo » November 1st, 2019, 8:35 am


wissbegierig
Posts: 11
Joined: November 9th, 2018, 11:39 pm

Re: Seit Core Update 135 und 136 Verbindungsabbrüche auf Rot

Post by wissbegierig » November 17th, 2019, 7:09 am

Guten Morgen,

Ich habe am Freitag gleich die 137iger inst.
Mmhhhh. Der Fehler hat sich verschlimmert.
Jetzt habe ich einmal was gefunden. CPU Hardwarelock -> deutet dies auf einen HW Fehler hin ?
Bei diesen Fehler hilft nur Strom Aus/Ein und danach läuft es max 1,5Tage.

Mfg

Didi L
Image

Image

DJ-Melo
Posts: 675
Joined: July 8th, 2014, 7:12 am

Re: Seit Core Update 135,136 und 137 Verbindungsabbrüche auf Rot

Post by DJ-Melo » November 17th, 2019, 10:01 am

Tausche mal ggf nochmal Lan-Kabel und wenn möglich netzwerkarten. Ggf mal die ganze Kidte falls möglich. Testweise evtl auch in ne vm vermute Hardware Problem.

Schau gerne auch mal ins Wiki bzgl Hardware.

P.s. Neues Forum: https://community.ipfire.org/
Grüße/Regards

Image

Post Reply