Gelöst Kernel Meldungen Martian RED 0 bei UM FB 6360 DS-Lite

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: HILFE Kernel Meldungen Martian RED 0

Post by sammydk » September 9th, 2013, 5:12 pm

Hallo Bernhard,
das hört sich logisch an, kann es aber eigentlich nicht sein, oder der Auslöser war beim Runter fahren des Rechners bzw. Der Rechner der diese IP aus dem RED Netz anfragt, war zu einem Fehlerbild die ganze Nacht aus und während dieser Zeit über Stunden nur noch Marsieaner, bis zum Reboot der IPF.
Passt aber zu deiner Erklärung, da nur noch zwei AP in Green waren, die IPF und die FB, mehr nicht.
Möglich wäre, dass das beim Ausschalten noch die Ursache gewesen wäre, und das Ganze wie eine ARP Flut in RED sein könnte nur zwischen IPFIRE und FB.
Aktuell habe ich diese IP-Abfrage aber noch nicht bereinigt, da ich den DUMP sehen will.
Einzige Änderung ist die Ergänzung des dyn. DHCP Bereiches, was mir aber auch nicht unbedingt einleuchten tut.
Aber wenn Du von exposed-host sprichst, hatte ich diesen eingeschaltet für die IP der IPF, da ich aber wegen eines IPV6 Problem mit UM auf Kriegsfuß stehe, da es AVM nach einer IPV6 Präfixänderung nicht schafft den IPv4 Tunnel wieder aufzubauen, hilft bei der Fritte nur der Reboot, in dem Sinne hatte ich auch zwischendurch mal die FB auf Werkreset gesetzt, damit war natürlich der exposed-host wieder weg und z.Zt ist dieser auch nicht eingeschaltet.
Z.Zt. läuft trotz der nicht vorhandenen IP in RED alles wieder super.
Ich schau mir das mal weiter an, und stelle mal an den einzelnen Rädchen so nach und nach, es muss doch auch mal wieder Auftreten.
Beruhigend ist das nicht, außer deine einleuchtende Erklärung.

Besten Dank schon mal vorab, aber wenn man sich mit jemandem abstimmen kann, erleichtert das doch die Fehlersuche.
Ich dachte schon, ich wäre hier Alleinunterhalter und schreibe einen Roman.
Last edited by sammydk on September 9th, 2013, 5:29 pm, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: HILFE Kernel Meldungen Martian RED 0

Post by sammydk » September 10th, 2013, 8:09 am

So neue Erkenntnisse,
ich habe mittlerweile zwei IPFIRE Systeme an der FB hängen (IPFIRE1 & IPFIRE2), um hier die Ursache eingrenzen zu können, bzw. Endgeräte auszuschließen.
Bei der IPFIRE1 ist der Switch der an Green hängt seit gestern Abend 22:00 Uhr aus, damit ist auch green down.
Sieht man daran, das Green heute Morgen um 7:38 UP wird, zeitgleich mit dem Switch habe ich das SIP Telefon eingeschaltet, das ja direkt an der Fritte hängt.
IPFIRE2 ist sowohl auf RED als auch auf GREEN online gewesen.
Beide Firewall-Systeme liefern aber seit gestern Nacht Marsianer Pakete auf Red.
Leider habe ich das heute Morgen nicht direkt bemerkt, so das sich das Ganze ab Verbindungsaufbau über IPFire1 per VPN zur Firma wieder verflüchtigt hat, bzw. durch das Einschalten des SIP Telefones weg ist.
Sieht mir fast so aus, als ob die Ursache eher auf der Fritte liegt, da beide Firewalls das gleiche Problem haben. Scheinbar liefert die Fritte auf den ARP nichts mehr, was aber wiederum merkwürdig ist, nachdem mein Firmen PC per DHCP von IPFire1 eine IP bekommen hat, die VPN Verbindung aufgebaut hat, geht alles wieder.
Nur kann ich zeitlich nicht sagen, ob es bei der DHCP Versorgung des Clients schon ging oder erst durch den VPN Aufbau.
Auf dem Firewall-Systemen sieht man im IPFIRE LOG, das der NTP Update nicht funktioniert hat und das wiederum bei beiden Systemen. Ich könnte diese FB echt in die Tonne treten.
Wer hat noch einen UM Anschluss mit einer FB 6360 und einer IPFIRE dahinter.
Das ist mittlerweile schon die dritte FB6360 von UM, Fehlerbild ist allerdings das DS-LITE Problem, Fehlerbild mit Marsianer hatte ich bei allen drei.
Das einzige, was in dem RED Verbindungsnetz sich noch befindet ist ein SIP Telefon, das auch direkt an der FB hängt, das wurde gestern aber mit dem Switch zusammen ausgeschaltet, auch der PC der das Monitoring macht, der in Green an IPFIRE 1 hängt lief allerdings nicht. Schade , das ich immer noch keinen DUMP habe
Last edited by sammydk on September 10th, 2013, 8:49 am, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

BeBiMa
Posts: 2805
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: HILFE Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by BeBiMa » September 10th, 2013, 9:32 am

Hallo Dietmar,

dies ist wirklich strange.
Könntest Du bitte noch mal kurz Deine Konfiguration auf der WAN-Seite ( IPFire, FB, SIP ) zusammenfassen?
Hast Du auf der FB die Möglichkeit die Logs des DOCSIS-Modems zu lesen. Nicht dass der Effekt durch Konfigdefizite auf der Strecke von UM erzeugt wird.
Ich kann mich schwach erinnern, dass ich auch mal so einen Fall bei KabelBW hatte. Durch den weniger komplexen Aufbau ( Cable <--> Modem <--> IPFire bzw. IPCop ) war das Problem leichter eingrenzbar und nachdrückliche Beschwerden beim ISP haben das Problem aus der Welt geschafft ( und damit aus meiner Erinnerung gestrichen :( )

BTW: Ich habe mir erlaubt, das Thema etwas anzupassen.
Last edited by BeBiMa on September 10th, 2013, 9:37 am, edited 1 time in total.
Image
Unitymedia Cable Internet ( 32MBit )

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: HILFE Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by sammydk » September 10th, 2013, 9:56 am

Hallo Bernhard,
ich habe mir mal beide messages Log von den IPFIRE gezogen, kannst Du dir die mal anschauen, so ab 9 Sept 21:56 fangen die Marsianer an, Sekunden vorher sieht man das bei IPFIRE 1 green down geht, da ich hier den angeschlossenen Switch ausgeschaltet habe, und an der gleichen Stromversorgung hängt auch das SIP Telefon was Ethernettechnisch an der FB hängt, auch aus.
bei der IPFIRE2 sind jede Mende DHCP Anforderuneg der Adresse 20 zu sehen, was mir auch schleierhaft ist.
Kannst Du mir mal deine Emailadresse per PN schicken über die Board eMail kann ich keine Dateien anhängen. Dann kann ich auch mal kurz den HW Aufbau dokumentieren und liefern.
Last edited by sammydk on September 10th, 2013, 10:40 am, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: HILFE Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by sammydk » September 10th, 2013, 10:41 am

Daten sind unterwegs
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: HILFE Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by sammydk » September 10th, 2013, 11:32 am

Ggf. hat das was mit der bescheuerten Green Funktion auf der FB zu tun.
Ich komme darauf, weil exakt mit dem Ausschalten des SIP Telefons die Problematik beginnt. Ich weiß allerdings nicht was der Auslöser in der FB ist.
Was wenn die auf ein log Paket schauen, was von den IPFIRE Boxen gedropt wird?
Habe hierzu im Inet eine Einstellung gefunden, die es bei meiner Version nicht mehr gibt. Ich kann nur noch zwischen 1GBit und 100 MBit wählen, ob noch weiter der ECO Mode evtl. die Ports log. abschaltet, weiß ich nicht.
Meine zwei IPFIRE stehen auf GBit, das SIP auf 100 MBit. ob das aber jetzt auf Automatik steht kann ich nicht sagen.
Geblocht wird hier permanent ein Mulicastpaket von der FB.

Code: Select all

Sep  9 23:28:09 ipfire1 kernel: ll header: ff:ff:ff:ff:ff:ff:00:22:4d:89:3c:f5:08:06
Sep  9 23:28:10 ipfire1 kernel: martian source 192.168.178.1 from 192.168.178.254, on dev red0
Sep  9 23:28:10 ipfire1 kernel: ll header: ff:ff:ff:ff:ff:ff:00:22:4d:89:3c:f5:08:06
Sep  9 23:28:23 ipfire1 kernel: DROP_INPUT IN=red0 OUT= MAC=01:00:5e:00:00:01:9c:c7:a6:25:d1:64:08:00 SRC=192.168.178.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 MARK=0xd2
Sep  9 23:28:23 ipfire1 kernel: DROP_INPUT IN=red0 OUT= MAC=01:00:5e:00:00:01:9c:c7:a6:25:d1:64:08:00 SRC=192.168.178.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 MARK=0xd2
Sep  9 23:28:38 ipfire1 kernel: martian source 192.168.178.1 from 192.168.178.254, on dev red0
Sep  9 23:28:38 ipfire1 kernel: ll header: ff:ff:ff:ff:ff:ff:00:22:4d:89:3c:f5:08:06
Sep  9 23:28:39 ipfire1 kernel: martian source 192.168.178.1 from 192.168.178.254, on dev red0
Sep  9 23:28:39 ipfire1 kernel: ll header: ff:ff:ff:ff:ff:ff:00:22:4d:89:3c:f5:08:06
Sep  9 23:28:40 ipfire1 kernel: martian source 192.168.178.1 from 192.168.178.254, on dev red0
Last edited by sammydk on September 10th, 2013, 11:36 am, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: HILFE Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by sammydk » September 10th, 2013, 12:06 pm

Hallo Bernhard,
ich kann die Marsianer reproduzieren  :D. Das glaubt man kaum.
Der Gedanke an Green IT mit der FB hat mich drauf gebracht.
Ich habe also das SIP Telefon abgeschaltet und umgehend treten auf beiden IPF Marsianer auf.
Ich habe das ganze dann mit TCPDUMP für red und green getraced.

Schick ich dir per Mail.
Last edited by sammydk on September 10th, 2013, 1:05 pm, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

BeBiMa
Posts: 2805
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: HILFE Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by BeBiMa » September 10th, 2013, 12:17 pm

Der Gedanke kam mir auch gerade,als ich die Adressierung durchgesehen habe.
Die Marsianer sehen aus,als ob die ARP-Pakete von IPFire.red ( 192.168.178.254 ) an FB( 192.168.178.1 ) gespiegelt würden. Die Quell-MAC des Ethernet-Frames, der von red0 empfangen wird, ist die MAC von red0.  Und das kann nicht sein --> "Eindringlinge vom Mars".
Sieht so aus, als ob bei abgeschaltetem SIP ein nicht abgeschlossenes Netzwerk-Kabel am Switch des FB anliegt. ( Das Problem kenne ich eigentlich nur noch aus alten Koax-Ethernet-Tagen  ::) )
Image
Unitymedia Cable Internet ( 32MBit )

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: Lösung in Sicht Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by sammydk » September 10th, 2013, 12:27 pm

Koaxial.-Yellow Cabel,Token Ring, FDDI, ARCNet usw. das waren noch Pionierzeiten, habe selber bis vor 10 Jahren Cisco, Enterasys und Extrem Networks Netze gebaut und konfiguriert. Angefangen mit Hirschmann und Retrix, seit dem ITIL Servicemanager und weg von der phys. Arbeit.
Alles nur noch Hobby.
Aber jetzt mal zum Thema, ich werde das SIP Telefon mal direkt am FB abziehen, denn es wird über einen POE Adapter direkt mit dem Phone verbunden, evtl. liegt hier ja auch das Problem begraben.
Melde mich gleich.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: Lösung in Sicht Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by sammydk » September 10th, 2013, 12:54 pm

So es ist definitiv das Telefon,
habe erst mal von UTP auf STP die Verkabelung ausgetauscht ohne Erfolg.
Dann habe ich die Stromversorgung direkt an dem Telefon angeschlossen also ohne POE.
kein Erfolg.
Solange das Telefon Strom bekommt, ist alles gut. Schalte ich es jetzt wieder ab, kommen lauter grüne Männchen.
Ziehe ich das Telefon an der FB ab auch alles gut.
Ich kann das Telefon ja mal austauschen, sitze ja an der Quelle.
Hauptsache die Ursache ist erst mal eingegrenzt. Ob das mit dem CMOS Technik in der FB zusammen hängt, solche Fehlerbilder gibt es bei unsern Kunden nicht, die haben aber auch keine FB,
Dieses Fehlerbild gab es vor der FB auch nicht, als ich das Telefon an der IPF Asterisk im Homenetz betrieben habe und das Telefon an einem anständigen Switch hing.
Das ist überhaupt noch mal ein Test wert, ich schalte mal einen Switch zwischen FB und Telefon, mal schauen ob dann alles weiter rund läuft, wenn ich das Telefon abschalte und der Switch an bleibt.
Leider sind die Telefone bei uns EOS da es andere gibt.

Bin ich froh  ;D ;D ;D ;D 8), hoffentlich ist nicht noch was.

Danke erst mal
Last edited by sammydk on September 10th, 2013, 1:09 pm, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

BeBiMa
Posts: 2805
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: Lösung in Sicht Kernel Meldungen Martian RED 0 bei UM DS-Lite

Post by BeBiMa » September 10th, 2013, 1:54 pm

Die Analyse deiner Logs bestätigt Deine Vermutung. :(
Mit Abschalten der Spannungsversorgung des SIP, dies ist laut Deiner Beschreibung identisch mit green0 down auf ipfire1, ist das Netzwerk FB <---> ipfire1/2 nicht mehr nutzbar.
ARPs werden gespiegelt, DNS ist nicht mehr möglich.

Da die FB den Übergabepunkt Deines ISP darstellt ( bzgl. IP-Verkehr ) kann ich nur empfehlen, UM "auf die Füsse zu steigen". Mit dieser Konfig ist jedenfalls von deren Seite keine Verfügbarkeit von >90% ( oder was auch immer garantiert wird) realisierbar.
Image
Unitymedia Cable Internet ( 32MBit )

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: Gelöst Kernel Meldungen Martian RED 0 bei UM FB 6360 DS-Lite

Post by sammydk » September 10th, 2013, 1:59 pm

Ja OK,
aber die Ursache liegt ja an der Konstellation Telefon und FB.
Ich werde das Telefon mal gegen ein anderes tauschen und mal sehen ob die Marsianer wieder auftauchen, ich weiß ja jetzt wie ich sie erzeugen kann. Da ein angeschlossener Switch An oder AUS keine Probleme macht, sehe ich hier eher das Problem in dem SIP Gerät.

Also hier noch mal ein kurzer Status zu dem SIEMENS OptiPoint 420 an FB 6360.
Ich habe jetzt mal einen Netgear Fast Ethernet Switch zwischen Telefon und FB gebaut.
Alles läuft stabil, egal ob Telefon  An oder AUS, Auch bleibt alles stabil, wenn ich den Switch an der FB An oder AUS habe, nur die Konstellation Telefon direkt an FB löst die MARTIAN Pakete auf der IPFIRE auf RED0 aus. Der Trace zeigt, das alle ARP Anfragen an die FB nicht mehr beantwortet werden, wenn das Telefon zwar an der FB angeschlossen ist aber nicht mit Spannung versorgt wird, es verhält sich wie ein LOOP, läuft das Telefon ist alle OK.

Man Man Man, war das eine verflixte Suche, danke an BeBiMa, der in der Diskussion mit mir nicht locker ließ.
Ich werde heute Abend mal wieder auf eine IPFIRE zurück bauen, wer braucht schon zwei Systeme für ein Homenetz.  ;)
Da fällt mir noch ein, das ich auf Grund diverser nicht erklärbarer Probleme den DHCP der FB abgeschaltet habe und alles in dem Transportnetz auf statische IP eingestellt habe, sollte das jetzt auch wieder gehen, da auch hier die IPFIRE von der FB keine IP erhalten hatte, da das Telefon AUS war  ::) und ich von Marsianern zu der Zeit noch nichts wusste.
Last edited by sammydk on September 10th, 2013, 2:10 pm, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

BeBiMa
Posts: 2805
Joined: July 30th, 2011, 12:55 pm
Location: Mannheim

Re: Gelöst Kernel Meldungen Martian RED 0 bei UM FB 6360 DS-Lite

Post by BeBiMa » September 10th, 2013, 2:15 pm

Danke für das Lob :-[ , dafür ist das Forum ja da.

Allerdings hast Du auch genügend Informationen beigesteuert, die eine Eingrenzung erst möglich gemacht haben.
Image
Unitymedia Cable Internet ( 32MBit )

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: Gelöst Kernel Meldungen Martian RED 0 bei UM FB 6360 DS-Lite

Post by sammydk » September 10th, 2013, 2:19 pm

Ja danke noch mal,
vier Augen sehen doch mehr als zwei.
Ich habe jetzt auch schon krumme Finger vom schreiben.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

sammydk
Posts: 761
Joined: July 8th, 2012, 2:50 pm
Location: NRW

Re: Gelöst Kernel Meldungen Martian RED 0 bei UM FB 6360 DS-Lite

Post by sammydk » September 10th, 2013, 7:30 pm

So, das hat mir doch keine Ruhe gelassen.
Mal für die Nachwelt, vielleicht hat ja mal jemand so ein Gerät an einer FB.
Habe mir gerade noch mal von einem Kollegen ein weiteres OptiPoint 420, noch in Originalverpackung, besorgt und auch ein Openstage60 beides SIP und in der neusten Firmwareversion, was aber ohne Spannung auch nichts ausmacht.

OP420 an die FB angeschlossen, ohne Spannung und siehe da, da sind sie wieder die Marsianer.
OS60 an die FB angeschlossen, ohne Spannung und es bleibt alles ruhig, keine Außerirdischen.

Für mich ist klar, auch wenn die FB in dieser Ausführung nicht das Geilste ist, aber die Ursache liegt an der Kombination FB und Telefon, was auch immer der Switch der FB durch ein abgeschaltetes Telefon erkennt, er tut das durch diese Kombination.
Das Telefon an einem HP oder Netgear oder gar ein Extreme Switch tut genau das was es soll auch im ausgeschalteten Zustand nur nicht an dem FB6360 Switch.
Last edited by sammydk on September 10th, 2013, 7:34 pm, edited 1 time in total.
Gruß Dietmar
@ HOME 150 MBit Down/ 10 MBit Up by UM IPv4 ;-)
Image
Testsystem
Image

Post Reply