[SOLVED] 4G Configuration - ZTE MF 823

General questions.
Post Reply
dkdlv
Posts: 4
Joined: April 7th, 2018, 11:02 am

[SOLVED] 4G Configuration - ZTE MF 823

Post by dkdlv » April 7th, 2018, 11:20 am

Hi everyone!

I'm stuck trying to configure a 4G USB stick.

The model I have is a ZTE MF823, is supposed to work out of the box (as stated here https://wiki.ipfire.org/hardware/networking), so I guess I'm doing something wrong, but as I'm no expert and my searches didn't help me to solve this issue, here I am, asking your help !

The stick is configured in the WUI like that :

Image


Some things I have noted :
lsusb shows me that (which is supposed to be good from what I see here : https://wiki.archlinux.org/index.php/ZT ... 9_4G_Modem) ):

Code: Select all

[root@ipfire ~]# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 19d2:1405 ZTE WCDMA Technologies MSM
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
But where I should have (from the compatibilty list):

Code: Select all

Bus 002 Device 002: ID 19d2:1403 ZTE WCDMA Technologies MSM
So is this a misconfiguration of USB_modeswitch ?


in /var/log/message, I have this :

Code: Select all

Apr  7 12:54:10 ipfire pppd[6716]: unrecognized option '/dev/ttyUSB0'
Apr  7 12:54:10 ipfire connectd[6718]: Connectd (start) started with PID 6718
Apr  7 12:54:10 ipfire connectd[6718]: No pppd is running. Trying reconnect.
Apr  7 12:54:10 ipfire connectd[6718]: Reconnecting: Attempt 1 of 5
Apr  7 12:54:30 ipfire kernel: usb 2-1: USB disconnect, device number 2
Apr  7 12:54:30 ipfire kernel: cdc_ether 2-1:1.0 red0: unregister 'cdc_ether' usb-0000:00:14.0-1, CDC Ethernet Device
Apr  7 12:54:40 ipfire connectd[6718]: Exiting gracefully connectd with PID 6718.
Apr  7 12:54:44 ipfire kernel: usb 2-1: new high-speed USB device number 3 using xhci_hcd
Apr  7 12:54:44 ipfire kernel: usb 2-1: New USB device found, idVendor=19d2, idProduct=1225
Apr  7 12:54:44 ipfire kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr  7 12:54:44 ipfire kernel: usb 2-1: Product: ZTE Technologies MSM
Apr  7 12:54:44 ipfire kernel: usb 2-1: Manufacturer: ZTE,Incorporated
Apr  7 12:54:44 ipfire kernel: usb 2-1: SerialNumber: MF8230ZTE##########################_35162H2B&&&&&&&&&&&&&&&&&&0
Apr  7 12:54:44 ipfire kernel: usb-storage 2-1:1.0: USB Mass Storage device detected
Apr  7 12:54:44 ipfire kernel: usb-storage 2-1:1.0: Quirks match for vid 19d2 pid 1225: 1
Apr  7 12:54:44 ipfire kernel: scsi3 : usb-storage 2-1:1.0
Apr  7 12:54:44 ipfire usb_modeswitch: switch device 19d2:1225 on 002/003
In the /dev folder, I have no ttyUSBX entries...

The sticks works on Windows.

Every help is welcome!

Thanks in advance,
Krys
Attachments
IPFire-dialup.JPG
Last edited by dkdlv on April 7th, 2018, 2:01 pm, edited 1 time in total.

dkdlv
Posts: 4
Joined: April 7th, 2018, 11:02 am

Re: 4G Configuration

Post by dkdlv » April 7th, 2018, 12:25 pm

Hmm, seems I'm wrong trying to use dialup as it seems to works as a an ethernet NIC (DHCP seems to work).

Now, the question is how can I set the APN & PIN code using the CLI...

rodneyp
Posts: 122
Joined: October 4th, 2010, 2:17 am
Location: Australia

Re: 4G Configuration

Post by rodneyp » April 7th, 2018, 12:48 pm

I doubt if you can or need to, although it might depend on how you ISP has configured it

Key thing is to set it to "autoconnect" - you need to browse to its IP address, tjhen set that from the menu.

See: http://ofmodemsandmen.com/hostless.html

dkdlv
Posts: 4
Joined: April 7th, 2018, 11:02 am

Re: 4G Configuration

Post by dkdlv » April 7th, 2018, 2:00 pm

I got it working removing the PIN code from Windows and I'm now using it to answer you... Thanks a lot for your advice !

(And thinking it twice, it doesn't seem to be mandatory as I can reach the red gateway (the dongle) from the green interface. (I was not able to do so just before, but I think it was my pluging/unpluging that didn't help me, works after a reboot)

robbo100
Posts: 16
Joined: April 23rd, 2016, 11:37 am

Re: [SOLVED] 4G Configuration - ZTE MF 823

Post by robbo100 » February 5th, 2019, 5:53 pm

Hi @dkdlv

I have just got the same modem (ZTE MF 823) and am having difficulty connecting to the internet. It works when I connect using a Windows 10 PC, but can't see the dev/ttyUSBX anywhere on the ipfire.

The wiki says that it is detected as Red0, as a network device, but when the it boots, ipfire says that there is no device connected on red, despite being correcty setup in the initial installation configuration.

Can you talk me through exactly how you configured your system please, I would be very grateful.

Did you set it up as PPPoE in the end, rather than Modem?

Thanks

Robbo100

rodneyp
Posts: 122
Joined: October 4th, 2010, 2:17 am
Location: Australia

Re: [SOLVED] 4G Configuration - ZTE MF 823

Post by rodneyp » February 6th, 2019, 1:39 am

It's a while since I used my with IPFire.

It is critical that it be set to "autoconnect" and AFAIK, that can be done only from Windows, but the procedure is set by the vendor and YMMV.

When installing IPFire, it should then appear as another "card", in setup -> networking -> drivers & card assignments, where it needs to be selected as RED

In setup -> address settings -> red, DHCP should definitely work. You could try a static address in the same net, but IIRC, it responded fairly quickly to DHCP and there would be little advantage.

robbo100
Posts: 16
Joined: April 23rd, 2016, 11:37 am

Re: [SOLVED] 4G Configuration - ZTE MF 823

Post by robbo100 » February 6th, 2019, 11:36 am

Hi @rodneyp

Thanks for your help.

For some reason, I still can't get it to work.

I have used a windows laptop to set the APN details etc, and set it to autoconnect. Now when the IPFire machine boots up, the blue light flashes to say that it is connected to the internet.

This means that the ZTE MF 823 should effectively act as a ethernet device (with built-in router to connect to the internet).

I have run ipfire setup and selected DHCP for red0, but when I boot I get

Code: Select all

Bringing up the red0 interface...
Interface red0 doesn't exist.
I did manage to get it to connect momentarily by selecting a static IP for red0, setting it to 192.168.0.1 (which is the MF 823 IP address), but the ipfire setup froze and although showing connected in the ipfire web interface. It didn't route to the internet.

Any thoughts?

Thanks again

Robbo100

robbo100
Posts: 16
Joined: April 23rd, 2016, 11:37 am

Re: [SOLVED] 4G Configuration - ZTE MF 823

Post by robbo100 » February 6th, 2019, 12:11 pm

I just realised that the ip address of the MF 823 is 192.168.0.1, so that is probably why it hung! :D

robbo100
Posts: 16
Joined: April 23rd, 2016, 11:37 am

Re: [SOLVED] 4G Configuration - ZTE MF 823

Post by robbo100 » February 6th, 2019, 1:25 pm

But even with a correct static IP, it still doesn't work

rodneyp
Posts: 122
Joined: October 4th, 2010, 2:17 am
Location: Australia

Re: [SOLVED] 4G Configuration - ZTE MF 823

Post by rodneyp » February 7th, 2019, 9:40 pm

After IPFire boots, activate SSH access and log in via terminal.

Then run setup and remove the RED interface device.

You will probably need to exit setup and re-start it. Then add the MF823 back as RED device.

How it should be configured might vary between Telcos (mine is with Telstra, Australia). DHCP is likely to be the most reliable address setting.

If this workaround gets it working, then I don't know what the fundamental problem is. I am currently having BananaPi give me the same error message, from core 127, for the USB-Ethernet device that I use as RED.

Post Reply