Page 1 of 1

URL Filter Not Working

Posted: July 10th, 2018, 9:40 am
by uzidesign
* transparent proxy enabled

Hi all,

I install IPfire on apu4b4. but the apu4b4 it's not my router (the reason is that I have 1G fiver and when I'm using IPfire as router the speed drop to around 500mb)
So I let the router to connect (PPPoE) add then The IPfire comes.
Router -> IPfire -> computers

The problem is when I do that, the URL filter not working / blocking.

What can I do?

Best Regards,
Oz

Re: URL Filter Not Working

Posted: July 10th, 2018, 10:27 am
by Aurien
Need more details on how your network is setup. Is the Router connection to IPFire on a RED network and the Computer on a GREEN network? This is how you'll have to have IPFire setup for URL filtering to work.

Router IPFire Computer

Re: URL Filter Not Working

Posted: July 10th, 2018, 2:00 pm
by uzidesign
Yes. this is my network setup Router IPFire Computer.

nslookup
Default Server: ipfire.localdomain
Address: 192.168.10.254
T1.JPG
T2.JPG
T3.JPG

Re: URL Filter Not Working

Posted: July 10th, 2018, 5:03 pm
by TimF
My understanding is that the transparent proxy will not work for https connections - which is the majority of connections these days. It's a function of the way that https works. This means that the URL filter doesn't work.

Re: URL Filter Not Working

Posted: July 11th, 2018, 7:12 am
by donaldo
Hi

but if we redirect the port 80 to the 443 of the proxy?
it Can Work?
it is possible to make a setting like this in the proxy setting?

Thanks
Donatello

Re: URL Filter Not Working

Posted: July 11th, 2018, 7:19 am
by uzidesign
But it's not working for http connections also.

Re: URL Filter Not Working

Posted: July 11th, 2018, 7:22 am
by donaldo
are you sure?

facebook work only on https connection

Re: URL Filter Not Working

Posted: July 11th, 2018, 7:52 am
by uzidesign
Facebook in the custom block for testing Only.
See above in the Filter settings, I have selected URL filters by groups also.