proxy filter web page

General questions.
Post Reply
ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

proxy filter web page

Post by ipfire987 » February 8th, 2019, 7:35 pm

hey

i successfully installed IPFire in the raspberry.
I use an ethernet cable for the red interface.
And i use a ethernet adapter for the green interface.

So now i can access to the web interface of IPFire.

i can't block some web site for example facebook or youtube...
I write this web site in the page of black liste box.
I Enabled on Green: OK
Transparent on Green: OK

I save i restart nothing change...


I try with transparent on green off and i manual add a proxy in the browser : don't work too

If you have a question ask me i will answer directly

Can somebody help me
Thanks a lot

cfusco
Posts: 148
Joined: March 23rd, 2015, 4:19 pm

Re: proxy filter web page

Post by cfusco » February 8th, 2019, 8:31 pm

The problem is that you can still connect to a blacklisted website or you cannot load any website? I suppose you checked url filter in the web interface of the proxy, right? Can you go to logs/url filter logs and see what do you have there?
Image

ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

Re: proxy filter web page

Post by ipfire987 » February 9th, 2019, 12:25 am

thanks for your reply

the problem is i can still connect to a blacklisted website
yes i check the "Enable custom blacklist:" near the blacklist

when i go to url/filter log and i select URL FILTER i have this :
Total number of URL filter hits for February 8: 0

that's mean it's not working i think

ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

Re: proxy filter web page

Post by ipfire987 » February 9th, 2019, 12:47 pm

when i do nslookup www.google.com
i see the box server adresse IP instead of the IPFire IP
aaa.png
bbb.jpg

ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

Re: proxy filter web page

Post by ipfire987 » February 9th, 2019, 12:49 pm

ccc.png
thanks a lot for all replys

ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

Re: proxy filter web page

Post by ipfire987 » February 9th, 2019, 12:53 pm

ddd.jpg
eee.jpg

ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

Re: proxy filter web page

Post by ipfire987 » February 9th, 2019, 12:59 pm

ggg.png
fff.png

ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

Re: proxy filter web page

Post by ipfire987 » February 9th, 2019, 3:44 pm

i add DNS in the red interface by public DNS
ok.png

User avatar
FischerM
Community Developer
Community Developer
Posts: 984
Joined: November 2nd, 2011, 12:28 pm

Re: proxy filter web page

Post by FischerM » February 9th, 2019, 3:52 pm

Hi,

I would recommend you make yourself (at least) comfortable with the (two) URLFilter pages which can be found in the IPFire wiki - and the wiki itself(!):

https://wiki.ipfire.org/configuration/n ... url-filter
and
https://wiki.ipfire.org/configuration/n ... url-filter

IMHO your main problem is - seen in your screenshots - that you didn't activate even one of the example block categories.

Go down on that page and choose one of the external lists (e.g):
Image

But be careful! Since you are running this
ipfire987 wrote:...in the raspberry...
you'll have to wait some time until the downloaded list will be ready to use. I don't know how such machines get along with the urlfilter.

So be (very) patient - just like the Blacklist update hint tells you: "The new blacklist will be automatically compiled to prebuilt databases. Depending on the size of the blacklist, this may take several minutes. Please wait for this task to be finished before restarting the URL filter."

Then, choose your categorie(s) to block and see...

HTH,
Matthias

ipfire987
Posts: 10
Joined: January 3rd, 2019, 1:21 pm

Re: proxy filter web page

Post by ipfire987 » February 9th, 2019, 4:39 pm

your main problem is - seen in your screenshots - that you didn't activate even one of the example block categories.

i think it's not an obligation to active this, normaly it's must work only with Custom blacklist that i enable

when i try to upload one of the external lists it's quickly refresh but nothing appear.

I think the problem is that :
in primary DNS this is not the IP adresse of IPFire but of the BOX (FAI)
IPFire adresse is 192.168.10.1 not 192.168.1.1
Capture d’écran de 2019-02-09 17-37-16.png

thanks for your answer Matthias

Post Reply