Sites timeout with Proxy enabled.

General questions.
Post Reply
dansport

Sites timeout with Proxy enabled.

Post by dansport » April 8th, 2010, 9:27 am

I recently ventured into the the life of ipfire - previously running ipcop.

Currently I have one domain that does not work : http://cc2.onstate.net
When i disable the proxy the sites works fine (call center software)
When I enable the proxy the site dies, it uses standard port 80 for communication, I have tried specifieng not to cache this site but it still doesnt work when the proxy is enabled.


Any advice would be appreciated.


My current setup:

Common settings
Enabled on Green: Proxy port:
Transparent on Green: Visible hostname: *
 
  Error messages language:
Suppress version information: Error messages design:
Squid cache version: [ 2.7.STABLE7 ]  
Number of filter processes
Processes URL filter
Enabled
+ 13 Update accelerator
Enabled
+ 11

Do not cache these domains (one per line): *
cc2.onstate.net onstate.net onstate.com


Allowed standard ports (one per line): Allowed SSL ports (one per line):
80 # http 21 # ftp 443 # https 563 # snews 70 # gopher 210 # wais 1025-65535 # unregistered ports 280 # http-mgmt 488 # gss-http 591 # filemaker 777 # multiling http 800 # Squids port (for icons) 443 # https 563 # snews
Network based access control

User avatar
Maniacikarus
Core Developer
Core Developer
Posts: 6210
Joined: February 24th, 2006, 10:35 am
Location: Nürnberg
Contact:

Re: Sites timeout with Proxy enabled.

Post by Maniacikarus » April 8th, 2010, 9:29 am

Well I´am getting

Forbidden
You don't have permission to access / on this server.

when trying to access http://cc2.onstate.net
Image


dansport

Re: Sites timeout with Proxy enabled.

Post by dansport » April 8th, 2010, 9:32 am

Sorry ... The requested URL could not be retrieved
IPFire


   While trying to retrieve the URL: http://cc2.onstate.net/

   The following error was encountered:

       * Connection to 63.210.44.138 Failed

   The system returned:

       (110) Connection timed out

   The remote host or network may be down. Please try the request again.

   Your cache administrator is webmaster.

Generated Thu, 08 Apr 2010 09:25:33 GMT by (squid)

User avatar
Maniacikarus
Core Developer
Core Developer
Posts: 6210
Joined: February 24th, 2006, 10:35 am
Location: Nürnberg
Contact:

Re: Sites timeout with Proxy enabled.

Post by Maniacikarus » April 8th, 2010, 9:33 am

Image

dansport

Re: Sites timeout with Proxy enabled.

Post by dansport » April 8th, 2010, 9:35 am

I tried the redirected URL but get the same result.

User avatar
Maniacikarus
Core Developer
Core Developer
Posts: 6210
Joined: February 24th, 2006, 10:35 am
Location: Nürnberg
Contact:

Re: Sites timeout with Proxy enabled.

Post by Maniacikarus » April 8th, 2010, 9:40 am

Need to check this @home, don´t have a fire here, but the squid here resolves the url
Image

dansport

Re: Sites timeout with Proxy enabled.

Post by dansport » April 8th, 2010, 9:42 am

Thank you

I have also noticed that when I click the clear cache button for that time period the site will connect again. once the clear cache is complete it times out, it almost seems like the site is being cached even with the domain being added as an exclusion

Regards
Dan

User avatar
Maniacikarus
Core Developer
Core Developer
Posts: 6210
Joined: February 24th, 2006, 10:35 am
Location: Nürnberg
Contact:

Re: Sites timeout with Proxy enabled.

Post by Maniacikarus » April 8th, 2010, 9:50 am

Clear Cache stopes the proxy for that period of time, thats why its working
Image

dansport

Re: Sites timeout with Proxy enabled.

Post by dansport » April 8th, 2010, 9:58 am

Understood, Disabling the proxy ant content filter for now.

User avatar
Maniacikarus
Core Developer
Core Developer
Posts: 6210
Joined: February 24th, 2006, 10:35 am
Location: Nürnberg
Contact:

Re: Sites timeout with Proxy enabled.

Post by Maniacikarus » April 8th, 2010, 4:18 pm

I´ve tried it and the page took a while to be loaded but after this i was displayed the login from the page http://cc2.onstate.net/order_talk/oa/oa.html
Image

dansport

Re: Sites timeout with Proxy enabled.

Post by dansport » April 9th, 2010, 7:53 am

I just retested without the proxy it comes up immediately, with proxy enabled it makes the initial connection I can see that in my Firefox tab but after a while it gives the timeout.  Not sure what could cause this the ipfire is Vanilla and newly set up...  I will set up another box with ipcop and test if I get the same results my previous ipcop install didn't have this problem. I will then compare and see if anything changed.

Regards
Dan

User avatar
makara
Posts: 11
Joined: March 16th, 2013, 8:25 pm
Location: New Zealand

Re: Sites timeout with Proxy enabled.

Post by makara » February 20th, 2019, 10:23 pm

Hi Dan.

Did you ever solve this? I have exactly the same problem with the website
http://gw.govt.nz/


Cheers


David

cfusco
Posts: 184
Joined: March 23rd, 2015, 4:19 pm

Re: Sites timeout with Proxy enabled.

Post by cfusco » February 21st, 2019, 10:26 am

makara wrote:
February 20th, 2019, 10:23 pm
Hi Dan.

Did you ever solve this? I have exactly the same problem with the website
http://gw.govt.nz/


Cheers


David
I just tried, I have no problem loading the site with IPFire Squid proxy using firefox on mac os. Logs enclosed.

Code: Select all

IPFire proxy log
Date: February 21, 2019
Source IP: ALL
Username: ALL
Ignore filter: [.](gif|jpeg|jpg|png|css|js)$
----redacted-----
11:22:30 127.0.0.1 - http://gw.govt.nz/
11:22:32 127.0.0.1 - http://www.gw.govt.nz/
11:22:32 10.1.4.26 - http://gw.govt.nz/
11:22:32 127.0.0.1 - http://www.gw.govt.nz/
11:22:34 10.1.4.26 - http://www.gw.govt.nz/
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/layout.css?m=1435873655
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/constituency.css?m=1408052441
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/typography.css?m=1433907431
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/form.css?m=1408052441
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/gwrc.css?m=1448317637
11:22:34 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/constituency.css?m=1408052441
11:22:34 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/layout.css?m=1435873655
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/print.css?m=1408052441
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/grid.css?m=1432095459
11:22:34 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/css/font-awesome.min.css?m=1438662325
11:22:34 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/form.css?m=1408052441
11:22:34 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/typography.css?m=1433907431
11:22:35 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/grid.css?m=1432095459
11:22:35 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/font-awesome.min.css?m=1438662325
11:22:35 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/print.css?m=1408052441
11:22:35 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/javascript/thickbox/thickbox-code/thickbox.css?m=1334202262
11:22:35 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/css/gwrc.css?m=1448317637
11:22:35 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/javascript/thickbox/thickbox-code/thickbox.css?m=1334202262
11:22:36 127.0.0.1 - http://www.gw.govt.nz/assets/Home-Page-Banners/bg-header-scene-21.jpg?date=20190221
11:22:36 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/fonts/fontawesome-webfont.woff2?v=4.3.0
11:22:36 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/fonts/fontawesome-webfont.woff2?v=4.3.0
11:22:37 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/fonts/fontawesome-webfont.woff?v=4.3.0
11:22:37 127.0.0.1 - http://www.gw.govt.nz/themes/gwrc/fonts/fontawesome-webfont.woff?v=4.3.0
11:22:38 10.1.4.26 - http://www.gw.govt.nz/themes/gwrc/fonts/fontawesome-webfont.woff?v=4.3.0
11:22:38 10.1.4.26 - http://www.gw.govt.nz/favicon.ico
11:22:38 10.1.4.26 - http://www.gw.govt.nz/assets/Home-Page-Banners/bg-header-scene-21.jpg?date=20190221
Image

Post Reply