Page 1 of 1

asterisk don't start "illegal instruction" error message

Posted: June 12th, 2007, 11:02 am
by Vubba
Dear all

I try to explain in English , I have installed ipfire 1.4.9 on AMD K6-2 400 MHz 128MB ram, I have updated (ipfireupdate X 3)
When I try to start asterisk (asteriskon) the message error is:
/usr/sbin/safe_asterisk: line 83  826 illegall istruction (core dumped) as asterisk ended with esxit status 132
asterisl exited on signal 4.
if I try with asterisk -v the message is:  "illegal instruction"
where is the problem?
thanks a lot

Re: asterisk doesn't start "illegal instruction" error message

Posted: June 12th, 2007, 11:46 am
by MichaelTremer
Hi,

at first of all to all non-german users: feel free to post in english in this forum!
In these days we are thinking about a multilanguage platform but still need some people to do that work.

And now let's talk about the problem:
I know that there are some problems in starting the asterisk pbx on pentium 1 systems. It may only work on Pentium 2 or higher (i686 for the experts)... What is your hardware configuration?

Could you please post the output of "uname -a" and "cat /proc/cpuinfo"?

Thank you

Michael

Re: asterisk don't start "illegal instruction" error message

Posted: June 12th, 2007, 12:35 pm
by Vubba
Hi

Thank you
this is the result
uname -a
Linux ipcop.localdomain 2.4.31 # 1 Fri aug 26 1:32:48 GMT 2005 i586 authenticAMD unknuwn GNU/Linux
cat /proc/cpuinfo
Processor :0
Vendor_id  :authenticAMD
Cpu family :5
model name : AMD-K6(tm) 3D processor
Stepping :12
cpu MHz : 400.902
cache size :64 KB
fdiv_bug: no
hlt_bug  :no
f00f_bug :no
coma_bug :no
coma_bug:no
fpu: yes
fpu_exception :yes
cpuid level :1
wp :yes
flags: fpu vme de pse tsc msr mce cx8 pge mmx syscall 3dnow k6_mtrr
bogomips: 799.53

Vubba

Re: asterisk don't start "illegal instruction" error message

Posted: June 12th, 2007, 1:11 pm
by MichaelTremer
Hmm, I think that exactly this cpu and the pentium 1 are incompatible to the asterisk pbx.

There are some optimizations available in the asterisk code that are not supported by the older cpus.
In the upcoming new release this is disabled that the asterisk will run on all i586 architectures.
The release of a beta with asterisk may be in July I guess.

Hope this will help you.

Michael

Re: asterisk don't start "illegal instruction" error message

Posted: June 12th, 2007, 1:29 pm
by Vubba
ok
I'm trying now a live distribution (astlinux) that it is based on asterisk 1.4.2, it is running, so I'll wait the next relase... because I like ipfire !!!! it is great !  8)

thanks a lot!!!

Vubba

Re: asterisk don't start "illegal instruction" error message

Posted: June 12th, 2007, 1:32 pm
by MichaelTremer
Thank you, too!

You will get a message when the new release is available!

Bye

Michael