(Gelöst) System/Hardware Graphen nach reboot verschwunden.

Post Reply
satbeppo
Posts: 65
Joined: August 12th, 2009, 8:54 am
Location: Hespe

(Gelöst) System/Hardware Graphen nach reboot verschwunden.

Post by satbeppo » March 22nd, 2016, 3:21 pm

Hallo
Ich habe in einem Anfall (geistiger Umnachtung) mein komplettes /var/log/rrd gelöscht.
Nach dem neutstart von collectd werden jetzt wieder alle Graphen erstellt.
Soweit so gut, aber nach einem Reboot ist alles wieder weg.

Ich schätze ich habe da wohl zu viel gelöscht...... ::)

Frage wie bekommen ich mein IPFire wieder dazu, das die Graphen gespeichert werden??
Habe schon im Forum gesucht, aber so blöd war wohl noch niemand..... :'(

Danke für eure Arbeit und Hilfe

Benno
Last edited by satbeppo on March 25th, 2016, 6:49 pm, edited 1 time in total.

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: System/Hardware Graphen nach reboot verschwunden.

Post by Arne.F » March 22nd, 2016, 4:20 pm

Stoppe den collectd mal auf der commandline
Wenn er da keine Fehler beim Sichern der Ramdisk meldet sollte alles wieder passen. Solange /var/log/rrd wieder angelegt wurde.

Evtl. konnte er die Ramdisk beim Runterfahren nicht sichern weil da noch was gemountet war.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

satbeppo
Posts: 65
Joined: August 12th, 2009, 8:54 am
Location: Hespe

Re: System/Hardware Graphen nach reboot verschwunden.

Post by satbeppo » March 22nd, 2016, 7:22 pm

Danke für die fixe Antwort
Jetzt stehe ich auf dem "Schlauch"...

/etc/init.d/collectd: line 108: /etc/init.d/tmpfs: No such file or directory

Wie komm ich nu weiter ??

Gruß
Benno

satbeppo
Posts: 65
Joined: August 12th, 2009, 8:54 am
Location: Hespe

Re: System/Hardware Graphen nach reboot verschwunden.

Post by satbeppo » March 23rd, 2016, 12:29 pm

Hi
So das mit tmpfs ist gelöst. War das alte init.d script.
Geholfen hat es leider nicht.
Ein stoppen und Starten von collectd auf der Console führt jetzt zu keiner Fehlermeldung.

Was mir noch aufgefallen ist:
Die grösse der Ramdisk wird mit 4gb angegeben. Ist das nicht "etwas" groß ??
Kann man das irgendwo einstellen???

Hab jetzt mal RAMDISK_MODE=0 gesetzt.

Mal schauen ob das was bringt.

Gruß
Benno

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: System/Hardware Graphen nach reboot verschwunden.

Post by Arne.F » March 23rd, 2016, 2:00 pm

Default für dieses Limit ist Arbeitspeicher/2. Es aber nur ein Maximalwert. Linux verwendet nur soviel Speicher wie Daten in der Ramdisk liegen.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

satbeppo
Posts: 65
Joined: August 12th, 2009, 8:54 am
Location: Hespe

Re: System/Hardware Graphen nach reboot verschwunden.

Post by satbeppo » March 23rd, 2016, 3:09 pm

Danke.
Das ist verstanden.

Wenn ich es richtig verstehe, heisst es beim Eintrag RAMDISK_MODE=0 (Ramdisk aus).
Hier sollte eigentlich alles auf die Platte gehen und auch dort bleiben.
Noch einem Reboot ist alles weg, oder muss es ein Shutdown sein..??

Probiers gleich mal aus! erl. Ändert sich nichts....!

Ich weiss hier nicht mehr weiter...

satbeppo
Posts: 65
Joined: August 12th, 2009, 8:54 am
Location: Hespe

(GELÖST) System/Hardware Graphen nach reboot verschwunden.

Post by satbeppo » March 25th, 2016, 6:48 pm

Hi
Hab gesehen das die Änderungen an der Ramdisk im Core 96 waren.
Habe dann "mine" auf Core 95 gesetzt und Pakfire update durchgeführt.

und was soll ich sagen. Alles Friede, freude, Eierkuchen!
Geht wieder.

Besten Dank nochmal und
frohe Ostern.
Benno

Post Reply