VoIP - Verbindungsabbruch und Last auf dem IPfire

the digital PBX
Post Reply
silbert3
Posts: 53
Joined: December 8th, 2009, 12:38 pm

VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by silbert3 » September 1st, 2010, 11:58 am

Hallo zusammen - ich hab da ein Problem, das ich nicht so richtig eingrenzen kann.

Ich nutze ein IP- Telefon, das über VPN (IPfire) an eine entfernte Telefonanlage angeschlossen ist. Seit ein paar Wochen bricht mir regelmäßig bei längeren Gesprächen die Leitung weg, ich höre die Gegenstelle nur noch abgehackt, werde selber aber wohl noch verstanden. Zeitgleich reagiert das Webinterface vom IPfire auf einmal extrem träge.
Erster Blick Status -> Netzwerk (sonstige): Jawoll, die Antwortzeiten vom Gateway schnellen sprunghaft in die Höhe - 3k millisekunden.
Mein erster Verdacht war natürlich DSL. Was mich aber wundert, ist, dass gleichzeitig die Last auf dem IPfire in die Höhe schnellt und man einen deutlichen Anstieg von "CPU wartet auf i/o" und "IRQ cpu Nutzung" sieht. Dazu die träge Reaktion vom Webinterface - kann eine schlechte DSL Leitung Last auf dem Fire verursachen?

Lustig ist hier nur, dass das Problem ausschließlich aufzutreten scheint, wenn ich telefoniere. Lege ich auf, dauert es etwa eine viertel bis halbe Stunde, bis sich alles normalisiert - starte ich den Fire durch ist es sofort wieder in Ordnung. Kann das IPfone den Fire aus dem tritt bringen?

Erwähnen möchte ich noch, dass DSL z.Zt. in der Gegend ausgebaut wird, also hin und wieder mal kurz weg ist...

Ich nutze die oben beschriebene Telefonie- Lösung seit Jahren ohne Probleme.

Hat jemand eine Idee, woran das liegen könnte, oder wo ich suchen kann? Gesucht hab ich im Forum bereits, evtl, hat dieser Thread http://forum.ipfire.org/http://forum.ipfire.org//viewtopic.php?t=9 damit zu tun, bin mir aber auch nicht sicher...

Gruß, Pat

User avatar
MichaelTremer
Core Developer
Core Developer
Posts: 5799
Joined: August 11th, 2005, 9:02 am

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by MichaelTremer » September 6th, 2010, 3:33 pm

Hmm...

Das hört sich in der Tat nach einem schwer lösbaren Problem an. Einen direkten Bezug zwischen dem Thread, den du bisher gefunden hast kann ich nicht feststellen, auch wenn die Symptome ähnlich sind.

Hast du das Quality-of-Service zufällig eingeschaltet?

Ist das Problem auch mit anderen Formen von Datenübertragung nachstellbar?

Evtl. Netzwerkkarte austauschen?

Michael
Support the project with our Donation Challenge!

Get Commercial Support for IPFire and more from Lightning Wire Labs!

Image

silbert3
Posts: 53
Joined: December 8th, 2009, 12:38 pm

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by silbert3 » September 15th, 2010, 10:21 am

Hi Michael,

bin da echt am verzweifeln - bisher lief mit der selben Hardware alles tipptop.  ??? Ob QoS an oder aus ist spielt keine Rolle.
Mit anderen Formen der Datenübertragungen kann ich da nichts nachstellen - alles ok. Sobald ich ein Telefonat  führe, beginnt im cpu Diagramm stetig die "irq cpu Nutzung" anzusteigen, und immer ziemlich genau nach 10 - 12 Minuten kommen die ersten Aussetzer. Die Gegenstelle kann mich zu diesem Zeitpunkt noch gut hören.
Lege ich dann nicht auf und telefoniere weiter, reißt das Gespräch irgendwann ab (irq cpu Nutzung dann so bei 50%) und mein IPfone hat die Verbindung verloren.

Unten der rosa Graph ab ca. 11:53 ist ein Telefonat, das ich aber rechtzeitig beendet habe - sonst würde IRQ CPU Nutzung ziemlich schnell bis auf 50% ansteigen bevor das Telefon die Verbindung verliert. Die Leitung ist übrigens frei (s. zweiten Screenshot)

Ab dem Zeitpunkt dauert es etwa 5 Minuten, bis sich das Telefon wieder verbindet - Gespräche sind ab dem Zeitpunkt bis zu einem Reboot des IPfire oder deutlich längerem Warten (über Nacht) nicht mehr möglich - sofort wieder Abbruch.
Werde wohl erstmal meinen alten IPCop rauskramen und dann demnächst den Fire neu installieren :-( vielleicht bringt das ja was.

Image
Image

und nochmal einer, den ich bis zum Abbruch durchgezogen hab, 16:28 begann das Gespräch:

Image

Gruß, Pat
Last edited by silbert3 on September 23rd, 2010, 3:19 pm, edited 1 time in total.

silbert3
Posts: 53
Joined: December 8th, 2009, 12:38 pm

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by silbert3 » September 23rd, 2010, 3:22 pm

Nochmal der Vollständigkeit halber weil ich sehe, dass der Thread verschoben wurde: Ich nutze nicht das Asterisk Addon - ich habe nur ein IP- Telefon, das durch einen VPN Tunnel mit der Telefonanlage der Firma verbunden ist.

User avatar
MichaelTremer
Core Developer
Core Developer
Posts: 5799
Joined: August 11th, 2005, 9:02 am

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by MichaelTremer » September 23rd, 2010, 7:48 pm

Das scheint auch kein Problem zu sein, was durch Software verursacht wird...

IRQ-Last wird durch Hardware verursacht, die dem Kernel melden, dass Daten da sind. Defekte Netzwerkkarte?
Support the project with our Donation Challenge!

Get Commercial Support for IPFire and more from Lightning Wire Labs!

Image

User avatar
Maniacikarus
Core Developer
Core Developer
Posts: 6210
Joined: February 24th, 2006, 10:35 am
Location: Nürnberg
Contact:

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by Maniacikarus » September 24th, 2010, 7:04 am

Tausch mal die Netzwerkkarte ggf. behebt das das Problem.
Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by Arne.F » September 27th, 2010, 6:23 pm

Ich würd da auch auf die Hardware oder die Treiber tippen. VOIP-RTP sind ganz kleine Packete dafür aber viele... Diese Art Traffic kriegt man mit kaum was anderem Erzeugt.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

silbert3
Posts: 53
Joined: December 8th, 2009, 12:38 pm

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by silbert3 » October 11th, 2010, 11:47 am

So, sorry dass es länger gedauert hat, ich hab gerade die rote NIC (Realtek) durch eine von 3com ersetzt - Gespräche brechen jetzt nicht mehr ab. Ich habe zwar nach wie vor deutlich sichtbar IRQ Nutzung auf dem Diagramm, allerdings nicht mehr nur kontinuierlich ansteigend sondern auf- und absteigend. (???) Konnte jedenfalls gerade ein 30 Minütiges Testtelefonat in ordentlicher Qualität und ohne Abbrüche führen.

Danke für den Tip!!!

silbert3
Posts: 53
Joined: December 8th, 2009, 12:38 pm

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by silbert3 » November 24th, 2010, 11:10 am

Nochmal der Vollständigkeit halber eine Ergänzung:

Das Problem tritt weiter auf, auch wenn es durch die Verwendung einer anderen Netzwerkkarte auf RED deutlich besser geworden ist. Ist mir immer noch ein Rätsel. Habe testweise auch mal auf einem eee der 700er Klasse einen Fire mit den gleichen Einstellungen installiert und laufen lassen - da war das Problem ebenfalls da, sogar noch schlimmer (aufgrund der geringeren Rechenleistung des Prozessors vermute ich mal)
Es scheint, als gäbe es ein gewisses Kontingent an "wasauchimmer" das der Server verkraftet und dann is Schluss bis zum nächsten Reboot. Wenn ich den Vormittag viel telefoniere, is meistens irgendwann am Nachmittag Schluss und o.g. Abbrüche treten auf - auch schon bei ganz kurzen Gesprächen. Das bessert sich nur wieder durch einen Reboot des IPfire. Derzeit boote ich meinen Fire halt Morgens und Mittags - wirklich befriedigend ist diese Lösung aber nicht :-(

Gruß, Pat

silbert3
Posts: 53
Joined: December 8th, 2009, 12:38 pm

Re: VoIP - Verbindungsabbruch und Last auf dem IPfire

Post by silbert3 » January 20th, 2011, 1:48 pm

Und ein letztes Mal hierzu (auch nochmal der Vollständigkeit halber):

Seit dem letzten Update auf Core 44 funktioniert alles wieder wie es soll (und zuvor mit identischer Hardware auch schon geklappt hatte). War also wohl doch ein softwareseitiges Problem.

Problem gelöst und vielen Dank für das Update!!! :-)

Pat

Post Reply