Anleitung: MEDIATOMB installation (funktionierend!)

MPFire, VLC, Gnump3d, Icecast
bertol
Posts: 18
Joined: October 4th, 2011, 3:28 pm
Location: St. Georgen im Schwarzwald

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by bertol » March 27th, 2012, 4:32 pm

@frnk dann mach mal

Code: Select all

sqlite3 /var/ipfire/mediatomb/mediatomb.db < /usr/share/mediatomb/sqlite3.sql
chown nobody:nobody /var/ipfire/mediatomb/mediatomb.db
chmod 644 /var/ipfire/mediatomb/mediatomb.db
/etc/init.d/mediatomb restart
Image

Image

frnk
Posts: 10
Joined: March 22nd, 2012, 3:21 am

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by frnk » March 27th, 2012, 5:00 pm

bertol wrote:@frnk dann mach mal

Code: Select all

sqlite3 /var/ipfire/mediatomb/mediatomb.db < /usr/share/mediatomb/sqlite3.sql
chown nobody:nobody /var/ipfire/mediatomb/mediatomb.db
chmod 644 /var/ipfire/mediatomb/mediatomb.db
/etc/init.d/mediatomb restart



Code: Select all

[root@ipfire /]# sqlite3 /var/ipfire/mediatomb/mediatomb.db < /usr/share/mediatomb/sqlite3.sql
Error: near line 2: database is locked
Error: near line 22: database is locked
Error: near line 23: database is locked
Error: near line 24: database is locked
Error: near line 25: database is locked
Error: near line 31: database is locked
Error: near line 35: database is locked
Error: near line 36: database is locked
Error: near line 51: database is locked
Error: near line 52: database is locked
Error: near line 53: database is locked
Error: near line 54: database is locked
Error: near line 55: database is locked
Error: near line 56: database is locked
Error: near line 57: database is locked
Error: near line 58: database is locked
[root@ipfire /]#

bertol
Posts: 18
Joined: October 4th, 2011, 3:28 pm
Location: St. Georgen im Schwarzwald

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by bertol » March 27th, 2012, 5:14 pm

Database locked? Ich würde sagen es läuft.

Du kannst mit

Code: Select all

/etc/init.d/mediaupdate status
prüfen obs läuft. Wenn nicht dann mit stop sicherheitshalber den dienst beenden, die Datenbank loeschen und nochmal mit den Zeilen sqlite3 ... die Grund Datenbank erstellen. Den dienst mit start starten, mit status prüfen obs läuft fertig
Image

Image

schneiderjoachim
Posts: 45
Joined: November 15th, 2009, 6:28 pm

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by schneiderjoachim » March 27th, 2012, 5:32 pm

wollte auch bescheid geben das es nach deiner anleitung funktioniert.
Vielen Dank für die Lösung

nur eine kleine frage hätte ich noch, vielleicht weist du eine antwort :)
ich möchte eine freigabe von Samba auch in mediatomb freigeben.
die verzeichnisse gehören dem user und der gruppe Samba.
kann ich mediatomb rechte einräumen um auf diese verzeichnisse zuzugreifen?

sorry, war ne doofe frage :) hab nur die create mask in samba geändert
Last edited by schneiderjoachim on March 27th, 2012, 5:42 pm, edited 1 time in total.
Image

schneiderjoachim
Posts: 45
Joined: November 15th, 2009, 6:28 pm

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by schneiderjoachim » March 31st, 2012, 7:12 am

Hi,
nachdem jetzt Mediatomb läuft und auch meine Festplatte wieder in ordnung ist, würde ich mich gerne an die konfiguration wagen :)
Ich habe versucht das Transcoding für OGG, mit dem schon enthaltenen profilen zu aktivieren. Leider startet Mediatomb dann nicht mehr, hat jemand eine Idee was mir fehlt?

Code: Select all

  <transcoding enabled="yes">
    <mimetype-profile-mappings>
      <transcode mimetype="video/x-flv" using="vlcmpeg"/>
      <transcode mimetype="application/ogg" using="vlcmpeg"/>
      <transcode mimetype="application/ogg" using="oggflac2raw"/>
      <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
    </mimetype-profile-mappings>
    <profiles>
      <profile name="oggflac2raw" enabled="yes" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ogg123" arguments="-d raw -f %out %in"/>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
      </profile>
      <profile name="vlcmpeg" enabled="no" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=$
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
    </profiles>
  </transcoding>

Code: Select all

[root@redbox ~]# /etc/init.d/mediatomb restart
Stopping mediatomb uPnP Mediaserver...                                                                                                                         [  OK  ]
Starting mediatomb uPnP Mediaserver...
/etc/rc.d/init.d/functions: line 438: 30419 Segmentation fault      ${cmd}                                                                                     [  OK  ]

Muss ich das transcodingprofil ändern? Oder geht es schlicht und einfach nicht?
Image

bertol
Posts: 18
Joined: October 4th, 2011, 3:28 pm
Location: St. Georgen im Schwarzwald

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by bertol » March 31st, 2012, 10:21 am

Keine Ahnung hatte ich bisher nicht versucht. Du kannst aber selber mal schauen, ob es im Debugging-Modus Fehler gibt.

1. Beende MidiaTomb mittels

Code: Select all

/etc/init.d/mediatomb stop

2. starte Mediatomb im debugging modus

Code: Select all

/usr/bin/mediatomb -u nobody -g nobody -c /var/ipfire/mediatomb/config.xml -e green0 -D

3. Es folgt eine lange, lange Ausgabe bis zum Fehler, in der Regel steht dann in den letzten Zeilen was schiefgelaufen ist.
4. Entweder siehst Du was da Falschläuft (Bsp. File xys not found) ansonsten hiernochmal Posten, vieleicht als Neues Thread. Wenn Du den Fehler gelöst hast, aufjedenfall die Lösung posten, damit die Nachwelt das Rad nicht neu erfinden muss ;)
Image

Image

schneiderjoachim
Posts: 45
Joined: November 15th, 2009, 6:28 pm

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by schneiderjoachim » March 31st, 2012, 3:52 pm

Es fehlen die Programme fürs Transcodieren.
Lösung: ffmpeg istallieren und die config.xml wie folgt anpassen.
für ogg und flac (aac geht mit diesem ffmpeg nicht)

Code: Select all

  <transcoding enabled="yes">
    <mimetype-profile-mappings>
      <transcode mimetype="application/ogg" using="2pcm"/>
      <transcode mimetype="audio/x-flac" using="2pcm"/>
    </mimetype-profile-mappings>
    <profiles>
      <profile name="2pcm" enabled="yes" type="external" >
        <mimetype>audio/L16</mimetype>
        <first-resource>yes</first-resource>
        <accept-url>yes</accept-url>
        <sample-frequency>44100</sample-frequency>
        <audio-channels>2</audio-channels>
        <hide-original-resource>yes</hide-original-resource>
        <agent command="/usr/bin/ffmpeg" arguments="-i %in -ac 2 -ar 44100 -y -f s16be %out"/>
        <buffer size="1048576" chunk-size="4096" fill-size="1024"/>
      </profile>
    </profiles>
  </transcoding>
Image

Ignored
Posts: 1
Joined: January 8th, 2013, 10:11 pm

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by Ignored » January 8th, 2013, 10:15 pm

Huhu, ich bin gerade dran bei jemandem Mediatomb zu Installieren.
Die Installation und das erstellen der DB hat wunderbar funktioniert allerdings Startet es nicht bzw steigt mit folgendem Debugfehler aus

Migratin server configuration to config version 2 segmentation fault

Ich werde leider aus dem Fehler nicht ganz schlau, an der Config hab ich nichts geändert.
Bin für jede Hilfe dankbar

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by Arne.F » January 8th, 2013, 10:29 pm

Mediatomb hat mit IPFire 2.11 (nur auf Intel, auf ARM gehts) seltsame Probleme bei Datenbankzugriffen. Das steigt regelmäßig aus. Mit der 2.13beta tritt das hoffentlich nicht mehr auf.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

torvo
Posts: 168
Joined: September 19th, 2011, 10:15 am

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by torvo » January 22nd, 2013, 8:22 pm

Moin

Das ist mein Fehler


2013-01-22 21:26:24    INFO: Loading configuration from: /var/ipfire/mediatomb/config.xml
2013-01-22 21:26:24    INFO: Checking configuration...
2013-01-22 21:26:24    INFO: Migrating server configuration to config version 2
Segmentation fault
Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by Arne.F » January 30th, 2013, 7:56 am

Hast du die 2.13beta2 drauf? Auf 2.11 gehts nicht da killt er immer irgendwann die Datenbank.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Leon
Posts: 153
Joined: October 25th, 2012, 9:15 pm

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by Leon » November 23rd, 2013, 5:08 pm

Ich habe jetzt ein Problem mit einen Fehler dieser lautet

[root@Server ~]# /etc/init.d/mediatomb start
Starting mediatomb uPnP Mediaserver...
SIOCADDRT: File exists                                                                    [  OK  ]


Ich habe schon probiert den mediatomb neu zu installieren aber der Fehler ist geblieben und deshalb läuft mein Mediatomb nicht mehr





Code: Select all

[root@Server ~]# /usr/bin/mediatomb -u nobody -g nobody -c /var/ipfire/mediatomb/config.xml -D

MediaTomb UPnP Server version 0.12.1 - http://mediatomb.cc/

===============================================================================
Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
MediaTomb is free software, covered by the GNU General Public License version 2

2013-11-23 17:51:35    INFO: Loading configuration from: /var/ipfire/mediatomb/config.xml
2013-11-23 17:51:35    INFO: Checking configuration...
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/tmpdir using default value: /tmp/
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/servedir using default value:
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/storage/attribute::caching using default value: yes
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/storage/sqlite3/synchronous using default value: off
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/storage/sqlite3/on-error using default value: restore
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/storage/sqlite3/backup/attribute::enabled using default value: no
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/storage/sqlite3/backup/attribute::interval using default value: 600
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/ui/attribute::poll-when-idle using default value: no
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/ui/attribute::poll-interval using default value: 2
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/ui/items-per-page/attribute::default using default value: 25
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/mappings/extension-mimetype/attribute::case-sensitive using default value: no
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:1352] validate(): received UTF-8 from nl_langinfo
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/filesystem-charset using default value: UTF-8
2013-11-23 17:51:35    INFO: Setting filesystem import charset to UTF-8
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/metadata-charset using default value: UTF-8
2013-11-23 17:51:35    INFO: Setting metadata import charset to UTF-8
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/playlist-charset using default value: UTF-8
2013-11-23 17:51:35    INFO: Setting playlist charset to UTF-8
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/pc-directory/attribute::upnp-hide using default value: no
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/interface using default value:
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/ip using default value:
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/bookmark using default value: mediatomb.html
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/modelName using default value: MediaTomb
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/modelDescription using default value: Free UPnP AV MediaServer, GNU GPL
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/modelNumber using default value: 0.12.1
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/serialNumber using default value: 1
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/manufacturerURL using default value: http://mediatomb.cc/
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/presentationURL using default value:
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/presentationURL/attribute::append-to using default value: none
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/upnp-string-limit using default value: -1
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/port using default value: 0
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /server/alive using default value: 1800
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/autoscan/attribute::use-inotify using default value: auto
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/library-options/libexif/auxdata using default value:
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/library-options/id3/auxdata using default value:
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2358] getOption(): Config: option not found: /import/magic-file using default value:
2013-11-23 17:51:35 WARNING: You enabled the YouTube feature, which allows you
                             to watch YouTube videos on your UPnP device!
                             Please check http://www.youtube.com/t/terms
                             By using this feature you may be violating YouTube
                             service terms and conditions!

2013-11-23 17:51:35    INFO: Configuration check succeeded.
2013-11-23 17:51:35   DEBUG: [../src/config_manager.cc:2260] validate(): Config file dump after validation:
<config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd">
  <server>
    <ui enabled="yes" show-tooltips="yes" poll-when-idle="no" poll-interval="2">
      <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>
    <items-per-page default="25"><option>10</option><option>25</option><option>50</option><option>100</option></items-per-page></ui>
    <name>MediaTomb</name>
    <udn>uuid:77703b11-a8d7-46f8-8598-ff10d51ae4a8</udn>
    <home>/root/.mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage caching="yes">
      <sqlite3 enabled="yes">
        <database-file>/root/.mediatomb/mediatomb.db</database-file>
      <synchronous>off</synchronous><on-error>restore</on-error><backup enabled="no" interval="600"/></sqlite3>
      <mysql enabled="no">
        <host>localhost</host>
        <username>mediatomb</username>
        <database>mediatomb</database>
      </mysql>
    </storage>
    <protocolInfo extend="no"/><!-- For PS3 support change to "yes" -->
    <!--
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
    -->
    <!--
    <custom-http-headers>
      <add header="X-User-Agent: redsonic"/>
    </custom-http-headers>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    -->
    <!-- Uncomment the line below if you have a Telegent TG100 -->
    <!--
       <upnp-string-limit>101</upnp-string-limit>
    -->
    <extended-runtime-options>
      <mark-played-items enabled="no" suppress-cds-updates="yes">
        <string mode="prepend">*</string>
        <mark>
          <content>video</content>
        </mark>
      </mark-played-items>
    </extended-runtime-options>
  <tmpdir>/tmp/</tmpdir><servedir></servedir><pc-directory upnp-hide="no"/><interface></interface><ip></ip><bookmark>mediatomb.html</bookmark><modelName>MediaTomb</modelName><modelDescription>Free UPnP AV MediaServer, GNU GPL</modelDescription><modelNumber>0.12.1</modelNumber><serialNumber>1</serialNumber><manufacturerURL>http://mediatomb.cc/</manufacturerURL><presentationURL append-to="none"></presentationURL><upnp-string-limit>-1</upnp-string-limit><port>0</port><alive>1800</alive></server>
  <import hidden-files="no">
    <scripting script-charset="UTF-8">
      <virtual-layout type="builtin"/>
    </scripting>
    <mappings>
      <extension-mimetype ignore-unknown="no" case-sensitive="no">
        <map from="mp3" to="audio/mpeg"/>
        <map from="ogx" to="application/ogg"/>
        <map from="ogv" to="video/ogg"/>
        <map from="oga" to="audio/ogg"/>
        <map from="ogg" to="audio/ogg"/>
        <map from="ogm" to="video/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="flv" to="video/x-flv"/>
        <map from="mkv" to="video/x-matroska"/>
        <map from="mka" to="audio/x-matroska"/>
        <!-- Uncomment the line below for PS3 divx support -->
        <!-- <map from="avi" to="video/divx"/> -->
        <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
        <!-- <map from="avi" to="video/avi"/> -->
      </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"/>
        <map from="video/*" to="object.item.videoItem"/>
        <map from="image/*" to="object.item.imageItem"/>
      </mimetype-upnpclass>
      <mimetype-contenttype>
        <treat mimetype="audio/mpeg" as="mp3"/>
        <treat mimetype="application/ogg" as="ogg"/>
        <treat mimetype="audio/x-flac" as="flac"/>
        <treat mimetype="image/jpeg" as="jpg"/>
        <treat mimetype="audio/x-mpegurl" as="playlist"/>
        <treat mimetype="audio/x-scpls" as="playlist"/>
        <treat mimetype="audio/x-wav" as="pcm"/>
        <treat mimetype="audio/L16" as="pcm"/>
        <treat mimetype="video/x-msvideo" as="avi"/>
        <treat mimetype="video/mp4" as="mp4"/>
        <treat mimetype="audio/mp4" as="mp4"/>
        <treat mimetype="application/x-iso9660" as="dvd"/>
        <treat mimetype="application/x-iso9660-image" as="dvd"/>
      </mimetype-contenttype>
    </mappings>
    <online-content>
      <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="mp4" hd="no">
        <favorites user="mediatomb"/>
        <standardfeed feed="most_viewed" time-range="today"/>
        <playlists user="mediatomb"/>
        <uploads user="mediatomb"/>
        <standardfeed feed="recently_featured" time-range="today"/>
      </YouTube>
    </online-content>
  <filesystem-charset>UTF-8</filesystem-charset><metadata-charset>UTF-8</metadata-charset><playlist-charset>UTF-8</playlist-charset><autoscan use-inotify="auto"/><library-options><libexif><auxdata></auxdata></libexif><id3><auxdata></auxdata></id3></library-options><magic-file></magic-file></import>
  <transcoding enabled="no">
    <mimetype-profile-mappings>
      <transcode mimetype="video/x-flv" using="vlcmpeg"/>
      <transcode mimetype="application/ogg" using="vlcmpeg"/>
      <transcode mimetype="application/ogg" using="oggflac2raw"/>
      <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
    </mimetype-profile-mappings>
    <profiles>
      <profile name="oggflac2raw" enabled="no" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
      </profile>
      <profile name="vlcmpeg" enabled="no" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
    </profiles>
  </transcoding>
</config>
2013-11-23 17:51:35   DEBUG: [../src/singleton.cc:73] registerSingleton(): registering new singleton... - 0 -> 1
2013-11-23 17:51:35   DEBUG: [../src/singleton.cc:73] registerSingleton(): registering new singleton... - 1 -> 2
2013-11-23 17:51:35   DEBUG: [../src/singleton.cc:73] registerSingleton(): registering new singleton... - 2 -> 3
2013-11-23 17:51:35   DEBUG: [../src/singleton.cc:73] registerSingleton(): registering new singleton... - 3 -> 4
2013-11-23 17:51:35   DEBUG: [../src/server.cc:118] upnp_init(): start
2013-11-23 17:51:35   ERROR: Error while accessing sqlite database file (/root/.mediatomb/mediatomb.db): Permission denied
[root@Server ~]#
Last edited by Leon on November 23rd, 2013, 5:12 pm, edited 1 time in total.
Image

Leon
Posts: 153
Joined: October 25th, 2012, 9:15 pm

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by Leon » November 23rd, 2013, 6:11 pm

Habe jetzt nochmal mediatomb und jetzt auch die SQL Datenbank gelöscht sowie den mediatomp Ordner unter root/./mediatomb diesen habe ich mit den neu installierten order von mediatomb ersetzt jetzt läuft es.
Image

torvo
Posts: 168
Joined: September 19th, 2011, 10:15 am

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by torvo » November 28th, 2013, 11:09 am

Wieso bleibt der Mediatomb eigentlich im testing Trunk.
Sind da immer noch Probleme zu erwarten?

Habe jetzt Core 73 im release Zweig drauf und wollte eigentlich gern wieder den Mediatomb drauf haben.
Kann ich da auch einfach nur für den download kurz in den Testint Trunk wechseln (ohne pakfire upgrade) und mir mediatomb installieren und danach wieder zurück in den Release Zweig wechseln?

Gruss
Image

Leon
Posts: 153
Joined: October 25th, 2012, 9:15 pm

Re: Anleitung: MEDIATOMB installation (funktionierend!)

Post by Leon » November 28th, 2013, 11:32 am

Das kann ich dir nicht beantworten aber was ich dir sagen kann benutzte lieber minidlna anstatt mediatomb. Ich persönlich nehme nur noch minidlna weil ich bei mediatomb alle Codecs Zugehörigkeiten Manuel eingefügt werden mussten und die Filme dann trotzdem nicht liefen. Bei minidlna ist es ganz einfach installieren scan machen und alle Filme werden automatisch richtig configuriert.

Minidlna wird auch noch weiterentwickelt was bei mediatomb wohl nicht mehr der fahl ist
Image

Post Reply