Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Samba, NFS
Bumsfallera

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by Bumsfallera » March 1st, 2013, 4:44 pm

Das Problem bei meinem Sat Receiver habe ich nun etwas eingrenzen können:

Mit dem Befehl

Code: Select all

mount -t nfs ...


erhalte ich die Fehlermeldung

Code: Select all

mount: RPC: Remote system error - Connection refused
mount: mounting 192.168.X.X:/mnt/daten on /media/test failed: Bad file descriptor


Mit dem Befehl

Code: Select all

mount -t nfs4 ...

klappt die Verbindung.

User avatar
StefanSchantl
Core Developer
Core Developer
Posts: 822
Joined: December 3rd, 2008, 2:50 pm
Location: Steiermark

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by StefanSchantl » March 1st, 2013, 5:43 pm

Guten Abend,

freut mich dass schlussendlich das mounten doch noch geklappt hat. Auf Grund euerer positiven Bewertungen entnehme ich, dass die neue Version der NFS utils das Problem mit dem NFS Server behebt und auch das einbinden von Remote Freigaben noch funktioniert.

Ein herzliches Dankeschön an alle Tester.

mfg

Stefan

DoM187
Posts: 9
Joined: January 7th, 2013, 1:07 am

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by DoM187 » March 6th, 2013, 5:06 am

Hallo Leute,

erstmal danke das ihr euch alle so toll um die Probleme kümmert. Soweit ich diesem Thread folgen konnte hätte ich mein NFS-Server Problem lösen können nur bekomme ich die Meldung:

Code: Select all

Starting NFS mountd...
/etc/rc.d/init.d/functions: line 509: /usr/sbin/rpc.mountd: cannot execute binary file                  [ FAIL ]
Starting NFS nfsd...
/etc/rc.d/init.d/functions: line 509: /usr/sbin/rpc.nfsd: cannot execute binary file                    [ FAIL ]
Starting NFS statd...
/etc/rc.d/init.d/functions: line 509: /usr/sbin/rpc.statd: cannot execute binary file                   [ FAIL ]
Exporting NFS Filesystems...
/etc/init.d/nfs-server: line 43: /usr/sbin/exportfs: cannot execute binary file                         [ FAIL ]


Dann ist mir eingefallen das ich ein RaspberryPi nutze und ich die Pre-Compiled Binaries nicht nutzen kann. Soweit meine eigene Vermutung. Was denkt ihr darüber? Und wenn ich richtig liege: Wie kann ich sie mir selber Compilieren und installieren? Oder gibt es noch fertige ARM Files?

Danke für die Mühe

Gruß

User avatar
StefanSchantl
Core Developer
Core Developer
Posts: 822
Joined: December 3rd, 2008, 2:50 pm
Location: Steiermark

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by StefanSchantl » March 6th, 2013, 5:26 pm

DoM187 wrote:Dann ist mir eingefallen das ich ein RaspberryPi nutze und ich die Pre-Compiled Binaries nicht nutzen kann....


Hallo DoM187,

du liegst mit deiner Vermutung genau richtig. Diese Testversion wurde für i586 compiliert und ist in dieser Form auf ARM Geräten nicht ausführbar. Es existiert auch derzeit keine compilierte Version für ARM.

Ich kann dich aber beruhigen, die Änderungen sind bereits im IPFire Hauptzweig und werden in kürze mit dem nächsten Core Update (67) für sämtliche Plattformen bereitstehen.

mfg

Stefan

DoM187
Posts: 9
Joined: January 7th, 2013, 1:07 am

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by DoM187 » March 6th, 2013, 7:33 pm

juhuuu  :D

Danke

gerdh
Posts: 506
Joined: July 25th, 2009, 10:36 pm
Contact:

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by gerdh » March 8th, 2013, 12:30 pm

Ich muss hier nochmal einhaken....
irgendwoe gibts da mit dem nfs noch ein Problem...
manuell mounten geht (auf 2 Kisten mit ubuntu 12.04)  aber der automounter will nicht mehr....  und ohne fehlermeldung.
Ich hab zum Vergleich nen Goflex mit Archlinux hier (im export file die selben einstellungen) und das volume darauf per automounter zu mounten geht.
Wenn ich mir die prozessliste vom NFS Server ansehe fehlt beim ipfire rcp.idmapd
(der liegt in /usr/sbin/)  manuell gestartet sagt der mir aber:

Code: Select all

/usr/sbin/rpc.idmapd: error while loading shared libraries: libevent-2.0.so.5: cannot open shared object file: No such file or directory


Gruss Gerd

teaborn
Community Developer
Community Developer
Posts: 58
Joined: April 29th, 2012, 12:29 pm
Location: Ruhrgebiet

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by teaborn » March 8th, 2013, 1:18 pm

Hast du denn über pakfire "libevent2" installiert?
Image

gerdh
Posts: 506
Joined: July 25th, 2009, 10:36 pm
Contact:

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by gerdh » March 8th, 2013, 1:40 pm

jetzt ja :) trotzdem => geht nicht...

Code: Select all

root@capricorn:/mnt/net/nfs/ipfire/export# ls -l
insgesamt 0
drwxr-xr-x 2 root root 0 Mär  8 14:34 dlna
drwxr-xr-x 2 root root 0 Mär  8 14:34 vdr
root@capricorn:/mnt/net/nfs/ipfire/export# cd dlna
bash: cd: dlna: Datei oder Verzeichnis gefunden
root@capricorn:/mnt/net/nfs/ipfire/export#



am ipfire gibts keine syslog meldung was das betrifft....

mount ipire:/export/dlna /mnt/test

gehts komischerweise....

gruss gerd
Gruss Gerd

Gruss Gerd

gerdh
Posts: 506
Joined: July 25th, 2009, 10:36 pm
Contact:

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by gerdh » March 11th, 2013, 10:08 am

OK hat sich erledigt.. war ein problem mit dem FSID im export file.....

gruss gerd

gerdh
Posts: 506
Joined: July 25th, 2009, 10:36 pm
Contact:

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by gerdh » March 12th, 2013, 10:29 am

Hmpf langsam komm ich mir als EInzelkaempfer bloed vor :)
Irgendwas scheint noch nicht rund zu laufen....
Nach dem Neustart vom IPfire
kann ich weder mit automount noch manuell was mounten

erst wenn ich den nfs-server neustarte geht dann beides...
hier man die Ausgabe nach dem Neustart:

Code: Select all

 sudo mount -vvvvvv -t nfs4 -o hard,intr,nodev,nosuid,async,rsize=32768,wsize=32768 192.168.63.251:/export/dlna  /mnt/test
mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "192.168.63.251:/export/dlna"
mount: node:  "/mnt/test"
mount: types: "nfs4"
mount: opts:  "hard,intr,nodev,nosuid,async,rsize=32768,wsize=32768"
mount: external mount: argv[0] = "/sbin/mount.nfs4"
mount: external mount: argv[1] = "192.168.63.251:/export/dlna"
mount: external mount: argv[2] = "/mnt/test"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "rw,nosuid,nodev,hard,intr,rsize=32768,wsize=32768"
mount.nfs4: timeout set for Tue Mar 12 11:24:01 2013
mount.nfs4: trying text-based options 'hard,intr,rsize=32768,wsize=32768,addr=192.168.63.251,clientaddr=192.168.63.1'
mount.nfs4: mount(2): Permission denied
mount.nfs4: access denied by server while mounting 192.168.63.251:/export/dlna


und hier nachdem ich den NFS Server neu gestartet hab...

Code: Select all

sudo mount -vvvvvv -t nfs4 -o hard,intr,nodev,nosuid,async,rsize=32768,wsize=32768 192.168.63.251:/export/dlna  /mnt/test
mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "192.168.63.251:/export/dlna"
mount: node:  "/mnt/test"
mount: types: "nfs4"
mount: opts:  "hard,intr,nodev,nosuid,async,rsize=32768,wsize=32768"
mount: external mount: argv[0] = "/sbin/mount.nfs4"
mount: external mount: argv[1] = "192.168.63.251:/export/dlna"
mount: external mount: argv[2] = "/mnt/test"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "rw,nosuid,nodev,hard,intr,rsize=32768,wsize=32768"
mount.nfs4: timeout set for Tue Mar 12 11:25:04 2013
mount.nfs4: trying text-based options 'hard,intr,rsize=32768,wsize=32768,addr=192.168.63.251,clientaddr=192.168.63.1'
192.168.63.251:/export/dlna on /mnt/test type nfs4 (rw,nosuid,nodev,hard,intr,rsize=32768,wsize=32768)


im Logfile steht nichts wenn er das access denied bringt.... kann es sein das die mounts noch nicht durch sind wenn der NFS server startet ?


Gruss Gerd
Last edited by gerdh on March 12th, 2013, 10:37 am, edited 1 time in total.

jakumoto
Posts: 6
Joined: August 22nd, 2011, 8:22 pm

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by jakumoto » June 12th, 2013, 10:22 am

Ich schließe mich da an!

Nach dem reboot von IPFIRE kann man sich nicht connecten. Starte ich den Dienst mit /etc/init.d/nfs-server restart neu funzt es. Ich tippe auf ein Problem mit der Startreihenfolge der Dienste. Die NFS-Freigabe ist auf einer ExtraHD. Es ist auf allen Ipfire nachvollziehbar.

Hab als workaround in die /etc/sysconfig/rc.local  "/etc/init.d/nfs-server restart" eingefügt.
datt funzt

Bumsfallera

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by Bumsfallera » June 28th, 2013, 3:51 pm

Eben ausprobiert:
Bei mir funktioniert ein NFS Mount sofort nach dem Reboot ohne Probleme (per fstab)

jakumoto
Posts: 6
Joined: August 22nd, 2011, 8:22 pm

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by jakumoto » July 1st, 2013, 10:22 am

Hast Du auch eine 2. Festplatte?

Bumsfallera

Re: Seit 2.13 kein Zugriff mehr auf NFS Freigaben

Post by Bumsfallera » July 2nd, 2013, 1:51 pm

Ja, ich habe eine System- und eine Datenplatte. Der NFS Export kommt logischerweise von der Datenplatte.

Beide Platten sind mit SATA angeschlossen.

Post Reply