Page 1 of 2

Eigenartiges/Nerviges Problem mit dem WLAN

Posted: September 29th, 2017, 6:01 pm
by gaminge
Hallo liebes Forum,

ich hoffe ihr könnt mir bei meinem eigenartigen/nerviges Problem mit dem WLAN weiterhelfen.

Mein Problem in der Kurzfassung:
Alle Linux basierten Geräte haben kein Internetzugang über Blau. Alle Windows basierten Geräte haben Internet über Blau.

Wie es zum Problem kam:
3-4 Tage nach dem ich auf das Core Update 113 geupdatet habe ging plötzlich das WLAN für alle Geräte im Netzwerk nicht mehr. Um das Problem schnell zu lösen habe ich meine APU1D4 vom Stromnetz getrennt und wieder angeschlossen. Allerdings hat IPFire seitdem nicht mehr richtig gebootet und ich musste daraufhin IPFire (Core 113) neuinstallieren. Nun habe ich das oben erwähnte Problem. Ich kann mich zwar mit allen Geräten mit dem WLAN verbinden bekomme aber bei Linux basierten Geräten keine Internetverbindung (Die MAC Adressen habe ich explizit erlaubt und ich bekomme auch ein IP Adresse zugewiesen). Es verhält sich so als hätte ich meine Linux basierten Geräten unter Zugriff auf Blau nicht hinzugefügt.
Hier eine Liste mit den Geräten die (k)eine Vebindung mit dem Internet haben.
  • Laptop Acer mit dual-boot: Windows8.1 Ja / Linux Mint 17.2 Nein (Beweis dafür, dass ich die MAC Adresse explizit erlaubt habe)
  • Raspberry Pi 2 Libreelec Nein
  • Windowsphone Nokia Ja
  • Android Huawei Nein
  • Android Samsung Nein
  • Tablet Acer Windows8.1 Ja
  • Laptop Acer Windows 7 Ja
Ich weiß nicht woran das liegen kann (an IPFire? an den Linux basierten Geräten?). Es wäre nett, wenn mir jmd mitteilen könnte wie ich vorgehen sollte (Debuggen, Logdateien einsehen, Terminal Befehle, etc) um erstmal herausfinden zu können wo das Problem liegt.

Sollte das Problem nicht verständlich oder werden mehr Information benötigt, einfach schreiben ;)

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 6th, 2017, 12:28 pm
by gregor
Fangen wir mal einfach an geht ein ping auf 8.8.8.8?

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 13th, 2017, 3:43 pm
by gaminge
Also pingen geht nicht -> Network is unreachable
Ich wollte noch anmerken dass alle aufgelisteten Geräte, bevor ich das Problem hatte, mit ipfire verbunden waren und es auch funktioniert hat.

MfG

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 13th, 2017, 3:48 pm
by fredym
gaminge wrote:
October 13th, 2017, 3:43 pm
Also pingen geht nicht -> Network is unreachable
Ich wollte noch anmerken dass alle aufgelisteten Geräte, bevor ich das Problem hatte, mit ipfire verbunden waren und es auch funktioniert hat.

MfG
nimm mal traceroute und sage, wie weit der "geht"
(8.8.8.8 und/oder 8.8.4.4 = google NS sollten gehen)
Namensauflösung später

Fred

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 13th, 2017, 8:08 pm
by gaminge
traceroute to 8.8.8.8 (8.8.8.8 ), 30 hops max, 60 byte packets
connect: Das Netzwerk ist nicht erreichbar

Kleines Zwischenupdate:
Ich habe IPFire auf 114 upgedated und habe versucht zwei weitere Geräten den Zugriff auf Blau zugewähren.
Zum einen ein frisch aufgesetzter RPi2 mit Volumio (war noch nie mit dem ipfire Router verbunden) und der Laptop von meinem Nachbar mit Windows 8.1.
Beim Laptop mit Windows hat alles so geklappt, wie es klappen sollte. Allerdings gibt es Probleme mit dem RPi2: Ich kann mich mit dem WLAN Netzwerk von IPFire verbinden (bekomme eine IP Adresse zugewiesen) und unter Zugriff auf Blau bei Aktuelle DHCP Zuordnungen auf Blau taucht der RPi2 auf (Mit IP-Adresse, MAC-Adresse, Hostname) aber sobald ich auf den blauen Stift klicke geschieht nichts. D.h. unter der Tabelle Geräte auf Blau taucht der RPI2 nicht auf und wie gesagt beim Laptop vom Nachbarn hat alles wunderbar funktioniert.

Deshalb muss es eigentlich an ipfire liegen und ich frage mich, ob es eine Datei gibt (auf die man zugreifen und editieren kann) in der die Geräte stehen, die Zugirff auf Blau haben ?

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 14th, 2017, 7:34 am
by Alorotom
Hallo gaminge,

"network unreachable" oder "Netzwerk nicht erreichbar" besagt eigentlich, dass die Schnittstelle offline ist. Entweder sie hat doch keine IP-Adresse bekommen oder der Link-Status ist aus anderem Grund nicht da.

Der erste Step vor ping nach draußen wäre doch eigentlich, auf dem jeweiligen Client die zugewiesenen Netzwerkparameter zu prüfen, dann mal irgendwas in BLUE anzupingen.
Statt eine IP-Adresse vom DHCP zu beziehen, könntest Du auch mal manuell eine IP-Adresse, DNS und Gateway zuweisen. Wie sieht es dann aus mit ping auf interne Geräte?

Außerdem wäre ein Blick in /var/log/messages vielleicht nützlich. Dort sollten Einträge über die DHCP-Aktivitäten drin stehen.

Gruß
Alorotom

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 14th, 2017, 5:08 pm
by gaminge
Ich habe mal mit meinem Linux Mint (kein Internet über Blau) andere Clients (Sowohl die Windows Clients als auch die Linux Clients) angepingt und es hat funktioniert. Mit ifconfig sehe ich dass ich eine IP-Adresse habe (dieselbe die auch in der Tabelle Geräte auf Blau steht)
Die log Datei (messages) werde ich mir mal demnächst genauer anschauen, aber auf dem ersten Blick habe ich keine unterschiede zwischen Windows Clients und Linux Clients entdeckt.

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 15th, 2017, 6:50 am
by Alorotom
Gut, dann geht zumindest ein bisschen was.
Prüfe bitte auch ob DNS und GW zwischen Linux- und Windows gleich zugewiesen wurden.

Als nächstes würde ich mir neben messages die iptables ansehen. Wenn es nicht doch noch mit dem Routing zu tun hat (siehe was fredym vorgeschlagen hat), wirkt es fast so, dass die allow Regeln für die unixoiden Clients nicht generiert werden.

Gruss
Alorotom

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 25th, 2017, 6:21 pm
by gaminge
Zum Punkt DNS und GW:
Bei den Windows Clients = DNS 84.200.69.80, 84.200.70.40 (sind in Grün definiert) GW = telekom router
Bei den Unix Clients = DNS IP adresse Grün GW = keine adresse

Zum Punkt /var/log/messages:
Bei den DHCP Einträgen sehe ich keine Unterschiede

Oct 15 00:16:11 ipfire dhcpd: DHCPREQUEST for 192.168.1.57 from e*:**:**:**:**:** (Windows) via blue0
Oct 15 00:16:11 ipfire dhcpd: DHCPACK on 192.168.1.57 to e*:**:**:**:**:** (Windows) via blue0
Oct 15 00:16:11 ipfire dhcpd: DHCPREQUEST for 192.168.1.57 from e*:**:**:**:**:** (Windows) via blue0
Oct 15 00:16:11 ipfire dhcpd: DHCPACK on 192.168.1.57 to e*:**:**:**:**:** via blue0

Oct 16 18:28:26 ipfire dhcpd: DHCPREQUEST for 192.168.1.53 from 9*:**:**:**:**:** (Mint) via blue0
Oct 16 18:28:26 ipfire dhcpd: DHCPACK on 192.168.1.53 to 9*:**:**:**:**:** (Mint) via blue0
Oct 16 18:28:26 ipfire dhcpd: DHCPREQUEST for 192.168.1.53 from 9*:**:**:**:**:** (Mint) via blue0
Oct 16 18:28:26 ipfire dhcpd: DHCPACK on 192.168.1.53 to 9*:**:**:**:**:** via blue0


Allerdings ist mir in dieser Datei was aufgefallen. Bei den unix-Clients finde ich folgenden Eintrag
Oct 13 21:42:33 ipfire kernel: DROP_WirelessinputIN=blue0 OUT= MAC=**:**:* SRC=192.168.1.53 DST=192.168.1.255 LEN=96 TOS=0x00 PREC=0x00 TTL=64 ID=37612 DF PROTO=UDP SPT=137 DPT=137 LEN=76

Wo kann ich die iptables einsehen bzw. wonach genau soll ich da suchen ?

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 26th, 2017, 6:26 am
by Alorotom
Hallo gaminge,
gaminge wrote:
October 25th, 2017, 6:21 pm
Bei den Unix Clients = DNS IP adresse Grün GW = keine adresse
Daraus kann zumindest ich nicht ersehen, ob die Linux-Clients DNS IPs zugewiesen bekommen, aber kein Gateway genügt schon, damit die nicht ins Internet finden. Das sie eine IP erhalten haben, reicht eben nicht.

Wie Du eingangs geschrieben hast, ist die DHCP-Verarbeitung nicht MAC-abhängig auf dem Dual-Boot Gerät zwischen Win und Linux.

Wahrscheinlich funktioniert der DHCP-Client unter Windows anders als unter Linux. Normalerweise ist das egal. Bei Dir liegt wohl eine Konstellation vor, die bei den Linux DHCP-Clients die Verarbeitung der Antwort auf den DHCP-Request verhindert oder der Request geht schon andere Wege.

Ich habe keine wirkliche Idee, was das sein soll. Aber ich stutze etwas bei "... = IP adresse Grün GW ..." in der Zeile aus dem Zitat. BLUE hat doch einen eigenen IP Adressraum. Es sollten da keine IPs aus GREEN auftauchen. Auch nicht die GREEN IP-Adresse der IPFire.

https://wiki.ipfire.org/en/addons/wireless/start

An anderer Stelle hattest Du glaube ich geschrieben, dass die Firewall von BLUE nach GREEN durchlässig konfiguriert ist. Insofern wäre mein Ansatz mit iptables --list im CLI nach möglichen regelbasierten Gründen für das Verhalten zu suchen. Zum Beispiel sollten vielleicht keine Regeln für das DHCP-Protokoll von BLUE nach GREEN existieren.

Ein weiterer Ansatz wäre, die unter BLUE Access erlaubten MACs darauf zu prüfen, ob sie für einen Linux-Client auch aktiv berücksichtigt werden. Das müsste sich eigentlich auch in iptables abbilden. Dann würden die fraglichen MACs der Linux-Clients in der iptables --list Ausgabe fehlen.

Gruß
Alorotom

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 26th, 2017, 6:39 am
by Alorotom
gaminge wrote:
October 25th, 2017, 6:21 pm
Allerdings ist mir in dieser Datei was aufgefallen. Bei den unix-Clients finde ich folgenden Eintrag
Oct 13 21:42:33 ipfire kernel: DROP_WirelessinputIN=blue0 OUT= MAC=**:**:* SRC=192.168.1.53 DST=192.168.1.255 LEN=96 TOS=0x00 PREC=0x00 TTL=64 ID=37612 DF PROTO=UDP SPT=137 DPT=137 LEN=76
DST=192.168.1.255 ist ein Broadcast in dem Subnet.
SPT=137 DPT=137 besagt, dass das ein Windows Client sein könnte, denn das ist normalerweise NetBIOS über TCP/IP.
Hätte demnach nichts mit dem DHCP-Problem zu tun.

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 27th, 2017, 3:31 pm
by gaminge
Ich muss korrigieren :
Bei den Windows Clients = DNS 84.200.69.80, 84.200.70.40 (sind in Grün definiert) GW = Blau
Bei den Unix Clients = DNS IP adresse Blau GW = keine adresse

Ich habe mal mir die Regeln mit iptables --list angeschaut
und nur evtl interessantes gefunden
Screenshot_.png

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 27th, 2017, 3:32 pm
by gaminge
Es ist ja möglich über die WebUI -> Zugriff auf Blau Geräte einmalig hinzuzufügen und dann hat das Gerät immer Zugriff auf Blau. Deshalb muss es doch eine Datei geben in der diese Geräte stehen, oder ?

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: October 30th, 2017, 8:45 am
by Alorotom
Kann Dir nicht sagen, in welcher Datei das möglicherweise steht. Meine Vermutung war, dass es sich in iptables findet.

Ansonsten probier doch

Code: Select all

find / -type f -exec grep -i "die fragliche MAC" {} \;
oder

Code: Select all

find / -type f -print0 | xargs -0 grep -i die-fragliche-MAC
wobei Du die MAC wahrscheinlich mal variieren müsstest mit der Schreibweise (ab12dc34ef56 oder ab-12-dc-34-ef-56 oder ab:12:dc:34:ef:56). Das gesamte System zu durchsuchen wird etwas dauern.

Statt bei "/" (root) anzusetzen, ggfs. mal die einzelnen Verzeichnisse angeben, da die Ausgabe sonst recht lang wird, weil grep bei binaries und bei permission denied entsprechende Fehlausgaben liefert.

Gruß
Alorotom

Re: Eigenartiges/Nerviges Problem mit dem WLAN

Posted: November 3rd, 2017, 7:54 am
by 5p9
moin,

deine DHCPs Infos zu deinen blue-Clients findest du z.B. hier:

Code: Select all

(/var/ipfire/dhcp):less dhcpd.conf
unter

Code: Select all

(/var/ipfire/dhcp):less settings
findest du die generellen Infos zu deinen Netzwerkinterfaces.

Was steht denn hier bei dir so drin?

VG, 5p9