paket zum upgraden bauen

Everything about WLan and hostap
Post Reply
thorstenk
Posts: 24
Joined: August 24th, 2010, 6:34 pm

paket zum upgraden bauen

Post by thorstenk » June 1st, 2011, 2:42 pm

Hi,

ich experimentiere gerade etwas mit compat-wireless-2.6.39.1-sn und würde gerne ein Paket daraus erstellen, welches man einfach über die bestehende IPFire-Installation drüber installieren kann.
Wie mach ich so was? Will nicht jedes mal alles neu installieren ...
Gibts da ne Anleitung für?

Danke im Voraus!


VG,

Thorsten

User avatar
Maniacikarus
Core Developer
Core Developer
Posts: 6210
Joined: February 24th, 2006, 10:35 am
Location: Nürnberg
Contact:

Re: paket zum upgraden bauen

Post by Maniacikarus » June 1st, 2011, 4:42 pm

Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: paket zum upgraden bauen

Post by Arne.F » June 2nd, 2011, 8:01 am

das compat-wireless-2.6.39 hat noch nen bug drin der den kernel als "taintet" markiert. Im next branch hab ich da einen Patch für drin. Leider hat der Maintainer bisher nicht reagiert.

Du kannst aber das test-packet von mir installieren.
stand jeweils wie im next branch. (Bisher sind da außerdem kernel 2.6.32.41, iw 0.9.22 und die aktuelle wireless-regdb drin)

Code: Select all

cd /opt/pakfire/tmp
wget http://people.ipfire.org/~arne_f/testing/next/packages/core-upgrade-2.10-next.ipfire.bz2
tar xvf core-upgrade-2.10-next.ipfire.bz2
./update.sh


Mach aber vorher Sicherheitshalber ein Backup der ganzen Platte...
Last edited by Arne.F on June 2nd, 2011, 8:05 am, edited 1 time in total.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

thorstenk
Posts: 24
Joined: August 24th, 2010, 6:34 pm

Re: paket zum upgraden bauen

Post by thorstenk » June 3rd, 2011, 10:58 am

Mein erster Eindruck von 2.6.39-1-sn ist super! Vor allem läuft der ath9k deutlich besser/endlich benutzbar im 5GhZ Bereich ...
Leider bekomme ich immer nur ein komplettes Image durch das build. Was muss ich denn im makefile von compat-wireless eintragen dass es zusatzlich als extra Paket/addon gebaut wird?

Danke im Voraus!

Thorsten

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: paket zum upgraden bauen

Post by Arne.F » June 3rd, 2011, 12:29 pm

Das ist nicht ganz so einfach. Du brachst eine Liste erstmal aller module die durch compat-wireless ersetzt werden. Diese muss als rootfile unter config/rootfiles/packages/ abgelegt werden. Es fehlen auch noch weitere Einträge im LFS um ein extra packet zu bauen. (PAK_VER, DEPS, dist: ...)

Da kernelmodule aber immer nur mit dem jeweiligen Kernel laufen gehören die nicht in ein Addon sondern zum Kernel und deshalb in ein core-update.

Wir planen eh den gesamten Kernel  bald zu updaten deshalb hab ich die module gar nicht erst rausgesucht. Du müsstest auch ein paar alte module löschen da diese nicht mehr mit dem compat-wireless laufen da sich die ordnerstruktur geändert hat. (rtl808x und iwl von intel gibt es sonst doppelt und er lädt das falsche automatisch)
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

thorstenk
Posts: 24
Joined: August 24th, 2010, 6:34 pm

Re: paket zum upgraden bauen

Post by thorstenk » June 3rd, 2011, 4:58 pm

Ok verstehe!
Und wie sieht es mit core-upgrade-datei aus. muss ich irgendwo spezifizieren was da alles rein soll, oder mach das das IPFire build-script automatisch (alles was ne höhere Versionsnummer hat als bei der letzten Version reinpacken)?


Thorsten

thorstenk
Posts: 24
Joined: August 24th, 2010, 6:34 pm

Re: paket zum upgraden bauen

Post by thorstenk » June 7th, 2011, 9:00 pm

okidoki, habs mittlerweile hinbekommen ein coreupdate-paket zu bauen ...

Post Reply