Include Noscan Patch for hostapd

Everything about WLan and hostap
Post Reply
Veti
Posts: 369
Joined: November 22nd, 2009, 9:26 am

Include Noscan Patch for hostapd

Post by Veti » February 25th, 2013, 5:00 pm

i cant get hostapd to enable 40 Mhz channels
my ht caps are
[HT40+][SHORT-GI-40][DSSS_CCK-40][TX-STBC][RX-STBC1]

in inssider after restart i can see the 300 mbit mode for a few seconds.

Apparently hostapd will disallow 40 Mhz channels of there is any traffic on the other channel.

the openwrt team has made a patch to overwrite this behavior.
this requires the option noscan=1 in the hostapd.conf to take effect.

https://dev.openwrt.org/browser/trunk/p ... ?rev=33392

is there any way we can include that patch in ipfire?

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Include Noscan Patch for hostapd

Post by Arne.F » February 27th, 2013, 12:21 pm

Apparently hostapd will disallow 40 Mhz channels of there is any traffic on the other channel.

Mormal that is the correct behaviour. You have to disable 40Mhz Mode if the other channel is already used.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Veti
Posts: 369
Joined: November 22nd, 2009, 9:26 am

Re: Include Noscan Patch for hostapd

Post by Veti » February 27th, 2013, 1:41 pm

Yes i know that you would not be conforming to the standard.

However a lot of the consumer hardware dont care about this neither and you can get 300 Mbit connections.

With the patch you have at least the same option.

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Include Noscan Patch for hostapd

Post by Arne.F » March 4th, 2013, 5:52 pm

I have checked the patch again it it does not do what you want. It disable the scan because some chips seems to have problems with the scaning. But it also disables the ht40 (40Mhz Mode) at all.
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Veti
Posts: 369
Joined: November 22nd, 2009, 9:26 am

Re: Include Noscan Patch for hostapd

Post by Veti » April 28th, 2013, 7:51 am

i found the patch that allows to force 40 mhz mode, but its not configurable.

Code: Select all

--- hostapd-0.7.3/src/ap/hw_features.c.old   2012-03-04 08:06:27.425520296 +0200
+++ hostapd-0.7.3/src/ap/hw_features.c   2012-03-04 08:10:31.776913761 +0200
@@ -441,7 +441,7 @@
    else
       oper40 = ieee80211n_check_40mhz_2g4(iface, scan_res);
    wpa_scan_results_free(scan_res);
-
+   oper40=1;
    if (!oper40) {
       wpa_printf(MSG_INFO, "20/40 MHz operation not permitted on "
             "channel pri=%d sec=%d based on overlapping BSSes",

User avatar
HectoPascal
Posts: 236
Joined: July 25th, 2011, 4:58 pm
Location: DE

Re: Include Noscan Patch for hostapd

Post by HectoPascal » October 16th, 2016, 6:11 pm

I second that. Please include the 'noscan' patch. It's very helpful for isolated environments where even the slightest outer signal prevents 40MHz modes.
In OpenWRT its triggered by HT Caps in /etc/config/wireless. I think that's an appropriate place.
Image
16GB CompactFlash (2GB root, 14GB samba, UDMA/33 mod), ext4/writeback journal, RT2870 hostap, Headless (no gfx, keyboard), VDSL

Post Reply