(gelöst) ClamAV startet nicht mehr Core124

Probleme bei der Installation?
Post Reply
ritchie
Posts: 229
Joined: January 20th, 2015, 5:43 pm

(gelöst) ClamAV startet nicht mehr Core124

Post by ritchie » October 26th, 2018, 3:32 pm

Hallo Zusammen,

ich habe gerade mein System auf Core 124 angehoben und musste jetzt feststellen, das ClamAV nicht mehr startet.

Auf der Console geprüft, kam folgende Meldung:

Code: Select all

freshclam
ClamAV update process started at Fri Oct 26 17:23:25 2018
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.100.1 Recommended version: 0.100.2
DON'T PANIC! Read https://www.clamav.net/documents/upgrading-clamav
main.cld is up to date (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
daily.cvd is up to date (version: 25068, sigs: 2134068, f-level: 63, builder: raynman)
bytecode.cld is up to date (version: 327, sigs: 91, f-level: 63, builder: neo)
Das Problem bestand wohl schon vorher, da ich diese Meldungen im Logfile entdeckt hatte:

Code: Select all

1:25:36	freshclam[17407]: 	Downloading daily-25055.cdiff [100%]
01:25:36	freshclam[17407]: 	Downloading daily-25056.cdiff [100%]
01:25:36	freshclam[17407]: 	Downloading daily-25057.cdiff [100%]
01:25:36	freshclam[17407]: 	Downloading daily-25058.cdiff [100%]
01:25:36	freshclam[17407]: 	Downloading daily-25059.cdiff [100%]
01:25:36	freshclam[17407]: 	Downloading daily-25060.cdiff [100%]
Das Kommando "/etc/init.d/clamav start" zeigt

Code: Select all

# /etc/init.d/clamav start
Starting Clamav Definition Updater...
Unable to continue: /usr/bin/freshclam is running                                                                                                                                                                                                                              
Wie kann ich das korrigieren, den scheinbar versucht ClamAV ständig ein Update via freshClam zu
fahren, was wegen der obigen Meldung wohl schief geht.

Edit:

Code: Select all

01:25:40	freshclam[17407]: 	buildcld: Can't add daily.hsb to new daily.cld - please check if there is enough disk space available
01:25:40	freshclam[17407]: 	Can't create local database
Df zeigt

Code: Select all

Filesystem     1K-blocks    Used Available Use% Mounted on
devtmpfs         2048932       4   2048928   1% /dev
tmpfs            2056060      12   2056048   1% /dev/shm
tmpfs            2056060     484   2055576   1% /run
/dev/sda3        1998672 1618420    259012  87% /
/dev/sda1          60400   44708     11108  81% /boot
/dev/sda4       54544132 1037488  50712900   3% /var
/var/lock           8192      12      8180   1% /var/lock
none             2056060      24   2056036   1% /var/log/vnstat
none             2056060   25484   2030576   2% /var/log/rrd
Kann das die Ursache sein. Wo werden diese Dateien abgelegt ?


Viele Grüße
R.
Last edited by ritchie on October 27th, 2018, 8:59 am, edited 2 times in total.
My Config & I use FHEM on this system as well
Image

Hellfire
Posts: 564
Joined: November 8th, 2015, 8:54 am

Re: ClamAV startet nicht mehr Core124

Post by Hellfire » October 26th, 2018, 6:35 pm

Hi,

hatte vor kurzem exakt das gleiche Problem und musste letztendlich die Partition vergrößern, weil ich nicht genügend freien Platz schaffen konnte.

Die Dateien finden sich in /usr/share/clamav und sollte sich in einer Standard-Installation auf sda3 befinden.

Michael
Image

ritchie
Posts: 229
Joined: January 20th, 2015, 5:43 pm

Re: ClamAV startet nicht mehr Core124

Post by ritchie » October 26th, 2018, 6:48 pm

Hallo,

Kann man das Verzeichnis auf eine andere
Partion ändern?

Wenn ja wie?

Viele Grüße R.
My Config & I use FHEM on this system as well
Image

Hellfire
Posts: 564
Joined: November 8th, 2015, 8:54 am

Re: ClamAV startet nicht mehr Core124

Post by Hellfire » October 26th, 2018, 6:53 pm

Das kann ich leider nicht beantworten, ich habe die SSD damals ausgebaut und am PC mittels GParted vergrößert und dazu gleich noch auch die boot Partition wegen aktueller Berichte über Platz Probleme beim Update.

Evtl ist dein Anliegen über SymLinks lösbar aber da bin ich zuwenig Linux Experte. Vielleicht kann hier einer von den Oldies einspringen.

Michael
Image

ritchie
Posts: 229
Joined: January 20th, 2015, 5:43 pm

Re: ClamAV startet nicht mehr Core124

Post by ritchie » October 26th, 2018, 9:14 pm

Hallo Michael,

hat die ganze Sache mit der Abänderung der Partionsgröße den problemlos funktioniert ?

GParted -> Linux oder und Windows ?

Viele Grüße
R.
My Config & I use FHEM on this system as well
Image

ritchie
Posts: 229
Joined: January 20th, 2015, 5:43 pm

Re: ClamAV startet nicht mehr Core124

Post by ritchie » October 27th, 2018, 8:58 am

Hallo Michael,

ich habe mir heute morgen einen Adapter von m-Sata auf Sata zugelegt (APC PC) und die Platte dann mittels gparted auch neu aufgeteilt.

Das ganze hat prima geklappt und mein ClamAv läuft wieder. Auch habe ich gleich alle Partionen für die Zukunft angepasst, so das ich jede Menge Platz auf Boot und anderen Partionen habe.

Vielen Dank für den Tip.

R.
Last edited by ritchie on October 28th, 2018, 10:14 am, edited 1 time in total.
My Config & I use FHEM on this system as well
Image

Hellfire
Posts: 564
Joined: November 8th, 2015, 8:54 am

Re: (gelöst) ClamAV startet nicht mehr Core124

Post by Hellfire » October 27th, 2018, 11:45 am

Perfekt würde ich sage!

Danke für die Rückmeldung!

Michael
Image

Post Reply