Suricata startet in Core 133 (wieder) nicht mehr

Probleme bei der Installation?
Post Reply
wildgunman
Posts: 12
Joined: August 26th, 2015, 1:36 pm

Suricata startet in Core 133 (wieder) nicht mehr

Post by wildgunman » June 15th, 2019, 7:05 am

Hallo,

habe gerade auf Core 133 aktualisiert und das IPS startet nun nicht mehr. In messages Log wird aber kein Fehler angezeigt. Auch habe ich die 133 nochmal drüber installiert - allerdings keine Besserung.

Wenn ich manuell starten möchte, erscheint diese Meldung:

/usr/bin/suricata -c /etc/suricata/suricata.yaml -i red0
/usr/bin/suricata: error while loading shared libraries: libjansson.so.4: cannot open shared object file: No such file or directory

Edit: Ich habs hinbekommen... über die Konsole einfach "pakfire install jansson" eingeben bzw. installieren und dann startet suricata.

Grüße Chris
Last edited by wildgunman on June 15th, 2019, 4:29 pm, edited 1 time in total.
Image

doc
Posts: 153
Joined: June 5th, 2014, 12:33 pm
Location: Hannover

Re: Suricata startet in Core 133 (wieder) nicht mehr

Post by doc » June 15th, 2019, 12:52 pm

libjansson sollte IMHO fest zum System gehören und nicht als Addon installiert werden müssen, zumal es sich auch mehr um eine Library als um ein Programm handelt.
Image

User avatar
Arne.F
Core Developer
Core Developer
Posts: 8522
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Suricata startet in Core 133 (wieder) nicht mehr

Post by Arne.F » June 15th, 2019, 8:43 pm

Da fehlte das neue libjansson im core. Ich hab das heute neu hochgeladen. Auch der fehler in der vpnmain.cgi ist behoben. Also installier das jetzt nochmal...
Arne

Support the project on the donation!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Post Reply