APU2 keyboard problem during install [solved]

Post Reply
erikvl
Posts: 16
Joined: April 9th, 2018, 9:14 am

APU2 keyboard problem during install [solved]

Post by erikvl » May 21st, 2019, 12:49 pm

This was solved in another thread. Apparently flow control needs to be disabled for IsoLinux.

===================================

I was having a problem with the keyboard running the ISO from a USB drive on an APU2d4, using putty. I haven't figured out how to fix it yet, but a work around was to connect a USB keyboard directly to the APU2. This allowed me to select serial setup, after which I could control the installation via putty again.

I had dd'ed the latest ISO to a flash drive. It checked out fine and the APU2d4 booted into the isolinux menu. However, at that point it stopped responding to the keyboard. The output was strange too. The menu entries were displayed with all characters repeated. See attached screenshot.

It seems the BIOS and IsoLinux do not get along. The double characters are caused by the BIOS doing serial redirection, which causes both the serial and VGA output to be sent to putty. With newer BIOS'es this can be disabled in setup.

That does not fix the keyboard issue though. Maybe someone else has solution?


screenshot ipfire.png

Post Reply