Owncloud bei Core Update 118

Post Reply
andibgl
Posts: 3
Joined: November 25th, 2017, 8:47 am

Owncloud bei Core Update 118

Post by andibgl » February 7th, 2018, 11:58 am

Hallo Forum,
seit Core Update 118 funktioniert bei mir Owncloud nicht mehr.
Bis 117 war alles in Ordnung.
Wenn ich versuche, mich unter Port 1011 einzuloggen, kommt im Browser die Fehlermeldung dass mit PHP 7 mindestens Owncloud 8.2 installiert sein muss.
Kann es sein, dass mit Update 118 ein php-Update auf Version 7 erfolgte und damit das in der Distribution enthaltene Owncloud 7 (bei mir installiert) nicht mehr funktioniert?
Ich finde auch im Pakfire keine Auswahl für Owncloud mehr, weder in der Liste der installierten Add-ons noch in der Liste der installierfähigen.
Was kann ich machen um Owncloud wieder zum Laufen zu bekommen?
Im Moment würde mir nur die Neuinstallation von ipfire 117 einfallen und den Update auf 118 würde ich nicht machen.
Gruß,
Andi

andibgl
Posts: 3
Joined: November 25th, 2017, 8:47 am

Re: Owncloud bei Core Update 118

Post by andibgl » February 7th, 2018, 1:53 pm

Hi zusammen,
das:
https://planet.ipfire.org/post/ipfire-2 ... or-testing
erklärt so manches...
Leider ist das Core Update bei mir nun drauf und es gibt kein "einfaches" zurück, oder?
Damit bin ich wohl gezwungen für meine Cloud-Lösung einen eigenen Server zu spendieren oder gibt es (künftig) in ipfire Möglichkeiten für eine Cloud-Lösung (nextcloud, ...)?
Gruß,
Andi

G666
Posts: 44
Joined: March 24th, 2016, 10:41 am

Re: Owncloud bei Core Update 118

Post by G666 » February 7th, 2018, 1:54 pm

Hallo,
ich glaube das geht auch nicht mehr. Wenn ich das richtig verstanden haben ist bei Core 118 PHP und auch owncloud weggefallen.

"Add-ons that have also been dropped: cacti, openmailadmin, phpSANE, nagios because icinga is available, nagiosql, mediatomb, owncloud"
Image

DJ-Melo
Posts: 373
Joined: July 8th, 2014, 7:12 am

Re: Owncloud bei Core Update 118

Post by DJ-Melo » February 7th, 2018, 2:52 pm

https://planet.ipfire.org/post/ipfire-2 ... most-there

"PHP is being removed for security reasons and for more and more of the software that we ship becoming independent from it. If you have installed any custom applications that use PHP, please move them to another machine."

User avatar
Arne.F
Core Developer
Core Developer
Posts: 7935
Joined: May 7th, 2006, 8:57 am
Location: BS <-> NDH
Contact:

Re: Owncloud bei Core Update 118

Post by Arne.F » February 9th, 2018, 8:14 am

For owncloud apply the same security concerns. Owncloud 7 was outdated and is not supported by the owncloud team anymore. Newer owncloud versions need newer php but we don't have found a maintainer that want update php in future so we had to drop it.

If your system support virtualisation in hardware you should try libvirt and a actual own- or nextcloud installation in a vm.
Arne

Support the project on the IPFire whishlist!

Image

Image

Image
PS: I will not answer support questions via email and ignore IPFire related messages on my non IPFire.org mail addresses.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest