Page 1 of 1

Amavisd IPfire 2.21 core 130

Posted: May 15th, 2019, 2:30 pm
by firerookie
Hallo an die Fachwelt hier.
ich habe auf den IPFire gewechselt und hatte bis vor kurzem noch den IPCOP im Einsatz.
Die Weiterentwicklung schaut nicht schlecht aus ist aber noch etwas unausgegoren.
Was mir sehr gefällt ist der Pakfire, abergenau da funkt nicht alles wie es soll.

Ich hatte den mailfix, clamav, spamassin etc. installiert, aber leider bringe ich amavisd nicht zu laufen, dem fehlt eine libidn.
Schade dachte ich, nun ja installiere ich nach ... nun will die libidn auch CC drauf haben um zu compilieren ... was mich sehr stutzig werden lies.
Ich denke auf einem Router haben Entwicklungsumgebungen nichts zu suchen, das Teil soll ja sicher sein, und schön wäre es jetzt wenn die libidn mit dem amavisd paket mitkommen würde.
Die Compilierung scheint ja nur notwendig zu sein weil es für die Umgebung von IPFire wohl keine fertige gibt?
Wenn es eine fertige libidn für IPFire gibt, wo bekomme ich die her?

Danke im voraus
Gruß
Reinhard

Re: Amavisd IPfire 2.21 core 130

Posted: May 15th, 2019, 2:45 pm
by DJ-Melo

Re: Amavisd IPfire 2.21 core 130

Posted: May 16th, 2019, 7:13 am
by firerookie
Hallo DJ
danke für die Links,
doch leider führen die nicht wirklich weiter weil diese nicht funktionieren oder beantworten meine Fragen.

Re: Amavisd IPfire 2.21 core 130

Posted: May 16th, 2019, 7:18 am
by DJ-Melo
Hi,

ich würde das verlinkte addon paket des user Gocart nutzen welches nicht über Pakfire kommt
Achtung:
Die Aktualisierung dieses Addons erfolgt immer über die Aktualisierung dieses Installers. Über Pakfire werden derzeit nur veraltete Pakete bereit gestellt. Sollte es doch zur Installation des alten Postfix sowie Amavisd aus dem Pakfire kommen, wird die Installation zerschossen. Dies kann aber durch ein erneutes vollständiges Ausführen des Installers einfach repariert werden.

Re: Amavisd IPfire 2.21 core 130

Posted: May 16th, 2019, 7:24 am
by firerookie
Hallo DJ
Dankeschön für den Tip, das werde ich mal probieren.
Ich bin nur etwas erstaunt, das bei IPFire sich diesbezüglich wohl nichts richtig standardisiert hat.
Nun ja es sind eben die ersten Gehversuche mit IPFire ... und bekanntlich sitzt das Problem vor dem PC ;D

Re: Amavisd IPfire 2.21 core 130

Posted: May 16th, 2019, 7:27 am
by DJ-Melo
das eine ist was IPfire selbst mitbringt das andere was die Community selber draus macht es darf sich ja gerne jeder einbringen.

Re: Amavisd IPfire 2.21 core 130

Posted: May 16th, 2019, 8:03 am
by Arne.F
Normal solte es eine libidn geben. Welche Version sucht denn amavisd?

Aktuell in core131 ist libidn.so.11.6.18

Re: Amavisd IPfire 2.21 core 130

Posted: August 13th, 2019, 12:41 pm
by p.weise
Habe unter Core 134 das selbe bzw ein ähnliches Problem. in der Fehlermeldung wird gesagt das die LibIDN fehlt und deshalb startet amavisd nicht. Gibt es dafür vll. eine Lösung?

Re: Amavisd IPfire 2.21 core 130

Posted: August 13th, 2019, 4:23 pm
by FischerM
Hi,

libidn sollt IMHO bei einer Standardinstallation mit dabei sein.

Werden die libs ev. an der falschen Stelle gesucht?

Was sagt ein:

Code: Select all

find / -name libidn* -ls
Gruß,
Matthias

Re: Amavisd IPfire 2.21 core 130

Posted: August 13th, 2019, 7:12 pm
by Arne.F
Da fehlt das perl Modul. Das hat Peter vergessen...

https://bugzilla.ipfire.org/show_bug.cgi?id=12138

Re: Amavisd IPfire 2.21 core 130

Posted: August 14th, 2019, 7:33 am
by p.weise
Habe die Dateien libidn.11.6.18, libidn.so.11 und libidn.so gefunden weiß jetzt aber nicht was ich mit diesen anfangen soll. Sollen die unter /usr/lib liegen oder müssen die woanders hin?

Re: Amavisd IPfire 2.21 core 130

Posted: August 14th, 2019, 8:42 am
by Arne.F
Es fehlt nicht die Lib sondern ein Modul für Perl (Net::LibIDN).

Re: Amavisd IPfire 2.21 core 130

Posted: August 14th, 2019, 2:21 pm
by p.weise
und wo finde ich das modul. das müsste doch eigentlich mit einem der addons installiert worden sein?
folgende sind installiert: perl-net-ip, perl-common-sense, perl-inotify2

Re: Amavisd IPfire 2.21 core 130

Posted: August 14th, 2019, 3:43 pm
by Arne.F
GenAu deshalb hab ich den Bug im Bugtracker erstellt. Das Addon gibts nicht, daher kann man es auch nicht Installieren.
Peter hat Amavisd aktualisiert aber das Perl Modul nicht als Addon gebaut...