Problems update Guardian 2.0.2

Questions to IPFire Addons.
Mentalic
Posts: 9
Joined: April 14th, 2018, 2:51 pm

Re: Problems update Guardian 2.0.2

Post by Mentalic » December 30th, 2018, 3:25 pm

Think I found the fix to this. After many uninstalls reinstalls, service stop and starts with no success in getting guardian working again.. Until in Guardian Configuration interface, I set "monitor snort alert file" to OFF, then save setting, then set "monitor snort alert file" to ON and save setting. Been working ever since.

Initially when I did the packfire update from 125 to 126 Guardian worked, but later clean installs of IPfire all resulted in guardian not working. Something wrong somewhere. ;)
Image

User avatar
Roberto Peña
Posts: 675
Joined: July 16th, 2014, 3:56 pm
Location: Bilbao (España)
Contact:

Re: Problems update Guardian 2.0.2

Post by Roberto Peña » December 30th, 2018, 5:18 pm

YES, It´s works OK.

Thanks Mentalic for this!!!. O0

When Bugzilla works (it looks like it is down), I report it.

Greetings.
Image
Image

User avatar
Deepcuts
Posts: 459
Joined: March 1st, 2016, 3:18 pm
Location: Romania

Re: Problems update Guardian 2.0.2

Post by Deepcuts » December 30th, 2018, 9:52 pm

Mentalic wrote:
December 30th, 2018, 3:25 pm
Think I found the fix to this. After many uninstalls reinstalls, service stop and starts with no success in getting guardian working again.. Until in Guardian Configuration interface, I set "monitor snort alert file" to OFF, then save setting, then set "monitor snort alert file" to ON and save setting. Been working ever since.

Initially when I did the packfire update from 125 to 126 Guardian worked, but later clean installs of IPfire all resulted in guardian not working. Something wrong somewhere. ;)
Indeed, this is a bug in 126.
This fix works for me.
Image
Image

JonM
Posts: 74
Joined: August 4th, 2017, 5:49 pm
Location: US

Re: Problems update Guardian 2.0.2

Post by JonM » December 30th, 2018, 11:09 pm

Mentalic wrote:
December 30th, 2018, 3:25 pm
Think I found the fix to this. After many uninstalls reinstalls, service stop and starts with no success in getting guardian working again.. Until in Guardian Configuration interface, I set "monitor snort alert file" to OFF, then save setting, then set "monitor snort alert file" to ON and save setting. Been working ever since.
This worked for me also! Thank you Mentalic! ;D
Production:
Image

Testing Raspi 3B+ (highly-experimental/rpi-crash):
Image

qiller
Posts: 64
Joined: July 27th, 2014, 3:21 pm

Re: Problems update Guardian 2.0.2

Post by qiller » December 31st, 2018, 8:58 am

Worked 4 me too, but after a reboot i got the same problem again. Perhaps a timing problem with certain configurations?

User avatar
Deepcuts
Posts: 459
Joined: March 1st, 2016, 3:18 pm
Location: Romania

Re: Problems update Guardian 2.0.2

Post by Deepcuts » December 31st, 2018, 12:27 pm

Today my IPFIre crashed hard for some reason.
I had to reinstall from scratch.
After enabling IDS on red, selecting some rules and clicking save, the rules setup is not saved. I guess this goes deeper than just Guardian.
Using sourcefire VRT for registered users.
Repeated several times, same result.
Image
Image

User avatar
Roberto Peña
Posts: 675
Joined: July 16th, 2014, 3:56 pm
Location: Bilbao (España)
Contact:

Re: Problems update Guardian 2.0.2

Post by Roberto Peña » December 31st, 2018, 1:49 pm

I can´t report by Bugzilla, because is down.
Bugzilla error.jpg
Grettings and happy new year!!!.
Image
Image

Mentalic
Posts: 9
Joined: April 14th, 2018, 2:51 pm

Re: Problems update Guardian 2.0.2

Post by Mentalic » December 31st, 2018, 4:01 pm

Looks like there are additional problems with Guardian/intrusion detection because I experienced a number of odd things last night while trying to tune my setup.

-Intrusion detection filter check box's selections disappear by themselves yet I suspect there still active because memory load did not change.
-Altering Intrusion filter selection resulted in several "white screen" crashes.
-Guardian blocked hosts list cleared itself.
-At one point Guardian stopped blocking again, did the snort file on/off/on and it worked again.

Uninstalled Guardian last night and about to do a clean install without it until this gets sorted out.
Image

Bradh
Posts: 3
Joined: December 22nd, 2010, 2:02 am

Re: Problems update Guardian 2.0.2

Post by Bradh » January 2nd, 2019, 12:43 am

I am also seeing this problem on several i586 installs. Have not seen problem with any of my x86_64 installs.

I now see why I had no problems with x86_64 installs. They hadn't taken the Guardian 2.0.2 update yet. That is what breaks Guardian.

User avatar
Roberto Peña
Posts: 675
Joined: July 16th, 2014, 3:56 pm
Location: Bilbao (España)
Contact:

Re: Problems update Guardian 2.0.2

Post by Roberto Peña » January 25th, 2019, 12:56 pm

Good morning to everybody.

I am sorry to report that with the test version 127, the problem is not solved. You have to do what Mentalic says every time IPFire starts.

Greetings.
Image
Image

DJ-Melo
Posts: 392
Joined: July 8th, 2014, 7:12 am

Re: Problems update Guardian 2.0.2

Post by DJ-Melo » January 25th, 2019, 1:08 pm

bugzilla is back online pls report a bug

User avatar
Roberto Peña
Posts: 675
Joined: July 16th, 2014, 3:56 pm
Location: Bilbao (España)
Contact:

Re: Problems update Guardian 2.0.2

Post by Roberto Peña » January 25th, 2019, 1:14 pm

Good Morning DJ-Melo.

It is already reported:

https://bugzilla.ipfire.org/show_bug.cgi?id=11954

Regards.
Image
Image

nazmul
Posts: 1
Joined: May 12th, 2016, 6:14 am

Re: Problems update Guardian 2.0.2

Post by nazmul » February 7th, 2019, 2:37 pm

Hello,

I have Guardian installed and service is running. But I cant see Guardian Interface under intrusion detection . I am using IPFire 2.21 (x86_64) - Core Update 127. I have faced the same in update 126 too. I have tried several uninstall & reinstall, but no luck.

Regards

Nazmul

callifo
Posts: 29
Joined: September 30th, 2013, 4:14 pm

Re: Problems update Guardian 2.0.2

Post by callifo » February 10th, 2019, 3:00 am

Same as above, 127 still has this issue present. Running IPFire 2.21 (i586) - core127
Image

Post Reply