Unable to remotely access OpenVPN on IPFire VM

Post Reply
dwpZN
Posts: 2
Joined: June 14th, 2018, 12:54 pm

Unable to remotely access OpenVPN on IPFire VM

Post by dwpZN » June 14th, 2018, 3:05 pm

Do forgive this my first post if already solved by others.

I was able to use a Debian VM and create an OpenVPN out of it. Remotely accessed with simple security in connecting to it.
Used the below as my reference.
http://danscourses.com/install-openvpn- ... ne-page-1/

I've now set up IPFire in a VM and wanted to set up its OpenVPN feature to do the same. Be able to access my environment remotely.
https://devops.profitbricks.com/tutoria ... -warriors/

Using the above link and setting my VM up like in the first scenario i hope to achieve the same. But am unable to connect to it remotely. I'm probably not doing a few things on my physical router or in the configuration of OpenVPN on this IPFire system but i really could use your help.

Any info i am to share please do let me know.

Thank you.

My log from an attempt.
Wed Jun 13 22:14:08 2018 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Wed Jun 13 22:14:08 2018 Need hold release from management interface, waiting...
Wed Jun 13 22:14:09 2018 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Wed Jun 13 22:14:09 2018 MANAGEMENT: CMD 'state on'
Wed Jun 13 22:14:09 2018 MANAGEMENT: CMD 'log all on'
Wed Jun 13 22:14:09 2018 MANAGEMENT: CMD 'echo all on'
Wed Jun 13 22:14:09 2018 MANAGEMENT: CMD 'bytecount 5'
Wed Jun 13 22:14:09 2018 MANAGEMENT: CMD 'hold off'
Wed Jun 13 22:14:09 2018 MANAGEMENT: CMD 'hold release'
Wed Jun 13 22:14:11 2018 MANAGEMENT: CMD 'password [...]'
Wed Jun 13 22:14:11 2018 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Wed Jun 13 22:14:11 2018 Outgoing Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Wed Jun 13 22:14:11 2018 Incoming Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Wed Jun 13 22:14:11 2018 WARNING: normally if you use --mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1400)
Wed Jun 13 22:14:11 2018 MANAGEMENT: >STATE:1528920851,RESOLVE,,,,,,
Wed Jun 13 22:14:11 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]"myphysicalrouter":1198
Wed Jun 13 22:14:11 2018 Socket Buffers: R=[65536->65536] S=[64512->64512]
Wed Jun 13 22:14:11 2018 UDP link local: (not bound)
Wed Jun 13 22:14:11 2018 UDP link remote: [AF_INET]"myphysicalrouter":1198
Wed Jun 13 22:14:11 2018 MANAGEMENT: >STATE:1528920851,WAIT,,,,,,
Wed Jun 13 22:14:47 2018 SIGTERM[hard,] received, process exiting

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest