URL Filter Not Working

General questions.
Post Reply
uzidesign
Posts: 4
Joined: July 10th, 2018, 9:30 am

URL Filter Not Working

Post by uzidesign » July 10th, 2018, 9:40 am

* transparent proxy enabled

Hi all,

I install IPfire on apu4b4. but the apu4b4 it's not my router (the reason is that I have 1G fiver and when I'm using IPfire as router the speed drop to around 500mb)
So I let the router to connect (PPPoE) add then The IPfire comes.
Router -> IPfire -> computers

The problem is when I do that, the URL filter not working / blocking.

What can I do?

Best Regards,
Oz

Aurien
Posts: 31
Joined: April 21st, 2015, 7:56 am

Re: URL Filter Not Working

Post by Aurien » July 10th, 2018, 10:27 am

Need more details on how your network is setup. Is the Router connection to IPFire on a RED network and the Computer on a GREEN network? This is how you'll have to have IPFire setup for URL filtering to work.

Router IPFire Computer
Image

uzidesign
Posts: 4
Joined: July 10th, 2018, 9:30 am

Re: URL Filter Not Working

Post by uzidesign » July 10th, 2018, 2:00 pm

Yes. this is my network setup Router IPFire Computer.

nslookup
Default Server: ipfire.localdomain
Address: 192.168.10.254
T1.JPG
T2.JPG
T3.JPG

TimF
Posts: 37
Joined: June 10th, 2017, 7:27 pm

Re: URL Filter Not Working

Post by TimF » July 10th, 2018, 5:03 pm

My understanding is that the transparent proxy will not work for https connections - which is the majority of connections these days. It's a function of the way that https works. This means that the URL filter doesn't work.

donaldo
Posts: 154
Joined: March 21st, 2013, 9:55 am

Re: URL Filter Not Working

Post by donaldo » July 11th, 2018, 7:12 am

Hi

but if we redirect the port 80 to the 443 of the proxy?
it Can Work?
it is possible to make a setting like this in the proxy setting?

Thanks
Donatello

uzidesign
Posts: 4
Joined: July 10th, 2018, 9:30 am

Re: URL Filter Not Working

Post by uzidesign » July 11th, 2018, 7:19 am

But it's not working for http connections also.

donaldo
Posts: 154
Joined: March 21st, 2013, 9:55 am

Re: URL Filter Not Working

Post by donaldo » July 11th, 2018, 7:22 am

are you sure?

facebook work only on https connection

uzidesign
Posts: 4
Joined: July 10th, 2018, 9:30 am

Re: URL Filter Not Working

Post by uzidesign » July 11th, 2018, 7:52 am

Facebook in the custom block for testing Only.
See above in the Filter settings, I have selected URL filters by groups also.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests